A qualquer momento, você pode selecionar Atualizar para atualizar os dados das Tabelas Dinâmicas em sua pasta de trabalho. Você pode atualizar os dados para Tabelas Dinâmicas importadas do Power Query, como um banco de dados (SQL Server, Oracle, Access e assim por diante), um cubo do Analysis Services, um feed de dados e várias outras fontes. Você também pode atualizar dados de uma tabela do Excel, que inclui automaticamente todas as alterações em sua fonte de dados externa.
Em versões mais antigas do Excel, as Tabelas Dinâmicas não são atualizadas automaticamente, mas você pode especificar que a Tabela Dinâmica seja atualizada automaticamente quando você abrir a pasta de trabalho que contém a Tabela Dinâmica. Em versões mais recentes do Excel, as Tabelas Dinâmicas podem ser atualizadas automaticamente quando conectadas a dados de pastas de trabalho locais.
Observação
A Atualização Automática de Tabela Dinâmica está atualmente disponível para participantes do programa Microsoft 365 Insider.
Atualizar manualmente
Selecione a Tabela Dinâmica para exibir a guia Análise de Tabela Dinâmica .
Selecione
Atualizar Tudo no grupo Dados ou pressione Alt+F5.
Dica
Clique com o botão direito do mouse na Tabela Dinâmica e selecione Atualizar.
Para atualizar todas as Tabelas Dinâmicas na pasta de trabalho de uma só vez, na guia Análise de Tabela Dinâmica , selecione a seta Atualizar e escolha
Atualizar Tudo.
Se a atualização demorar mais do que o esperado, na guia Análise de Tabela Dinâmica, selecione a seta Atualizar e escolha Atualizar Status para marcar o status da atualização.
Para parar de atualizar, selecione Cancelar Atualização.
Se as larguras das colunas e a formatação das células dos dados se ajustarem quando você atualizar os dados da Tabela Dinâmica e você não quiser que isso aconteça, verifique se as seguintes opções estão marcadas:
- Na guia Análise de Tabela Dinâmica , selecione
Opções.
- Na guia Layout e Formato, marque as caixas Ajustar automaticamente a largura das colunas ao atualizar e Preservar a formatação da célula ao atualizar.
Atualizar os dados automaticamente ao abrir a pasta de trabalho
- Selecione a Tabela Dinâmica para exibir a guia Análise de Tabela Dinâmica na faixa de opções.
- Selecione
Opções.
- Na guia Dados, marque a caixa Atualizar dados ao abrir o arquivo.
Atualizar dados automaticamente
As novas Tabelas Dinâmicas criadas com base em dados de pastas de trabalho locais terão a Atualização Automática ativada por padrão.
Observação
Se a pasta de trabalho contiver Tabelas Dinâmicas existentes com a Atualização Automática desativada, todas as novas Tabelas Dinâmicas que usem os mesmos dados de origem também terão a Atualização Automática desativada.
Há duas maneiras de ativar ou desativar a Atualização Automática: através da guia Análise de Tabela Dinâmica ou pelas Opções da Tabela Dinâmica.
Importante
A atualização automática é definida por fonte de dados, portanto, ativá-la ou desativá-la afeta todas as tabelas dinâmicas conectadas a essa fonte de dados.
Na guia Análise de Tabela Dinâmica:
- Selecione a Tabela Dinâmica para exibir a guia Análise de Tabela Dinâmica .
- Selecione
Atualização automática no grupo Dados para ativá-lo ou desativá-lo. A atualização automática estará ativada se o botão tiver um contorno ao redor.
Em Opções de Tabela Dinâmica:
- Selecione a Tabela Dinâmica para exibir a guia Análise de Tabela Dinâmica .
- Selecione
Opções.
- Na guia Dados, marque ou desmarque Atualizar automaticamente quando a fonte de dados for alterada.
Dica
Para alterar a configuração de Atualização Automática padrão das novas Tabelas Dinâmicas: Vá paraOpções> de Arquivo> Opçõesde>Dados de Dados e selecione Editar Layout Padrão. Na caixa de diálogo Opções da Tabela Dinâmica , abra a guia Dados e desmarque Atualizar automaticamente quando os dados de origem forem alterados.
Atualizar manualmente
Selecione a Tabela Dinâmica para mostrar a guia Tabela Dinâmica na faixa de opções.
Selecione a seta para baixo Atualizar Tudo no grupo de dados e escolha Atualizar.
Dica
Clique com o botão direito do mouse na Tabela Dinâmica e selecione Atualizar.
Para atualizar todas as Tabelas Dinâmicas na pasta de trabalho de uma só vez, na guia Tabela Dinâmica , selecione Atualizar Tudo.
Impedir que as larguras das colunas se ajustem
Se as larguras das colunas dos dados se ajustarem quando você atualizar os dados da Tabela Dinâmica e você não quiser que isso aconteça, verifique se a seguinte opção está marcada:
Na guia Tabela Dinâmica , selecione
Configurações.
Dica
Talvez seja necessário selecionar Mostrar na faixa de opções para acessar Configurações.
No painel Configurações da Tabela Dinâmica à direita, selecione Ajustar automaticamente as larguras das colunas ao atualizar em Classificar e exibir.
Atualizar os dados automaticamente ao abrir a pasta de trabalho
Na guia Tabela Dinâmica , selecione
Configurações.
Dica
Talvez seja necessário selecionar Mostrar na faixa de opções para acessar Configurações.
No painel Configurações da Tabela Dinâmica à direita, selecione Atualizar dados ao abrir arquivo.
Atualizar dados automaticamente
As novas Tabelas Dinâmicas criadas com base em dados de pastas de trabalho locais terão a Atualização Automática ativada por padrão.
Observação
Se a pasta de trabalho contiver Tabelas Dinâmicas existentes com a Atualização Automática desativada, todas as novas Tabelas Dinâmicas que usem os mesmos dados de origem também terão a Atualização Automática desativada.
Há duas maneiras de ativar ou desativar a Atualização Automática: pela guia Tabela Dinâmica ou pelo painel Configurações da Tabela Dinâmica .
Importante
A atualização automática é definida por fonte de dados, portanto, ativá-la ou desativá-la afeta todas as tabelas dinâmicas conectadas a essa fonte de dados.
Na guia Tabela Dinâmica:
- Selecione a Tabela Dinâmica para mostrar a guia Tabela Dinâmica na faixa de opções.
- Selecione
Atualização automática para ativá-lo ou desativá-lo. A atualização automática estará ativada se o botão tiver um contorno ao redor.
Em configurações da Tabela Dinâmica:
- Na guia Tabela Dinâmica , selecione
Configurações.
- No painel Configurações da Tabela Dinâmica no lado direito, vá para a seção Atualizar e salvar e marque ou desmarque Atualizar dados automaticamente.
Atualizar manualmente
Selecione a Tabela Dinâmica para exibir a guia Análise de Tabela Dinâmica .
Selecione
Atualizar.
Dica
Você pode pressionar a tecla Control pressionada na Tabela Dinâmica e selecionar Atualizar.
Para atualizar todas as Tabelas Dinâmicas na pasta de trabalho de uma só vez, na guia Análise de Tabela Dinâmica , selecione a seta Atualizar e escolha
Atualizar Tudo.
Se a atualização demorar mais do que o esperado, na guia Análise de Tabela Dinâmica, selecione a seta Atualizar e escolha Atualizar Status para marcar o status da atualização.
Para parar de atualizar, selecione Cancelar Atualização.
Se as larguras das colunas e a formatação das células dos dados se ajustarem quando você atualizar os dados da Tabela Dinâmica e você não quiser que isso aconteça, verifique se as seguintes opções estão marcadas:
- Selecione a Tabela Dinâmica para exibir a guia Análise de Tabela Dinâmica .
- Selecione Opções e, em seguida, Opções novamente.
- Na guia Layout , selecione as caixas Ajustar automaticamente as larguras das colunas na atualização e Preservar a formatação da célula nas caixas de atualização .
Atualizar os dados automaticamente ao abrir a pasta de trabalho
- Selecione a Tabela Dinâmica para exibir a guia Análise de Tabela Dinâmica .
- Selecione Opções e, em seguida, Opções novamente.
- Na guia Dados , selecione Atualizar dados ao abrir o arquivo.
Atualizar dados automaticamente
As novas Tabelas Dinâmicas criadas com base em dados de pastas de trabalho locais terão a Atualização Automática ativada por padrão.
Observação
Se a pasta de trabalho contiver Tabelas Dinâmicas existentes com a Atualização Automática desativada, todas as novas Tabelas Dinâmicas que usem os mesmos dados de origem também terão a Atualização Automática desativada.
Há duas maneiras de ativar ou desativar a Atualização Automática: através da guia Análise de Tabela Dinâmica ou da caixa de diálogo Opções da Tabela Dinâmica .
Importante
A atualização automática é definida por fonte de dados, portanto, ativá-la ou desativá-la afeta todas as tabelas dinâmicas conectadas a essa fonte de dados.
Na guia Análise de Tabela Dinâmica:
- Selecione a Tabela Dinâmica para exibir a guia Análise de Tabela Dinâmica .
- Selecione
Atualização automática para ativá-lo ou desativá-lo. A atualização automática estará ativada se o botão tiver um contorno ao redor.
Em Opções de Tabela Dinâmica:
- Selecione a Tabela Dinâmica para exibir a guia Análise de Tabela Dinâmica .
- Selecione
Opções.
- Selecione a guia Dados e marque ou desmarque Atualizar automaticamente quando a fonte de dados for alterada.
Importante
A Tabela Dinâmica no iPad está disponível para clientes que usam o Excel no iPad versão 2.82.205.0 e posterior. Para acessar esse recurso, certifique-se de que seu aplicativo esteja atualizado para a versão mais recente na App Store.
Toque em qualquer lugar na Tabela Dinâmica para mostrar para a guia Tabela Dinâmica na faixa de opções e toque em Atualizar.
Como alternativa, você pode pressionar e segurar uma célula em qualquer lugar no intervalo da Tabela Dinâmica e tocar em Atualizar.
Precisa de mais ajuda?
Você sempre pode consultar um especialista na Excel Tech Community ou obter suporte nas Comunidades.