Criar, carregar ou editar uma consulta no Excel (Consulta do Power)

Criar, carregar ou editar uma consulta no Excel (Consulta do Power)

A Consulta do Power oferece várias maneiras de criar e carregar consultas do Power em sua agenda de trabalho. Você também pode definir as configurações de carga de consulta padrão na janela Opções de Consulta.   

Dica      Para saber se os dados em uma planilha são moldados pela Consulta do Power, selecione uma célula de dados e, se a guia Faixa de Opções de contexto de consulta for exibida, os dados serão carregados da Consulta do Power. 

Selecionar uma célula em uma consulta para revelar a guia Consulta

Saiba em qual ambiente você está O Power Query é bem integrado à interface do usuário Excel, especialmente quando você importa dados, trabalha com conexões e edita tabelas dinâmicas, tabelas Excel e intervalos nomeados. Para evitar confusão, é importante saber em qual ambiente você está atualmente, Excel ou Power Query, a qualquer momento.

A planilha Excel familiar, faixa de opções e grade

A faixa de opções do Editor de Consulta do Power e a visualização de dados 

Uma planilha Excel típica Um exibição típico do Editor de Consultas do Power

Por exemplo, manipular dados em uma planilha Excel é fundamentalmente diferente do Power Query. Além disso, os dados conectados que você vê em uma planilha Excel, podem ou não ter o Power Query funcionando nos bastidores para moldar os dados. Isso só ocorre quando você carrega os dados para uma planilha ou modelo de dados da Consulta do Power.

Renomear guias de planilha    É uma boa ideia renomear as guias de planilha de forma significativa, especialmente se você tiver muitas delas. É particularmente importante esclarecer a diferença entre uma planilha de dados e uma planilha carregada do Editor de Consultas do Power. Mesmo que você tenha apenas duas planilhas, uma com uma tabela Excel, chamada Sheet1, e a outra uma consulta criada importando essa tabela Excel, chamada Table1, é fácil de confundir. É sempre uma boa prática alterar os nomes padrão das guias de planilha para nomes que fazem mais sentido para você. Por exemplo, renomeie Sheet1 para DataTable e Table1 para QueryTable. Agora está claro qual guia tem os dados e qual guia tem a consulta.

Você pode criar uma consulta a partir de dados importados ou criar uma consulta em branco.

Criar uma consulta a partir de dados importados

Essa é a maneira mais comum de criar uma consulta.

  1. Importar alguns dados. Para obter mais informações, consulte Import data from external data sources.

  2. Selecione uma célula nos dados e selecione Consulta > Editar.

Criar uma consulta em branco

Talvez você queira começar do zero. Há duas maneiras de fazer isso.

  • Selecione Dados> Obter dados >de outras fontes > consulta em branco.

  • Selecione Dados> Obter Dados > Iniciar o Editor de Consulta do Power.

Neste ponto, você pode adicionar manualmente etapas e fórmulas se conhecer bem a linguagem de fórmula power query M.

Ou você pode selecionar Home e, em seguida, selecionar um comando no grupo Nova Consulta. Siga um destes procedimentos:

  • Selecione Nova Fonte para adicionar uma fonte de dados. Este comando é exatamente como o comando Data> Obter Dados na faixa Excel faixa de opções.

  • Selecione Fontes Recentes para selecionar a partir de uma fonte de dados com a que você tem trabalhado. Este comando é exatamente como o comando Data> Fontes Recentes na faixa Excel faixa de opções.

  • Selecione Inserir Dados para inserir dados manualmente. Você pode escolher esse comando para experimentar o Editor de Consulta do Power independentemente de uma fonte de dados externa.

Supondo que sua consulta seja válida e não tenha erros, você pode carregá-la de volta para uma planilha ou modelo de dados.

Carregar uma consulta do Editor de Consulta do Power

No Editor de Consulta do Power, faça um dos seguintes:

  • Para carregar em uma planilha, selecione Home > Close & Load > Close & Load.

  • Para carregar em um Modelo de Dados, selecione Home > Fechar & Carregar > Fechar & Carregar para.

    Na caixa de diálogo Importar Dados, selecione Adicionar esses dados ao Modelo de Dados.

Dica   Às vezes, o comando Load To está esmaecida ou desabilitada. Isso pode ocorrer na primeira vez que você criar uma consulta em uma workbook. Se isso ocorrer, selecione Fechar & Carregar, na nova planilha, selecione Dados > Consultas & Conexões > Consulta, clique com o botão direito do mouse na consulta e selecione Carregar para. Como alternativa, na faixa de opções do Editor de Consulta do Power, selecione Consulta > Carregar para.

Carregar uma consulta do painel Consultas e Conexões 

Em Excel, talvez você queira carregar uma consulta em outra planilha ou modelo de dados.

  1. Em Excel, selecione Dados> Consultas & Conexõese selecione a guia Consultas.

  2. Na lista de consultas, localize a consulta, clique com o botão direito do mouse na consulta e selecione Carregar para. A caixa de diálogo Importar Dados é exibida.

  3. Decida como você deseja importar os dados e selecione OK. Para obter mais informações sobre como usar essa caixa de diálogo, selecione o ponto de interrogação (?).

Há várias maneiras de editar uma consulta carregada em uma planilha.

Editar uma consulta de dados na Excel planilha

  • Para editar uma consulta, localize uma carregada anteriormente no Editor de Consulta do Power, selecione uma célula nos dados e selecione Consulta > Editar.

Editar uma consulta do painel Consultas & Conexões

Você pode achar que o painel Consultas & Conexões é mais conveniente de usar quando você tem muitas consultas em uma única workbook e deseja encontrar uma rapidamente.

  1. Em Excel, selecione Dados> Consultas & Conexõese selecione a guia Consultas.

  2. Na lista de consultas, localize a consulta, clique com o botão direito do mouse na consulta e selecione Editar.

Editar uma consulta da caixa de diálogo Propriedades de Consulta

  • Em Excel, selecione Data> Data & Conexões > Consultas, clique com o botão direito do mouse na consulta e selecione Propriedades,selecione a guia Definição na caixa de diálogo Propriedades e selecione Editar Consulta.

Dica    Se você estiver em uma planilha com uma consulta, selecione Propriedades de dados> ,selecione a guia Definição na caixa de diálogo Propriedades e selecione Editar Consulta

Um Modelo de Dados normalmente contém várias tabelas organizadas em uma relação. Você carrega uma consulta em um Modelo de Dados usando o comando Load To para exibir a caixa de diálogo Importar Dados e, em seguida, selecionando a caixa de seleção Adicionar esses dados à caixa de seleção Modo deDados l. Para obter mais informações sobre modelos de dados, consulte Descubra quais fontes de dados são usadas em um modelo de dados de uma agenda de trabalho,Crie um modelo de dados no Excele Use várias tabelas para criar uma tabeladinâmica .

  1. Para abrir o Modelo de Dados, selecione Power Pivot >Gerenciar.

  2. Na parte inferior da janela Do Power Pivot, selecione a guia planilha da tabela que você deseja.

    Confirme se a tabela correta é exibida. Um Modelo de Dados pode ter muitas tabelas.

  3. Observe o nome da tabela.

  4. Para fechar a janela do Power Pivot, selecione Arquivo > Fechar. Pode levar alguns segundos para recuperar memória.

  5. Selecione Conexões > dados & propriedades > consultas, clique com o botão direito do mouse na consulta e selecione Editar.

  6. Quando terminar de fazer alterações no Editor de Consulta do Power, selecione Arquivo > Fechar & Carregar.

Resultado

A consulta na planilha e a tabela no Modelo de Dados são atualizadas.

Se você observar que o carregamento de uma consulta para um Modelo de Dados leva muito mais tempo do que carregar em uma planilha, verifique suas etapas de Consulta do Power para ver se você está filtrando uma coluna de texto ou uma coluna estruturada lista usando um operador Contains. Essa ação faz Excel enumerar novamente por meio de todo o conjunto de dados para cada linha. Além disso, Excel pode efetivamente usar a execução multithread. Como solução alternativa, tente usar um operador diferente, como Equals ou Begins With.

A Microsoft está ciente desse problema e está sob investigação.

Você pode carregar uma consulta do Power:

  • Para uma planilha. No Editor de Consulta do Power, selecione Home > Fechar & Carregar > Fechar & Carregar.

  • Para um modelo de dados. No Editor de Consulta do Power, selecione Home > Close & Load > Close & Load To.

    Por padrão, o Power Query carrega consultas para uma nova planilha ao carregar uma única consulta e carrega várias consultas ao mesmo tempo para o Modelo de Dados.  Você pode alterar o comportamento padrão de todas as suas guias de trabalho ou apenas a atual. Ao definir essas opções, o Power Query não altera os resultados da consulta na planilha ou nos dados e anotações do Modelo de Dados.

    Você também pode substituir dinamicamente as configurações padrão de uma consulta usando a caixa de diálogo Importar que é exibida depois de selecionar Fechar & Carregarpara. 

Configurações globais que se aplicam a todas as suas guias de trabalho

  1. No Editor de Consulta do Power, selecione Opções de> de arquivo e configurações > Opções de Consulta.

  2. Na caixa de diálogo Opções de Consulta, no lado esquerdo, na seção GLOBAL,selecione Carga de  Dados.

  3. Na seção Carga de Consulta Padrão Configurações, faça o seguinte:

    • Selecione Usar configurações de carga padrão

    • Selecione Especificar configurações de cargapadrão personalizadas e selecione ou desempurar Carregar para planilha ou Carregar para o Modelo de   Dados.

Dica    Na parte inferior da caixa de diálogo, você pode selecionar Restaurar Padrões para retornar convenientemente às configurações padrão.

Configurações de manual de trabalho que se aplicam apenas à manual de trabalho atual

  1. Na caixa de diálogo Opções de Consulta, no lado esquerdo, na seção WORKBOOK ATUAL, selecione Carga de Dados.

  2. Siga um ou mais dos procedimentos abaixo:

    • Em Detecção de Tipo,selecione ou desfaque Detect column types and headers for unstructured sources.

      O comportamento padrão é detectá-los. Desarmem essa opção se preferirem moldar os dados por conta própria.

    • Em Relações, selecione ou desmarque Criar relações entre tabelas ao adicionarao Modelo de Dados pela primeira vez .

      Antes de carregar para o Modelo de Dados, o comportamento padrão é encontrar relações existentes entre tabelas, como chaves estrangeiras em um banco de dados relacional e importá-las com os dados. Desarmem essa opção se preferirem fazer isso por conta própria.

    • Em Relações,selecione ou desembrava as relações de atualização ao atualizar consultas carregadas para o Modelo de Dados.

      O comportamento padrão é não atualizar relacionamentos. Ao atualizar consultas já carregadas para o Modelo de Dados, o Power Query encontra relações existentes entre tabelas como chaves estrangeiras em um banco de dados relacional e atualiza-as. Isso pode remover relações criadas manualmente depois que os dados foram importados ou introduzir novos relacionamentos. No entanto, se você quiser fazer isso, selecione a opção.

    • Em Dados em Segundo Plano, selecione ou desempure Permitir visualizaçõesde dados para baixar em segundo plano .

      O comportamento padrão é baixar visualizações de dados em segundo plano. Desarmem essa opção se você puder ver todos os dados imediatamente.

Confira também

Ajuda do Power Query para Excel

Gerenciar consultas em Excel

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

×