Criar um diagrama de classe UML

Você pode criar um diagrama de classe umL para mostrar uma exibição estática das classes de um sistema, seus atributos e métodos e as relações entre objetos. Ele fornece uma visão geral de um aplicativo.

(As Professional de Visio incluem suporte para o diagrama de classe uml e estêncil, mas as edições Standard não.)

Um exemplo de um diagrama de classe umL mostrando as contas de sistema de um banco para clientes pessoais.

Quando você inicia um novo diagrama de classe, o estêncil da Classe UML é exibido, juntamente com formas que estão em conformidade com o padrão UML 2.5.

  1. Inicie o Visio. Ou se você já tiver um arquivo aberto, clique em Arquivo > Novo.

  2. Na caixa Pesquisa, digite classe UML.

  3. Selecione o diagrama classe uml.

  4. Na caixa de diálogo, selecione o modelo em branco ou um dos três diagramas de início. (Uma descrição de cada um é mostrada à direita ao selecioná-la.) Em seguida, selecione Unidades Métricas ou Unidades dos EUA.

  5. Selecione Criar.

  6. O diagrama é aberto. Você deve ver a janela Formas ao lado do diagrama. Se você não vê-lo, vá para Exibir > Painéis de Tarefas e certifique-se de que Shapes está selecionado. Se você ainda não vir, clique no botão Expandir formas à esquerda.

  7. Na guia Exibir, verifique se a caixa de seleção ao lado de Pontos de Conexão está selecionada. Essa opção faz com que os pontos de conexão apareçam quando você começa a conectar formas.

  8. Agora, arraste formas que você deseja incluir no diagrama da janela Formas para a página. Para renomear rótulos de texto, clique duas vezes nos rótulos.

  9. Para adicionar mais membros à forma de classe, enumeração ou interface, arraste a forma do membro do painel de formas para a respectiva forma. Você também pode adicionar um novo membro clicando com o botão direito do mouse em um membro existente e escolhendo a opção para inserir um membro.

    Adicione um novo membro clicando com o botão direito do mouse em um membro existente e escolhendo a opção para inserir um membro.

  10.  Conexão duas formas com conectores UML para representar as relações entre as formas. Para alterar os tipos de relação, clique com o botão direito do mouse no conector. Escolha a relação desejada no menu Definir Tipo de Conector.

    Clique com o botão direito do mouse em um conector e selecione Definir Tipo de Conector para ver as opções para tipos de conector.

  11.  Resize uma forma de classe, enumeração ou interface clicando no header da forma para selecioná-lo e movendo o ponto de controle amarelo (na borda direita da forma) à esquerda ou à direita para diminuir ou aumentar a largura da forma.

  12.  Adicione campos de parâmetro e estereótipo às formas de classe selecionando a forma, clicando com o botão direito do mouse e escolhendo a opção correspondente no menu pop-up.

    Adicione campos de parâmetro e estereótipo às formas de classe clicando com o botão direito do mouse em uma forma.

Primeiro, você cria um diagrama e adiciona um estêncil de classe UML que tem formas que estão em conformidade com o padrão UML 2.5.

Observação: Criar e editar diagramas de UML no Visio para a Web requer uma licença Visio Plano 1 ou Visio Plano 2, que é comprada separadamente do Microsoft 365. Para obter mais informações, entre em contato com seu Microsoft 365 administrador. Se o administrador tiver ligado a "compra de autoatendamento", você poderá comprar uma licença para Visio si mesmo. Para obter mais detalhes, consulte Perguntas frequentes sobre compra de autoatendores.

  1. Abra Visio para a Web.

  2. Próximo ao canto superior direito da página, selecione Mais modelos.

  3. Na Galeria, role para baixo até a linha Classe UML, sobre o meio termo para baixo da página.

    O primeiro item na linha representa um modelo em branco mais o estêncil de parceiro. Os outros itens na linha são diagramas de exemplo que já têm algumas formas desenhadas para ajudá-lo a começar rapidamente.

  4. Clique em qualquer item para ver uma visualização maior.

  5. Quando você encontrar o diagrama que deseja usar, clique no botão Criar.

    O novo diagrama, com o estêncil relacionado, é aberto no navegador. Você está pronto para começar a desenhar seu diagrama.

  6. Agora, arraste formas que você deseja incluir no diagrama da janela Formas para a página. Para renomear rótulos de texto, clique duas vezes nos rótulos.

  7. Para adicionar mais membros à forma de classe, enumeração ou interface, arraste a forma do membro do painel de formas para a respectiva forma. Você também pode adicionar um novo membro clicando com o botão direito do mouse em um membro existente e escolhendo a opção para inserir um membro.

    Adicione um novo membro clicando com o botão direito do mouse em um membro existente e escolhendo a opção para inserir um membro.

  8.  Conexão duas formas com conectores UML para representar as relações entre as formas. Para alterar os tipos de relação, clique com o botão direito do mouse no conector. Escolha a relação desejada no menu Definir Tipo de Conector.

    Clique com o botão direito do mouse em um conector e selecione Definir Tipo de Conector para ver as opções para tipos de conector.

  9.  Resize uma forma de classe, enumeração ou interface clicando no header da forma para selecioná-lo e movendo o ponto de controle amarelo (na borda direita da forma) à esquerda ou à direita para diminuir ou aumentar a largura da forma.

  10.  Adicione campos de parâmetro e estereótipo às formas de classe selecionando a forma, clicando com o botão direito do mouse e escolhendo a opção correspondente no menu pop-up.

    Adicione campos de parâmetro e estereótipo às formas de classe clicando com o botão direito do mouse em uma forma.

Primeiro, selecione o diagrama classe uml, que vem com um estêncil de classe contendo formas que estão em conformidade com a especificação uml 2.0.

  1. Inicie o Visio. Ou se você já tiver um arquivo aberto, clique em Arquivo > Novo.

  2. Na caixa Pesquisa, digite classe UML.

  3. Selecione o diagrama classe uml.

  4. Na caixa de diálogo, selecione Unidades Métricas ou Unidades dos EUA.

  5. Selecione Criar.

  6. O diagrama é aberto. Você deve ver o estêncil da Classe UML na janela Formas ao lado do diagrama. Se você não vê-lo, vá para Exibir > Painéis de Tarefas e certifique-se de que Shapes está selecionado. Se você ainda não o vir, selecione a divisa na margem esquerda da janela Expanda o botão da janela Formas.

  7. Na guia Exibir, verifique se a caixa de seleção ao lado de Pontos de Conexão está selecionada. Essa opção faz com que os pontos de conexão apareçam quando você começa a conectar formas.

  8. Agora, arraste formas que você deseja incluir no diagrama da janela Formas para a página. Para renomear rótulos de texto, clique duas vezes nos rótulos.

Em Visio 2010, a maneira de criar um diagrama de classe umL é usando um diagrama de Estrutura Estática. Consulte Criar um diagrama de estrutura estática de UML para obter detalhes.

Dicas para criar um diagrama de classe

  • Identifique cada elemento e suas relações.

  • Identifique claramente pelo que cada classe é responsável.

  • Não inclua propriedades desnecessárias no diagrama que possam torná-lo muito complicado.

Notação de classe

Símbolo

Significado

-

O atributo ou a operação é privado.

+

O atributo ou a operação é público.

Confira também

Diagramas UML no Visio

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

×