Você pode usar a Consulta da Microsoft para recuperar dados de fontes externas. Ao usar o Microsoft Query para recuperar dados de seus bancos de dados corporativos e arquivos, você não precisa retipo os dados que deseja analisar no Excel. Você também pode atualizar seus relatórios Excel e resumos automaticamente do banco de dados de origem original sempre que o banco de dados for atualizado com novas informações.

Usando a Consulta da Microsoft, você pode se conectar a fontes de dados externas, selecionar dados dessas fontes externas, importar esses dados para sua planilha e atualizar os dados conforme necessário para manter seus dados de planilha sincronizados com os dados nas fontes externas.

Tipos de bancos de dados que você pode acessar     Você pode recuperar dados de vários tipos de bancos de dados, incluindo Microsoft Office Access, Microsoft SQL Server e Microsoft SQL Server OLAP Services. Você também pode recuperar dados de Excel pastas de trabalho e arquivos de texto.

Microsoft Office fornece drivers que você pode usar para recuperar dados das seguintes fontes de dados:

  • Microsoft SQL Server Analysis Services (provedor OLAP )

  • Microsoft Office Access

  • dBASE

  • Microsoft FoxPro

  • Microsoft Office Excel

  • Oracle

  • Paradox

  • Bancos de dados de arquivo de texto

Você também pode usar drivers ODBC ou drivers de fonte de dados de outros fabricantes para recuperar informações de fontes de dados que não estão listadas aqui, incluindo outros tipos de bancos de dados OLAP. Para obter informações sobre como instalar um driver ODBC ou um driver de fonte de dados que não está listado aqui, verifique a documentação do banco de dados ou entre em contato com o fornecedor do banco de dados.

Selecionando dados de um banco de dados     Você recupera dados de um banco de dados criando uma consulta, que é uma pergunta que você faz sobre os dados armazenados em um banco de dados externo. Por exemplo, se seus dados são armazenados em um banco de dados do Access, talvez você queira saber os números de vendas de um produto específico por região. Você pode recuperar uma parte dos dados selecionando apenas os dados do produto e região que deseja analisar.

Com a Consulta da Microsoft, você pode selecionar as colunas de dados que deseja e importar somente esses dados para Excel.

Atualizando sua planilha em uma operação     Depois de ter dados externos em uma pasta de trabalho Excel, sempre que o banco de dados mudar, você poderá atualizar os dados para atualizar sua análise — sem precisar criar novamente seus relatórios e gráficos de resumo. Por exemplo, você pode criar um resumo mensal de vendas e atualize-o todos os meses quando os novos números de vendas chegam.

Como a Consulta da Microsoft usa fontes de dados     Depois de configurar uma fonte de dados para um banco de dados específico, você pode usá-la sempre que quiser criar uma consulta para selecionar e recuperar dados desse banco de dados — sem precisar retipo todas as informações de conexão. A Consulta da Microsoft usa a fonte de dados para se conectar ao banco de dados externo e para mostrar quais dados estão disponíveis. Depois de criar sua consulta e retornar os dados para Excel, a Microsoft Query fornece à pasta de trabalho Excel informações de consulta e fonte de dados para que você possa se reconectar ao banco de dados quando quiser atualizar os dados.

Diagrama de como o Query usa fontes de dados

Usando a Consulta da Microsoft para importar dados     para importar dados externos para Excel com a Consulta da Microsoft, siga estas etapas básicas, cada uma delas é descrita com mais detalhes nas seções a seguir.

O que é uma fonte de dados?     Uma fonte de dados é um conjunto armazenado de informações que permite que Excel e a Consulta da Microsoft se conectem a um banco de dados externo. Quando você usa a Consulta da Microsoft para configurar uma fonte de dados, você dá um nome à fonte de dados e fornece o nome e o local do banco de dados ou servidor, o tipo de banco de dados e suas informações de logon e senha. As informações também incluem o nome de um driver OBDC ou um driver de fonte de dados, que é um programa que faz conexões com um tipo específico de banco de dados.

Para configurar uma fonte de dados usando a Consulta da Microsoft:

  1. Na guia Dados, no grupo Obter Dados Externos, clique em De Outras Fontese clique em Da Consulta da Microsoft.

  2. Faça um dos seguintes:

    • Para especificar uma fonte de dados para um banco de dados, arquivo de texto ou Excel de trabalho, clique na guia Bancos de Dados.

    • Para especificar uma fonte de dados de cubo OLAP, clique na guia Cubos OLAP. Essa guia só estará disponível se você tiver que fazer a consulta da Microsoft Excel.

  3. Clique duas vezes <nova fonte de dados>.

    –ou–

    Clique <nova fonte de dados>e clique em OK.

    A caixa de diálogo Criar Nova Fonte de Dados é exibida.

  4. Na etapa 1, digite um nome para identificar a fonte de dados.

  5. Na etapa 2, clique em um driver para o tipo de banco de dados que você está usando como sua fonte de dados.

    Observações: 

    • Se o banco de dados externo que você deseja acessar não tiver suporte dos drivers ODBC instalados com a Consulta microsoft, você precisará obter e instalar um driver ODBC compatível com o Microsoft Office de um fornecedor de terceiros, como o fabricante do banco de dados. Entre em contato com o fornecedor do banco de dados para obter instruções de instalação.

    • Os bancos de dados OLAP não exigem drivers ODBC. Quando você instala o Microsoft Query, os drivers são instalados para bancos de dados que foram criados usando Microsoft SQL Server Analysis Services. Para se conectar a outros bancos de dados OLAP, você precisa instalar um driver de fonte de dados e um software cliente.

  6. Clique Conexãoe forneça as informações necessárias para se conectar à sua fonte de dados. Para bancos de dados, Excel pastas de trabalho e arquivos de texto, as informações fornecidas dependem do tipo de fonte de dados selecionada. Você pode ser solicitado a fornecer um nome de logon, uma senha, a versão do banco de dados que você está usando, o local do banco de dados ou outras informações específicas para o tipo de banco de dados.

    Importante: 

    • Use senhas fortes que combinem letras maiúsculas e minúsculas, números e símbolos. Senhas fracas não misturam esses elementos. Um exemplo de senha forte é Y6dh!et5. Um exemplo de senha fraca é Casa27. As senhas devem ter 8 ou mais caracteres. Uma frase secreta com 14 ou mais caracteres é melhor.

    • É fundamental que você se lembre da sua senha. Caso você a esqueça, a Microsoft não poderá recuperá-la. Guarde as senhas que anotar por escrito em um lugar seguro, longe das informações que elas ajudam a proteger.

  7. Depois de inserir as informações necessárias, clique em OK ou Concluir para retornar à caixa de diálogo Criar Nova Fonte de Dados.

  8. Se o banco de dados tiver tabelas e você quiser que uma tabela específica seja exibida automaticamente no Assistente de Consulta, clique na caixa da etapa 4 e clique na tabela que você deseja.

  9. Se você não quiser digitar seu nome de logon e senha ao usar a fonte de dados, marque a caixa de seleção Salvar minha ID de usuário e senha na caixa de seleção Definição da fonte de dados. A senha salva não é criptografada. Se a caixa de seleção não estiver disponível, consulte o administrador do banco de dados para determinar se essa opção pode ser disponibilizada.

    Observação de segurança: Evite salvar informações de logon ao se conectar a fontes de dados. Essas informações podem ser armazenadas como texto sem texto, e um usuário mal-intencionado pode acessar as informações para comprometer a segurança da fonte de dados.

Depois de concluir essas etapas, o nome da fonte de dados será exibido na caixa de diálogo Escolher Fonte de Dados.

Use o Assistente de Consulta para a maioria das consultas     O Assistente de Consulta facilita a seleção e a coleta de dados de diferentes tabelas e campos em seu banco de dados. Usando o Assistente de Consulta, você pode selecionar as tabelas e campos que deseja incluir. Uma junção interna (uma operação de consulta que especifica que linhas de duas tabelas são combinadas com base em valores de campo idênticos) é criada automaticamente quando o assistente reconhece um campo de chave primária em uma tabela e um campo com o mesmo nome em uma segunda tabela.

Você também pode usar o assistente para classificar o conjunto de resultados e para fazer filtragem simples. Na etapa final do assistente, você pode optar por retornar os dados para Excel ou refinar ainda mais a consulta na Consulta da Microsoft. Depois de criar a consulta, você pode executar em Excel ou na Consulta da Microsoft.

Para iniciar o Assistente de Consulta, execute as etapas a seguir.

  1. Na guia Dados, no grupo Obter Dados Externos, clique em De Outras Fontese clique em Da Consulta da Microsoft.

  2. Na caixa de diálogo Escolher Fonte de Dados, verifique se a caixa de seleção Usar o Assistente de Consulta para criar/editar consultas está selecionada.

  3. Clique duas vezes na fonte de dados que você deseja usar.

    –ou–

    Clique na fonte de dados que você deseja usar e clique em OK.

Trabalhar diretamente na Consulta da Microsoft para outros tipos de consultas     Se você quiser criar uma consulta mais complexa do que o Assistente de Consulta permite, você pode trabalhar diretamente na Consulta da Microsoft. Você pode usar a Consulta da Microsoft para exibir e alterar consultas que você começa a criar no Assistente de Consulta ou pode criar novas consultas sem usar o assistente. Trabalhe diretamente na Consulta da Microsoft quando quiser criar consultas que fazem o seguinte:

  • Selecionar dados específicos de um campo     Em um banco de dados grande, talvez você queira escolher alguns dos dados em um campo e omitir dados que você não precisa. Por exemplo, se você precisar de dados para dois dos produtos em um campo que contenha informações para muitos produtos, poderá usar o critérios para selecionar dados apenas para os dois produtos que deseja.

  • Recuperar dados com base em critérios diferentes cada vez que você executar a consulta     Se você precisar criar o mesmo relatório ou resumo de Excel para várias áreas nos mesmos dados externos , como um relatório de vendas separado para cada região, você pode criar um consulta parâmetro. Quando você executar uma consulta de parâmetro, você será solicitado a usar um valor como o critério quando a consulta selecionar registros. Por exemplo, uma consulta de parâmetro pode solicitar que você insira uma região específica e você pode reutilizar essa consulta para criar cada um dos seus relatórios de vendas regionais.

  • Ingressar dados de maneiras diferentes     As junções internas que o Assistente de Consulta cria são o tipo mais comum de junção usado na criação de consultas. Às vezes, no entanto, você deseja usar um tipo diferente de junção. Por exemplo, se você tiver uma tabela de informações de vendas de produtos e uma tabela de informações do cliente, uma junção interna (o tipo criado pelo Assistente de Consulta) impedirá a recuperação de registros de clientes para clientes que não fizeram uma compra. Usando a Consulta da Microsoft, você pode ingressar nessas tabelas para que todos os registros de clientes sejam recuperados, juntamente com os dados de vendas para os clientes que fizeram compras.

Para iniciar a Consulta da Microsoft, execute as etapas a seguir.

  1. Na guia Dados, no grupo Obter Dados Externos, clique em De Outras Fontese clique em Da Consulta da Microsoft.

  2. Na caixa de diálogo Escolher Fonte de Dados, verifique se a caixa de seleção Usar o Assistente de Consulta para criar/editar consultas está limpa.

  3. Clique duas vezes na fonte de dados que você deseja usar.

    –ou–

    Clique na fonte de dados que você deseja usar e clique em OK.

Reutilação e compartilhamento de consultas     No Assistente de Consulta e na Consulta microsoft, você pode salvar suas consultas como um arquivo .dqy que você pode modificar, reutilizar e compartilhar. Excel pode abrir arquivos .dqy diretamente, o que permite que você ou outros usuários criem intervalos de dados externos adicionais a partir da mesma consulta.

Para abrir uma consulta salva do Excel:

  1. Na guia Dados, no grupo Obter Dados Externos, clique em De Outras Fontese clique em Da Consulta da Microsoft. A caixa de diálogo Escolher Fonte de Dados é exibida.

  2. Na caixa de diálogo Escolher Fonte de Dados, clique na guia Consultas.

  3. Clique duas vezes na consulta salva que você deseja abrir. A consulta é exibida na Consulta da Microsoft.

Se você quiser abrir uma consulta salva e a Consulta da Microsoft já estiver aberta,clique no menu Arquivo de Consulta da Microsoft e clique em Abrir .

Se você clicar duas vezes em um arquivo .dqy, Excel abre, executa a consulta e insere os resultados em uma nova planilha.

Se você quiser compartilhar um resumo Excel ou relatório baseado em dados externos, você pode dar a outros usuários uma workbook que contenha um intervalo de dados externo ou você pode criar um modelo. Um modelo permite salvar o resumo ou relatório sem salvar os dados externos para que o arquivo seja menor. Os dados externos são recuperados quando um usuário abre o modelo de relatório.

Depois de criar uma consulta no Assistente de Consulta ou na Consulta microsoft, você pode retornar os dados para uma Excel de consulta. Os dados se tornam um intervalo de dados externos ou um relatório de Tabela Dinâmica que você pode formatar e atualizar.

Formatação de dados recuperados     No Excel, você pode usar ferramentas, como gráficos ou subtotais automáticos, para apresentar e resumir os dados recuperados pela Consulta da Microsoft. Você pode formatar os dados e a formatação é mantida quando você atualize os dados externos. Você pode usar seus próprios rótulos de coluna em vez dos nomes de campo e adicionar números de linha automaticamente.

Excel formatar automaticamente novos dados que você digita no final de um intervalo para corresponder às linhas anteriores. Excel também pode copiar automaticamente fórmulas que foram repetidas nas linhas anteriores e as estende para linhas adicionais.

Observação: Para ser estendido para novas linhas no intervalo, os formatos e fórmulas devem aparecer em pelo menos três das cinco linhas anteriores.

Você pode ativar essa opção (ou desativar novamente) a qualquer momento:

  1. Clique em Arquivo> Opções > Avançada.

    Em Excel 2007: clique no botão Microsoft Office botão Imagem do botão do Office, clique Excel Opçõese clique na categoria Avançado.

  2. Na seção Opções de Edição, selecione a verificação Estender formatos e fórmulas do intervalo de dados. Para desativar a formatação automática do intervalo de dados novamente, desempure essa caixa de seleção.

Atualização de dados externos     Quando você atualize dados externos, execute a consulta para recuperar todos os dados novos ou alterados que corresponde às suas especificações. Você pode atualizar uma consulta no Microsoft Query e Excel. Excel oferece várias opções para atualizar consultas, incluindo atualizar os dados sempre que você abrir a workbook e atualize-a automaticamente em intervalos de tempo. Você pode continuar a trabalhar no Excel enquanto os dados estão sendo atualizados e também pode verificar o status enquanto os dados estão sendo atualizados. Para obter mais informações, consulte Refresh an external data connection in Excel.

Início da página

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade da tradução?

O que afetou sua experiência?

Algum comentário adicional? (Opcional)

Obrigado por seus comentários!

×