Sintomas
Em um ambiente do Microsoft Exchange Server 2016, os usuários experimentam o seguinte comportamento quando uma operação FindItems é realizada nas chamadas do Exchange Web Services (EWS):
-
A chamada do EWS falha com o seguinte erro:
Exceção sem tratamento: Microsoft. Exchange. WebServices. Data. inresponseexception: ocorreu um erro de servidor interno. A operação falhou. não é possível consultar linhas em uma tabela.
-
O EWS registra em C:\Program Files\Microsoft\Exchange Server\V15\Logging\Ews no servidor de função caixa de correio mostra o seguinte erro:
ExceptionHandler_Execute = Microsoft. Exchange. Data. Storage. StoragePermanentException: não é possível consultar linhas em uma tabela. ---> Microsoft. MAPI. MapiExceptionMaxObjsExceeded: MapiExceptionMaxObjsExceeded: não é possível consultar linhas da tabela.
Causa
Uma alteração no número de restrições materializadas que podem existir em uma caixa de correio foi introduzida no Exchange Server 2016. Essa alteração pode disparar uma situação em que uma chamada de FindItems deve criar uma nova pesquisa materializada na caixa de correio, mas não pode fazer isso porque a caixa de correio já está com o limite.
Resolução
Para resolver o problema, instale a atualização cumulativa 3 do Exchange Server 2016 ou posterior. No cenário descrito na seção "sintomas", a pesquisa materializada mais antiga será expirada após a instalação desta atualização. Portanto, uma nova pesquisa pode ser criada sem gerar uma exceção.