Sintomas
Você recebe a seguinte mensagem de erro quando você configura as Opções de Solicitação de Férias no Outlook 2003 ou Outlook 2007 em todas as estações de trabalho, incluindo o servidor:
Não é possível se conectar ao Portal de Negócios. Você não está autorizado a se conectar devido a um erro de protocolo, que pode estar relacionado às configurações de segurança de diretório para o diretório virtual do Portal de Negócios. Essas configurações devem permitir autenticação Windows Ingegrated. Entre em contato com o Administrador do Portal de Negócios.
Esse erro ocorre quando você tenta conectar a ferramenta Outlook solicitação de férias Add-In no Outlook do HRM self service usando o Portal de Negócios com o Microsoft Dynamics GP.
Causa
Verifique as configurações para acesso à autenticação. Normalmente, a Autenticação Básica no gerenciador de Serviços de Informações da Internet da Microsoft (IIS) está habilitada e deve ser desabilitada.
Resolução
Método 1: Configurações no Gerenciador do IIS 1. Conceda permissões ao grupo Usuários de Domínio para seu Site da BP por meio Serviços de Informações da Internet da Microsoft (IIS) seguindo estas etapas:
a. Faça logoff no Servidor Web do Portal de Negócios (BP) executando o IIS. b. No Painel de Controle,abra Ferramentas Administrativase clique em Gerenciador do IIS.
c. Na janela Gerenciador do IIS, expanda Sites.
d. Clique com o botão direito do mouse em seu Site da BP e clique em Permissões.
e. Na janela Segurança, você deve ter um grupo "Usuários" semelhante a (XXXXX\Users)Observação XXXXX é um espaço reservado para o nome de domínio)Se esse grupo não existir, adicione o grupo de domínios. 2. Conceda autenticação Windows para seu Site da BP por meio do IIS seguindo estas etapas:
a. Faça logoff no SERVIDOR Web bp executando o IIS. b. No Painel de Controle,abra Ferramentas Administrativase clique em Gerenciador do IIS.
c. Na janela Gerenciador do IIS, expanda Sites.
d. Clique com o botão direito do mouse em seu Site da BP e clique em Propriedades.
e. Clique na guia Segurança do Diretório.
f. Na área De autenticação e controle de acesso, clique em Editar.
g. Na área acesso autenticado, clique para marcar a caixa de seleção Autenticação integrada Windows autenticação.
h. Na área acesso autenticado, verifique se a caixa de seleção Autenticação básica não está marcada. ---- Para verificar a Autenticação Básica do IIS 7.0, use estas etapas: a. Na estação de trabalho onde o Portal de Negócios (BP) está instalado, navegue até o Gerenciador do IIS. Para fazer isso, clique em Iniciar, clique em Painel de Controle, em Ferramentas Administrativas e clique duas vezes Serviços de Informações da Internet Gerenciador (IIS). b. Na seção Conexões na margem esquerda, clique para expandir o site de conexão apropriado.c. Clique para expandir Sites.d. Clique com o botão direito do mouse em Portal de Negócios (que pode estar no site do Sharepoint) e clique em Alternar para Exibição de Recursos.e. No Features View, você verá seções rotuladas como ASP.NET e IIS. Na seção IIS, clique duas vezes em Autenticação. f. Clique para selecionar Autenticação Básica.g. Na margem direita em Ações, clique em Desabilitar. (Observação: se somente 'Habilitar' estiver listado, ele já está desabilitado.) h. Feche as janelas. ----- 3. Redefinir o IIS. Para fazer isso, clique em Iniciar, em Executar, digite IISRESET no campo Abrir e clique em OK para processar. 4. Teste novamente. Se você ainda tiver o mesmo problema, tente que um usuário diferente acesse a janela Opções de Solicitação de Férias a partir de seu perfil de Outlook e veja se ele é capaz de acessar.OBSERVAÇÃO: Certifique-se de Outlook Microsoft está instalado como o sistema de email compatível com MAPI. Se esse método não funcionar, prossiga para o Método 2.Método 2: Configurações no Internet Explorer 1. No Internet Explorer, clique em Ferramentas, em Opções da Internet e clique em selecionar a Guia Avançada. Na seção Segurança, certifique-se de que a autenticação habilitar a autenticação Windows integrada está marcada. 2. Adicione a URL de BP aos Sites Confiáveis.Método 3: Verificar/testar se você pode navegar até a URL mostrada nas Opções de Solicitação de Férias Outlook 1. Depois que o Add-In estiver instalado, abra Outlook. Clique em Ferramentas, em Opções de Solicitação de Férias e na guia Conexão. Observe a URL listada na parte inferior da janela. Esse é o caminho que você precisará procurar para usar essas etapas. Veja a seguir um exemplo da URL: http://localhost/BusinessPortal/Applications/HRM/VacationRequestWebService.asmx (Observação Se você digitou um Nome de Host, ele substituirá o 'localhost' nesta URL.) 2. Vá para o servidor onde a BP está instalada. Clique em Iniciar, em Ferramentas Administrativas e em Serviços de Informações da Internet (IIS) Manager.3. Clique para expandir a conexão do banco de dados na margem esquerda.4. Clique para expandir Sites, clique em Expandir Portal de Negócios, em Expandir Portal de Negócios novamente, em Aplicativos e na pasta HRM. (Basicamente, navegue até a mesma URL que você vê na janela Opções de Solicitação de Férias. Suas etapas/localização para onde navegar podem ser diferentes do que está listado neste exemplo.) 5. Clique em Exibir conteúdo na parte inferior da janela para exibir os arquivos na pasta HRM.6. Role para baixo para encontrar VacationRequestWebService.asmx. Clique com o botão direito do mouse nele e clique em procurar. Uma janela VacationRequestWebService deve ser aberta. É importante que ele abra a janela do serviço Web aqui. 7. Se a janela do serviço Web for aberta, anote a URL na parte superior da página. A URL listada na janela Opções de Solicitação de Férias deve corresponder exatamente a essa URL.