Sintomas
Se você executar o Microsoft Dynamics GP 10.0 em um ambiente Citrix, a funcionalidade de cópia (CTRL+C) e colar (CTRL+V) não funcionará no Microsoft Dynamics GP. Você não pode mais copiar ou colar entre um aplicativo local e uma sessão ou entre diferentes aplicativos em uma sessão.
Causa
Esse comportamento ocorre porque o aplicativo GP do Microsoft Dynamics incorretamente se insere na cadeia de Windows de transferência em uma estação de trabalho local ou dentro da sessão.
Resolução
Para resolver esse problema, obtenha o service pack mais recente para o Microsoft Dynamics GP 10.0. Para obter mais informações, visite um dos seguintes sites da Microsoft, dependendo se você é um parceiro ou um cliente.
Parceiros
https://mbs.microsoft.com/partnersource/downloads/servicepack/Clientes
https://mbs.microsoft.com/customersource/support/downloads/servicepacks
Solução alternativa
Para resolver esse comportamento, repare temporariamente a cadeia de transferência usando a ferramenta RepairCBDChain:
-
Baixe a ferramenta RepairCBDChain. Para baixar a ferramenta RepairCBDChain, visite o seguinte site:
-
Verifique se o Microsoft Dynamics GP 10.0 está em execução.
-
Em um prompt de comando, altere o diretório para onde a ferramenta RepairCBDChain está localizada.
-
Digite RepairCBDChain.exe e pressione ENTER.
Observação Sempre que você executar o Microsoft Dynamics GP, você precisa concluir essas etapas para que a funcionalidade de cópia e colar funcione.
Se o Microsoft Dynamics GP for implantado como um aplicativo publicado em que o usuário não tenha acesso à área de trabalho, siga estas etapas:
-
Faça uma cópia de backup do arquivo Dynamics.set.
-
Faça uma cópia de backup do arquivo Dex.ini arquivo.
-
Copie o arquivo Launcher.cnk da pasta \Tools\Continuum no Microsoft Dynamics GP 10.0 CD VOL 2 para o diretório de instalação do Microsoft Dynamics GP 10.0. O diretório de instalação do Microsoft Dynamics GP 10.0 pode ser o seguinte:
C:\Arquivos de Programas\Microsoft Dynamics\GP\
-
Copie o RepairCBDChain.exe para a unidade raiz (por exemplo, C:\RepairCBDChain.exe).
-
Abra o Dex.ini que está localizado no diretório de instalação do Microsoft Dynamics GP 10.0 usando Bloco de notas. O diretório de instalação do Microsoft Dynamics GP 10.0 pode ser o seguinte:
C:\Arquivos de Programas\Microsoft Dynamics\GP\Data\
-
Adicione a seguinte linha à parte inferior do arquivo Dex.ini:
OLE_Application1=C:\RepairCBDChain.exeNotes
-
Altere o caminho para o caminho onde você copiou o arquivo RepairCBDChain.exe na etapa 4. O caminho não pode conter uma pasta cujo nome usa espaços ou caracteres especiais.
-
Substitua 1 por 2 se você já tiver uma linha OLE_Application1 no arquivo Dex.ini de outros aplicativos do Contínuo de complemento. Se você já tiver algumas OLE_ApplicationX, substitua 1 por X+1.
-
-
Salve e feche o arquivo Dex.ini arquivo.
-
Inicie o Microsoft Dynamics GP 10.0 e clique em Sim para incluir novo código, se você for solicitado.
Observação O arquivo Dynamics.set terá PRODID "851" com o nome "Contínuo Iniciador de Aplicativos" adicionado a ele. -
Faça logoff em uma empresa no Microsoft Dynamics GP e verifique se a funcionalidade de cópia e colar funciona.
Para remover essa solução alternativa com segurança, reverte para os arquivos Dex.ini e Dynamics.set originais.
Informações adicionais
Quando você tiver instalado a ferramenta Launcher e iniciar o Microsoft Dynamics GP, poderá receber uma mensagem de que a ferramenta RepairCBDChain está em execução. Você pode clicar nesta janela de mensagem. Se você não quiser receber essa mensagem, consulte parâmetros descritos em Citrix Document ID CTX106226. Para acessar este documento, visite o seguinte site do Citrix:
http://support.citrix.com/article/CTX106226ImportantMake sure that you do not remove the OLE_Application1 line from the Dex.ini file or delete the RepairCBDChain.exe file. Se você remover a linha OLE_Application1 ou excluir o arquivo RepairCBDChain.exe inesperadamente, a funcionalidade de cópia e colar será interrompida. Além disso, você pode receber uma mensagem de erro fora do tipo de memória ou uma mensagem de erro de tipo de destreza ao iniciar o Microsoft Dynamics GP.
Status
A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a". Esse problema foi corrigido pela primeira vez no Microsoft Dynamics GP 10.0 Service Pack 3.