Applies ToExchange Server 2010 Enterprise Exchange Server 2010 Standard

Sintomas

Você cria um novo banco de dados de pasta pública em um servidor Microsoft Exchange Server 2010 Service Pack 1 (SP1). No entanto, a hierarquia de pastas públicas não é replicada de outros armazenamentos públicos para esse novo banco de dados. Além disso, os seguintes eventos são registrados no log de aplicativos:

Nome do Log: Fonte do Aplicativo: MSExchangeIS Data do Armazenamento Público: ID do Evento de Data: 3079 Categoria de Tarefa: Nível de Erros de Replicação: Palavras-chave de erro: Usuário clássico: Computador: Descrição do computador: Erro de thread de replicação inesperada 0x80070057 no banco de dados " Primeiro Grupo de Armazenamento\Armazenamento de Pastas Públicas (Server_Name)".

Nome do Log: Fonte do Aplicativo: MSExchangeIS Data do Armazenamento Público: ID do Evento de Data: 3089 Categoria de Tarefa: Nível de Erros de Replicação: Palavras-chave de aviso: Usuário clássico: N/A Computador: Descrição do computador: Erro 0x80070057 ocorreu durante o processamento de uma mensagem de replicação de entrada no Armazenamento de Pastas Públicas " Primeiro Grupo de Armazenamento\Armazenamento de Pastas Públicas (Server_Name)".

Observação Os eventos são registrados sempre que o servidor tenta fazer o backfill da hierarquia.

Causa

Esse problema ocorre porque a tabela ReplidMap no banco de dados de pasta pública contém um GUID (Identificação Universal Global) zero.

Resolução

Para resolver esse problema, instale o seguinte acúmulo de atualizações:

2645995 Descrição do Pacote de Atualizações 1 para Exchange Server 2Note do Service Pack 2010 Esta atualização permite que os usuários que não podem executar o comando isinteg pulem a verificação guid zero. Para obter mais informações sobre como executar o comando isinteg para resolver esse problema, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento da Microsoft:

2506049 A hierarquia de um novo banco de dados de pasta pública em um servidor Exchange Server 2010 SP1 não é replicada Depois de aplicar essa atualização, desabilite a detecção zero de GUID para pastas públicas em servidores Exchange Server 2010. Para que desabilitemos a detecção zero de GUID para pastas públicas, vá para a seção "Corrigir para mim". Se você preferir desabilitar a detecção zero de GUID para pastas públicas por conta própria, vá para a seção "Deixe-me corrigi-lapor conta própria ".

Corrigir para mim

Para desabilitar a detecção zero de GUID para pastas públicas automaticamente, clique no botão Corrigir ou no link. Em seguida, clique em Executar na caixa de diálogo Baixar Arquivo e siga as etapas no assistente Corrigir.

Observações

  • Instale o hotfix descrito no artigo 2645995 da Base de Dados de Conhecimento da Microsoft (KB) antes de executar essa solução Correção.

  • Esse assistente pode estar apenas em inglês. No entanto, a correção automática também funciona em versões do Windows em outros idiomas.

  • Se você não estiver usando o computador que apresenta o problema, salve a solução Corrigir em uma unidade flash ou em um CD e execute-a no computador que apresenta o problema.

Em seguida, vá para a seção "Isso corrigiu o problema?"

Desejo corrigir sozinho

Para desabilitar a detecção zero de GUID para pastas públicas, siga estas etapas Exchange Server servidores 2010:

  1. Clique em Iniciar botão iniciar , digite regedit na caixa Iniciar Pesquisa e pressione Enter.

  2. Localize e clique na seguinte chave do Registro:

    HKLM/SYSTEM/CurrentControlSet/Services/MSExchangeIS/ParametersPublic

  3. Clique em Editar, aponte para Novoe clique em Valor DWORD.

  4. Digite Desabilitar a Detecção de Guid Zero para Pastas Públicas e pressione Enter.

  5. Clique em Editare em Modificar.

  6. Na caixa Dados valor, digite 1.

  7. Saia do Editor do Registro.

O problema foi corrigido?

  • Verifique se o problema foi corrigido. Se o problema tiver sido corrigido, você terá concluído esta seção. Se o problema não tiver sido corrigido, você poderá contatar o suporte.

  • Agradecemos pelos seus comentários. Para fornecer comentários ou relatar quaisquer problemas com essa solução, deixe um comentário no blog "Corrigirpara mim " ou envie um emailpara nós.

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a".

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.