Sintoma
A linha do tempo na UCI não renderiza a exibição do seguinte erro: "Os registros não puderam ser carregados devido a um erro inesperado". Isso se parece com isso:
Se você abrir as ferramentas do desenvolvedor e atualizar a página, verá na guia Rede uma solicitação "lote" que contém uma chamada GET para /api/data/v9.0/activitypointers/Microsoft.Dynamics.CRM.RetrieveTimelineWallRecordshas que falhou com 400 – Solicitação Incorreta (a solicitação com falha estará em vermelho) e esta mensagem:
{"error":{"code":"0x8004430d","message":"Número de entidades de link na consulta excedeu o limite máximo.","innererror":{"message":"Número de entidades de link na consulta excedeu o limite máximo".
Causa
Essa é uma limitação do controle de linha do tempo que nossa equipe está abordando agora. Há uma configuração QueryLinkEntityLimit e ultrapassar esse limite resulta no erro. As entidades de link são provenientes de atividades fora da caixa, bem como de atividades personalizadas.
Os clientes podem adicionar entidades de link extras a essa chamada fazendo a seguinte personalização à linha do tempo: usando formulários de cartão para atividades personalizadas.
Mitigação
Mitigação 1
Você pode entrar em contato com o suporte ao cliente e fornecer os detalhes sobre esse erro e solicitar que eles aumentem a configuração QueryLinkEntityLimit para sua organização.
Observação: essa configuração afetará todas as chamadas na organização que têm entidades de link e podem diminuir o desempenho para chamadas que têm uma contagem muito alta de entidades de link. No entanto, o desempenho atingido não deve ser significativo se estivermos aumentando o limite em um único dígito.
Mitigação 2
Se o cliente tiver criado atividades personalizadas e estiver usando formulários de cartão para eles, poderá desabilitar os formulários de cartão para reduzir o número de entidades de link na solicitação do lote. Isso pode ser alcançado fazendo as seguintes etapas:
-
Acesse as configurações da Linha do Tempo para UCI (no editor de formulários da entidade com problemas, clique duas vezes na seção linha do tempo e as configurações devem ser abertas).
-
Na guia Atividades, seção Opções Adicionais, procure todas as atividades personalizadas que tenham um formulário de cartão.
-
Altere a seleção para "Selecionar Formulário de Cartão" – isso desabilitará o formulário de cartão.
Também é possível não incluir uma atividade personalizada na linha do tempo se não for útil:
-
Acesse as configurações da Linha do Tempo para UCI.
-
Na guia Atividades, filtrar por seção, em vez de "Mostrar tudo" selecione "Mostrar selecionado".
-
Desmarque as atividades personalizadas que serão removidas da linha do tempo.