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Sintomas

Considere o seguinte cenário:

  • Instale o cliente System Center Configuration Manager 2007 Service Pack 1 (SP1) ou o cliente System Center Configuration Manager 2007 Service Pack 2 (SP2).

  • Instale a atualização de 974571 ou Windows 7 Service Pack 1 (SP1) no mesmo computador.

  • Uma sequência de tarefas do ConfigMgr é executada nesse cliente. Essa sequência de tarefas inclui a etapa de sequência de tarefas Capturar Estado do Usuário e a etapa restaurar a sequência de tarefas Estado do Usuário.

Nesse cenário, a migração de estado do usuário falha. Ao mesmo tempo, a seguinte mensagem de erro é registrada no arquivo Ccmexec.log:

Falha ao importar o OSDSMPClient (repositório de certificados do 0x80092024) do cliente

Causa

Esse erro ocorre porque um caractere NULL inserido está na propriedade Nome amigável de um certificado. A atualização de 974571 impede a ação que importa o certificado quando sua propriedade Nome amigável tem um caractere NULL inserido. Portanto, o certificado não pode ser importado.

Resolução

Importante Para resolver esse problema, instale esse hotfix em todos os servidores de site do System Center Configuration Manager 2007 Service Pack 1 (SP1) e em todos os servidores de site do System Center Configuration Manager 2007 Service Pack 2 (SP2). Em seguida, implante esse hotfix em todos os clientes.



Esse hotfix resolve esse problema para todos os novos certificados de cliente gerados. Para corrigir os certificados atuais, execute o utilitário CCMCertFix que está neste pacote em todos os clientes Configuration Manager SP1 e em todos os clientes Configuration Manager SP2.

Observação Para extrair o utilitário CCMCertFix, siga estas etapas:

  1. Instale esse hotfix no servidor do site.

  2. Localize o CCMCertFix.exe arquivo. Por padrão, esse arquivo está localizado na seguinte pasta:

    ConfigMgr_2007_Installation_Directory\Logs\KB977203

  3. Copie e execute o arquivo CCMCertFix.exe em qualquer cliente existente.

Um hotfix com suporte está disponível na Microsoft. No entanto, esse hotfix destina-se a corrigir apenas o problema descrito neste artigo. Aplique esse hotfix somente a sistemas que estão enfrentando esse problema específico.

Se o hotfix estiver disponível para download, haverá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não aparecer, envie uma solicitação para o Atendimento ao Cliente e Suporte da Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se alguma solução de problemas for necessária, talvez seja necessário criar uma solicitação de serviço separada. Os custos usuais de suporte serão aplicados a perguntas e problemas de suporte adicionais que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de Atendimento ao Cliente e Suporte da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportObservação O formulário "Download de hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, System Center Configuration Manager 2007 Service Pack 1 (SP1) ou System Center Configuration Manager 2007 Service Pack 2 (SP2) deve ser instalado.

Necessidade de reinicialização

Você não precisa reiniciar o computador depois de aplicar esse hotfix.

Informações sobre a substituição de hotfixes

Esse hotfix não substitui nenhum hotfix lançado anteriormente.

Informações do arquivo

A versão em inglês (Estados Unidos) deste hotfix instala arquivos que têm os atributos listados nas tabelas a seguir. As datas e as horas desses arquivos estão listados no formato UTC (Tempo Universal Coordenado). As datas e as horas desses arquivos no computador local são exibidas no horário local, com o ajuste de DST (horário de verão) atual. Além disso, as datas e as horas poderão ser alteradas quando você realizar algumas operações nos arquivos.

System Center Configuration Manager do arquivo 2007 SP1

File name

Versão do arquivo

Tamanho do arquivo

Data

Horário

Platform

Ccmcertfix.exe

4.0.6221.1193

17,768

01 de dezembro de 2008

01:40

x86

Ccmgencert.dll

4.0.6221.1193

130,408

01 de dezembro de 2008

01:40

x86

Ccmsetup-sup.cab

Não Aplicável

257,833

01 de dezembro de 2008

01:40

Não Aplicável

Ccmsetup.exe

4.0.6221.1193

609,128

01 de dezembro de 2008

01:40

x86

Ccmsetup.msi

Não Aplicável

1,662,464

01 de dezembro de 2008

01:40

Não Aplicável

Mcs.msi

Não Aplicável

7,312,896

01 de dezembro de 2008

01:40

Não Aplicável

Mcsisapip.dll

4.0.6221.1193

205,672

01 de dezembro de 2008

01:40

x86

Mp.msi

Não Aplicável

9,515,520

01 de dezembro de 2008

01:40

Não aplicável

Sccm2007ac-sp1-kb977203-x86.msp

Não Aplicável

3,076,096

01 de dezembro de 2008

01:40

Não Aplicável

Smpmgr.dll

4.0.6221.1193

85,864

01 de dezembro de 2008

01:40

x86

Ccmgencert.dll

4.0.6221.1193

649,576

01 de dezembro de 2008

01:40

IA-64

Ccmgencert.dll

4.0.6221.1193

285,032

01 de dezembro de 2008

01:40

x64

Mcsisapip.dll

4.0.6221.1193

480,616

01 de dezembro de 2008

01:40

x64


System Center Configuration Manager do arquivo 2007 SP2


File name

Versão do arquivo

Tamanho do arquivo

Data

Horário

Platform

Ccmcertfix.exe

4.0.6487.2111

17,768

25 de janeiro de 2010

06:27

x86

Ccmgencert.dll

4.0.6487.2111

130,408

25 de janeiro de 2010

06:27

x86

Ccmsetup-sup.cab

Não aplicável

253,016

10 de dezembro de 2009

03:40

Não aplicável

Ccmsetup.exe

4.0.6487.2111

611,688

25 de janeiro de 2010

06:27

x86

Ccmsetup.msi

Não Aplicável

1,662,976

25 de janeiro de 2010

06:27

Não Aplicável

Mcs.msi

Não Aplicável

7,204,864

25 de janeiro de 2010

06:28

Não aplicável

Mcsisapip.dll

4.0.6487.2111

206,696

25 de janeiro de 2010

06:28

x86

Mp.msi

Não Aplicável

9,180,672

25 de janeiro de 2010

06:28

Não aplicável

Sccm2007ac-sp2-kb977203-x86.msp

Não Aplicável

444,928

25 de janeiro de 2010

06:28

Não aplicável

Smpmgr.dll

4.0.6487.2111

86,376

25 de janeiro de 2010

06:28

x86

Ccmgencert.dll

4.0.6487.2111

649,576

25 de janeiro de 2010

06:28

IA-64

Ccmgencert.dll

4.0.6487.2111

285,032

25 de janeiro de 2010

06:29

x64

Mcsisapip.dll

4.0.6487.2111

481,640

25 de janeiro de 2010

06:29

x64

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a".

Informações adicionais

Propriedades de instalação do cliente

Se você especificou uma propriedade de instalação por push do cliente quando instalou o cliente System Center Configuration Manager 2007 SP1 ou o cliente System Center Configuration Manager 2007 SP2, especifique a propriedade novamente ao instalar o hotfix. Se você não especificar a propriedade novamente ao instalar o hotfix, a propriedade será removida da configuração. Por exemplo, se você modificou a instalação original usando o ponto de localizador de servidor (SMSSLP) ou a propriedade FSP (ponto de status de fallback), deverá especificar essa propriedade novamente ao instalar o hotfix.

Como usar o utilitário CCMCertFix.exe aplicativo

O utilitário CCMCertFix é um utilitário de prompt de comando que é executado sem opções (opções). No entanto, você deve executar usando direitos administrativos. O CCMCertFix.exe é instalado no seguinte local:

sms root\logs\KB977203Note Você pode redirecionar erros para um arquivo de log específico. Por exemplo, suponha que o nome do arquivo de log seja CCMCertFix.log. Nesse cenário, você pode executar o seguinte comando:

CCMCertFix.exe CCMCertFix.log

Informações de implantação sobre CCMCertFix.exe utilitário

O utilitário CCMCertFix pode ser distribuído como um Configuration Manager programa. Por exemplo, suponha que você use as seguintes configurações para distribuir o utilitário como um Configuration Manager programa:

  • Executar: Oculto

  • Executar se um usuário está conectado ou não

  • Executar com direitos administrativos

Essas configurações de programa podem ser alteradas para atender ao ambiente e às suas necessidades de negócios.

Observe que você deve executar o utilitário CCMCertFix usando direitos administrativos.

Para obter mais informações sobre a atualização 974571 segurança, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento Microsoft:

974571 MS09-056 : Vulnerabilidades no CryptoAPI

podem permitir falsificação Para obter mais informações sobre a terminologia de atualização de software, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento Microsoft:



824684 Descrição da terminologia padrão usada para descrever as atualizações de software

da Microsoft O hotfix descrito no artigo da Base de Dados de Conhecimento microsoft 997384 substitui e inclui esse hotfix.

Portanto, esse hotfix não pode ser instalado depois que esse hotfix é instalado. No entanto, CCMCertFix.exe utilitário não está incluído como parte desse hotfix. Para obter o utilitário CCMCertFix.exe depois de instalar esse hotfix, baixe o hotfix descrito neste hotfix e execute o seguinte comando para extrair o conteúdo do hotfix:

msiexec.exe /a SCCM2007-SP2-KB977203-ENU.msi /qb targetdir=Path_To_Extract_ToNotes

  • Nesse comando, o espaço reservado Path_To_Extract_To representa o local onde o conteúdo do hotfix deve ser extraído. Depois que CCMCertFix.exe utilitário for extraído, você poderá encontrar o utilitário nesse local.

  • O nome do arquivo .msi neste comando pode ser diferente dependendo da versão localizada que é baixada. Verifique o nome do arquivo .msi que é baixado e altere a linha de comando adequadamente se isso for necessário.

Instalar o KB977203 durante uma sequência de tarefas



Para implantações de sistema operacional, o hotfix KB977203 deve ser instalado durante uma sequência de tarefas osD do ConfigMgr 2007 na tarefa Windows e ConfigMgr. Caso contrário, o problema continuará ocorrendo enquanto a sequência de tarefas é executada. O hotfix não pode ser instalado usando uma tarefa de "instalar software". Isso faria com que o serviço cliente do ConfigMgr 2007 parasse, o que fará com que a sequência de tarefas falhe.

Observação Se a atualização do cliente descrita no artigo base do Knolwedge 977384 estiver sendo instalada durante a sequência de tarefas, não será necessário instalar também essa atualização do cliente, pois essa atualização está incluída como parte dessa atualização.

Para instalar o hotfix KB977203 durante uma sequência de tarefas osD do ConfigMgr 2007, use a opção PATCH= descrita no seguinte artigo da Base de Dados de Conhecimento Microsoft:

907423 Como incluir uma atualização na instalação inicial do Cliente Avançado do Systems Management Server 2003


Para instalar o hotfix KB977203 durante uma sequência de tarefas osD do ConfigMgr 2007, siga estas etapas:

  1. Aplique o hotfix no servidor do site.

  2. Depois que o hotfix tiver sido aplicado no servidor do site, os arquivos de instalação do cliente do ConfigMgr 2007 serão atualizados para incluir o hotfix KB977203 no diretório \i386\hotfix\KB977203\ dos arquivos de instalação do cliente do ConfigMgr 2007. Como os arquivos de instalação do cliente do ConfigMgr 2007 foram atualizados, atualize os pontos de distribuição em que o pacote de instalação do cliente do ConfigMgr 2007 reside.

  3. Clique com o botão direito do mouse na sequência de tarefas que você precisa alterar e clique em Editar.

  4. Clique em Janelas de Instalação e ConfigMgr.

  5. Na caixa Propriedades de instalação, digite o seguinte:

    Para o ConfigMgr 2007 SP1:

    PATCH="C:\_SMSTaskSequence\OSD\<Package_ID>\i386\hotfix\KB977203\SCCM2007AC-SP1-KB977203-x86.msp"For ConfigMgr 2007 SP2:

    PATCH="C:\_SMSTaskSequence\OSD\<Package_ID>\i386\hotfix\KB977203\SCCM2007AC-SP2-KB977203-x86.msp"
    Notes

    • O <Package_ID> espaço reservado é a ID do pacote de instalação do cliente configMgr 2007 no ConfigMgr 2007.

    • Certifique-se de incluir as aspas como parte do caminho. No entanto, não inclua os colchetes que estão ao redor do espaço reservado.

    • Verifique se a ID do pacote de instalação do cliente do ConfigMgr 2007 é usada e não a ID do pacote de hotfix KB977203.

    • A _SMSTaskSequence de cache do cliente residirá na unidade que tem mais espaço em disco. Se o computador tiver várias unidades ou partições, _SMSTaskSequence pasta poderá acabar em uma unidade diferente da unidade C. Nesse cenário, altere o caminho para apontar para a unidade que contém a _SMSTaskSequence pasta. Não recomendamos que você use a variável _SMSTSMDataPath no caminho porque a letra da unidade nesse caminho pode ser enumerada de forma diferente no Windows PE do que no sistema operacional Windows completo.

    • Como alternativa ao uso do caminho local que aponta para os arquivos de instalação do cliente do ConfigMgr 2007 localizados no cache local da Sequência de Tarefas, você pode especificar um caminho UNC que aponta para os arquivos de instalação do cliente configMgr 2007 na origem do pacote original ou em um ponto de distribuição.

    • Verifique o nome do arquivo .msp localizado no diretório \i386\hotfix\KB977203\ dos arquivos de instalação do cliente do ConfigMgr 2007. O nome pode ser diferente dependendo da localidade. Se o nome for diferente do nome do arquivo .msp usado na linha de comando PATCH= nesta etapa, ajuste o nome adequadamente.

  6. Clique em Aplicarou OK para salvar a sequência de tarefas.


Além de instalar o hotfix KB977203 durante a sequência de tarefas, CCMCertFix.exe também precisa ser executado. Quando CCMCertFix.exe execuções depende do cenário de implantação que está ocorrendo (substituir ou atualizar ou novo computador). As etapas a seguir mostram como executar CCMCerFix.exe para todos os cenários de implantação.

  1. Use a distribuição de software normal para criar um pacote e um programa usando o CCMCertFix.exe utilitário do KB977203. O programa não precisa ter nenhuma comutadores e pode apenas executar CCMCertFix.exe diretamente. Depois de criar o pacote e o programa, certifique-se de colocar o pacote nos pontos de distribuição.

  2. Clique com o botão direito do mouse na sequência de tarefas afetada e selecione Propriedades.

  3. Clique na guia Avançado.

  4. Clique na opção executar outro programa primeiro e selecione o pacote e o programa na etapa 1.

  5. Clique em OK.

  6. Clique com o botão direito do mouse na sequência de tarefas afetada e selecione Editar.

  7. Clique na tarefa Windows e ConfigMgr.

  8. Com a tarefa Windows e ConfigMgr selecionada, clique no menu Adicionar e selecione Geral --> Instalar Software.

  9. Clique na tarefa de instalação de software recém-criada e selecione o pacote e o programa da etapa 1.

  10. Com a tarefa de instalação de software recém-criada ainda selecionada, clique no menu Adicionar e selecione Geral --> Reiniciar Computador.

  11. Clique na tarefa reiniciar computador recém-criada e selecione a opção O sistema operacional padrão instalado no momento. Além disso, desmarque a opção Notificar o usuário antes de reiniciar.

  12. Clique em OKou Aplicar para salvar a sequência de tarefas.


Observação Para cenários de substituição, você só precisa seguir as etapas de 1 a 5 para a sequência de tarefas que captura os dados no computador original. Para a sequência de tarefas que restaura os dados no novo computador, siga todas as etapas.

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