A replicação do AD falha com um problema RPC após você definir uma porta estática para NTDS em um ambiente de domínio compatível com o Windows

Sintomas


Suponha que você defina uma porta TCP na qual o serviço NTDS escute e responda à entrada de chamadas de procedimento remoto (RPCs). Nessa situação, a replicação do Diretório Ativo pode falhar com um problema RPC. Esse problema pode incluir todos os sintomas em e .

Notes

  • Para obter mais informações sobre como restringir o tráfego de replicação do Diretório Ativo e o tráfego RPC do cliente para uma porta específica, clique no número abaixo para ler o artigo na Base de Conhecimento Microsoft:

    O tráfego de replicação do Active Directory restringindo e o tráfego RPC do cliente para uma porta específica

  • A interface NTDS também é conhecido como a interface do DRS. Usar uma porta estática permite ao administrador restringir a comunicação de uma atividade (como a replicação do Diretório Ativo) para uma porta conhecida. Isso permite que os firewalls sejam configurados para permitir tráfego apenas naquela porta.


Causa

Quando a porta estática para o serviço NTDS é registrada com êxito com o mapeador de ponto de extremidade, uma porta dinâmica também é registrada. No entanto, a porta estática não é sempre retornada pelo mapeador de ponto de extremidade como primeira prioridade. Se uma porta dinâmica é retornada e também é bloqueada pelo firewall, ele pode causar o problema descrito na seção "Sintomas".

Resolução

Para resolver esse problema no Windows 8.1 ou no Windows Server 2012 R2, instale a atualização 2955164. Para obter mais informações sobre atualização 2955164, clique no número abaixo para ler o artigo na Base de Conhecimento Microsoft:

Windows RT 8.1, 8.1 para Windows e Windows Server 2012 R2 cumulativo: maio de 2014Para resolver esse problema no Windows 7 ou Windows Server 2008 R2, instale o hotfix descrito neste artigo.

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

Observação: "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esse hotfix, você deve estar executando o Windows 7 Service Pack 1 (SP1) ou o Windows Server 2008 R2 SP1.

Para obter mais informações sobre como obter um service pack do Windows 7 ou do Windows Server 2008 R2, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:

informações sobre o Service Pack 1 para o Windows 7 e Windows Server 2008 R2

Informações do registro:

Para aplicar esse hotfix, não é necessário efetuar quaisquer alterações ao registro.

Requisitos de reinicialização:

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui um hotfix lançado anteriormente.

A versão global deste hotfix instala arquivos que possuam os atributos listados nas tabelas a seguir. As datas e horas desses arquivos estão listadas no Tempo Universal Coordenado (UTC). As datas e horas desses arquivos em seu computador local são exibidas em sua hora local com a diferença de horário de verão (DST) atual. Além disso, as datas e as horas podem ser alteradas quando você realizar determinadas operações nos arquivos.

Observações sobre o arquivo Windows Server 2008 R2

  • Os arquivos que se aplicam a um produto, etapa (RTM, SPn) e ramificação do serviço (LDR, GDR) específicos podem ser identificados examinando os números de versão do arquivo, conforme exibido na seguinte tabela:

  • Os arquivos MANIFEST (. manifest) e os arquivos MUM (. mum) instalados para cada ambiente são listados separadamente na seção "Informações adicionais sobre arquivos para Windows Server 2008 R2". MUM e arquivos de manifesto e os arquivos de catálogo (. cat) de segurança associadas, são importantes para manter o estado do componente atualizado. Os arquivos do catálogo de segurança, para os quais os atributos não estejam listados, são assinados com uma assinatura digital da Microsoft.

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Mais informações

Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:

descrição da terminologia padrão usada para descrever as atualizações de software

Informações adicionais sobre os arquivos:

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