Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

Você usa muitos fluxos de trabalho Microsoft Dynamics CRM 4.0. As tabelas AsyncOperationBase e WorkflowLogBase crescem muito grandes e ocorrem problemas de desempenho.

Causa

Esse problema ocorre porque, quando as regras de fluxo de trabalho são disparadas, uma instância de fluxo de trabalho e um registro de fluxo de trabalho são criados nas tabelas AsyncOperationBase e WorkflowLogBase do banco de dados MSCRM. No entanto, quando a instância do fluxo de trabalho é concluída, o registro de fluxo de trabalho permanece no banco de dados. Portanto, as tabelas AsyncOperationBase e WorkflowLogBase continuam a crescer. Eventualmente, o desempenho diminui.

Observação A propriedade AsyncOperationType para esses registros está definida como 10.

Resolução

Esse problema é corrigido na última atualização cumulativa para Microsoft Dynamics CRM 4.0.
Para obter mais informações, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento da Microsoft:

949256 Microsoft Dynamics CRM atualizações 4.0 e hotfixes Importantes Esta seção, método ou tarefa contém etapas que lhe dizem como



modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para obter mais proteção, faça backup do Registro antes de modificá-lo. Dessa forma, você poderá restaurar o Registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:

322756 Como fazer backup e restaurar o Registro no Windows Depois de instalar o hotfix, para que ativemos esse hotfix para você, vá para a seção " Corrigir para

mim ". Se você preferir habilitar o hotfix por conta própria, vá para a seção "Let me fix it myself".

Corrigir para mim



Para habilitar o hotfix automaticamente, clique no botão Corrigir ou no link. Clique em Executar na caixa de diálogo Download de Arquivo e siga as etapas no assistente Fix it.




Observações

  • Esse assistente pode estar apenas em inglês. No entanto, a correção automática também funciona em versões do Windows em outros idiomas.

  • Se você não estiver usando o computador que apresenta o problema, salve a solução Corrigir em uma unidade flash ou em um CD e execute-a no computador que apresenta o problema.


Em seguida, vá para a seção "Isso corrigiu o problema?"



Desejo corrigir sozinho

Para habilitar esse hotfix, siga estas etapas:

  1. Clique em Iniciar,clique em Executar,digite regedit e clique em
    OK.

  2. No Editor do Registro, localize a seguinte subchave:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

  3. Determine se existe uma entrada do Registro DWORD chamada AsyncRemoveCompletedWorkflows. Os dados de valor da entrada do Registro AsyncRemoveCompletedWorkflows devem ser 1.

  4. Se a entrada do Registro AsyncRemoveCompletedWorkflows não existir, adicione a entrada. Para fazer isso, siga estas etapas:

    1. Clique com o botão direito do mouse em MSCRM,aponte para
      Novo,clique em Valor DWORDe digite
      AsyncRemoveCompletedWorkflows na
      caixa Nome.

    2. Clique duas
      vezes em AsyncRemoveCompletedWorkflowse digite
      1 na caixa De dados Valor.

    3. Clique em Iniciar,
      em Executar, digite iisreset e clique em
      OK.

      Observação Se o valor na caixa de dados Valor do valor DWORD AsyncRemoveCompletedWorkflows for reversível para 0, o Microsoft Dynamics CRM continuará a manter os registros de fluxo de trabalho no banco de dados, mesmo que as tarefas sejam concluídas.

Observação Este hotfix é somente proativo. Portanto, quando o hotfix é instalado e ativado, apenas novos registros de fluxo de trabalho são excluídos automaticamente. Se as tabelas AsyncOperationBase e WorkflowLogBase já são grandes devido a esses registros de fluxo de trabalho, você deve executar uma limpeza dessas tabelas usando o script de limpeza Microsoft SQL Server que está incluído no seguinte artigo da Base de Dados de Conhecimento da Microsoft:

968520 O desempenho será lento se a tabela AsyncOperationBase se tornar muito grande Microsoft Dynamics CRM 4.0

O problema foi corrigido?

  • Verifique se o problema foi corrigido. Se o problema tiver sido corrigido, você terá concluído esta seção. Se o problema não tiver sido corrigido, você poderá contatar o suporte.

  • Agradecemos pelos seus comentários. Para fornecer comentários ou relatar qualquer problema com essa solução, deixe um comentário no blog "Corrigirpara mim " ou envie uma mensagem de email.

Informações adicionais

Para obter mais informações sobre a terminologia de atualização de software, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento da Microsoft:

824684 Descrição da terminologia padrão usada para descrever atualizações de software da Microsoft Para obter mais informações sobre o hotfix de software do Microsoft Business Solutions CRM e a terminologia do pacote de atualização, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento da Microsoft:

887283 Hotfix de software do Microsoft Business Solutions CRM e padrões de nomenização de pacote de atualização

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×