Aplica-se aBizTalk Server Branch 2010 BizTalk Server Developer 2010 BizTalk Server Enterprise 2010 BizTalk Server Standard 2010 BizTalk Server 2013 Branch BizTalk Server 2013 Developer BizTalk Server 2013 Enterprise BizTalk Server 2013 Standard

Sintomas

Suponha que você tenha instalado o.NET Framework 4.5. x em um servidor que tenha o Microsoft BizTalk Server 2010 ou 2013 instalado. Depois disso, o Host do BizTalk instâncias falha com o código de erro 80131544 semelhante à seguinte no log de eventos:

Nome de logon: aplicativoCódigo-fonte: Runtime do .NETData:Identificação do evento: 1023Categoria da Tarefa: NenhumNível: erroPalavras-chave: clássicoUsuário: N/DComputador: <nome_do_servidor>Descrição:Aplicativo: BTSNTSvc64.exeVersão do Framework: v4.0.30319Descrição: O processo foi encerrado devido a um erro interno no Runtime do .NET na 000007FDED170BC1 IP (000007FDECE00000) com saída de código 80131544.Nome de logon: aplicativoOrigem: Erro de aplicativoData:Identificação do evento: 1000Categoria da tarefa: (100)Nível: erroPalavras-chave: clássicoUsuário: N/DComputador: <nome_do_servidor>Descrição:Nome do aplicativo com falha: BTSNTSvc64.exe, versão: 3.10.229.0, carimbo de data / hora: 0x50fe567aNome do módulo com falha: clr.dll, versão: 4.0.30319.19106, carimbo de data / hora: 0x51a512d4Código de exceção: 0x80131544Deslocamento com falha: 0x0000000000370bc1Id do processo com falha: 0xca8Com a hora de início do aplicativo: 0x01ceb6394f1dd32aCaminho do aplicativo com falha: <Nome do disco>: \Program (x86) arquivos \Microsoft 2013\BTSNTSvc64.exe do BizTalk ServerCaminho de módulo com falha: <Nome do disco>: \Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dllIdentificação do relatório: <ReportId>Com o nome completo do pacote:ID do aplicativo de pacote relativa com falha:Nome de logon: sistemaFonte: Gerenciador de controle de serviçoData:Identificação do evento: 7031Categoria da Tarefa: NenhumNível: erroPalavras-chave: clássicoUsuário: N/DComputador: <nome_do_servidor>Descrição:O grupo do BizTalk serviço BizTalk: BTSOrchHost service foi encerrado inesperadamente. Ele tem feito nesse 2 vez (es). A seguinte ação corretiva será tomada em 60000 milissegundos: reiniciar o serviço.

Causa

Esse problema ocorre porque você instala o.NET Framework 4.5 no ambiente do BizTalk Server e não é suportada oficialmente antes da atualização cumulativa 7 (CU7) para o BizTalk Server 2010. Você precisa usar o.NET Framework 4.0, quando você executa o BizTalk Server 2010 cumulativo Update 6 (CU6) ou anterior.

Resolução

Informações da atualização cumulativa

Esse problema foi corrigido primeiro na atualização cumulativa seguinte do BizTalk Server:

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Solução alternativa

Para contornar o problema, desative o encerramento de AppDomain XLANG seguindo as etapas:

  1. Localize a sua pasta do BizTalk Server. Por padrão, é C:\Program Files (x86) \Microsoft BizTalk Server 2013.

  2. Salve uma cópia do arquivo BTSNTSvc64.exe.config usando um novo nome.Observação: Salve uma cópia do arquivo BTSNTSvc.exe.config se trata de um host de 32 bits. Você pode verificar a mensagem de erro para ver se o travamento ocorre para BTSNTSvc.exe ou BTSNTSvc64.exe.

  3. Abra o arquivo original no bloco de notas e localize o nó < configuration >. Em seguida, diretamente abaixo dela, adicione o seguinte:<configSections>< nome da seção = "xlangs" type="Microsoft.XLANGs.BizTalk.CrossProcess.XmlSerializationConfigurationSectionHandler, Microsoft.XLANGs.BizTalk.CrossProcess" / ></configSections>

  4. Localize ao < / runtime > nó e adicione o seguinte:<xlangs><Configuration>< AppDomains AssembliesPerDomain = "50" >< DefaultSpec SecondsIdleBeforeShutdown = "-1" SecondsEmptyBeforeShutdown = "-1" / ></AppDomains></Configuration></xlangs>

  5. Recicle o host.

Mais informações

A partir do CU7, BizTalk Server 2010 oferece suporte a.NET Framework 4.0 e 4.5. x para o tempo de execução. CU7 pode ser instalado antes ou depois de instalar o.NET Framework 4.5.

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.