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Recomendação atualizada

Após aplicar o hotfix descrito na seção "Resolução", o serviço de Enterprise Single Sign-On (ENTSSO) apresenta um vazamento de memória. Portanto, recomendamos que você instale a correção mais recente .

Sintomas

Considere o seguinte cenário:

  • Você instalou o componente de versão 5 Enterprise Single Sign-On (SSO) está incluído no Microsoft BizTalk Server 2013 R2 ou o Host Integration Server 2013.

  • Em uma das seguintes situações, é possível restaurar a chave do segredo mestre de um arquivo de backup:

    • Quando você estiver configurando um cluster de SSO empresarial

    • Durante a recuperação de desastres SSO corporativo

    • Quando você está promovendo um servidor Enterprise SSO ao servidor o segredo mestre (MSS)

    • Durante a migração de uma versão anterior do Enterprise SSO

    • Durante uma atualização in-loco de uma versão anterior do Enterprise SSO

    • Quando você estiver executando várias sequências de backup e restauração de Enterprise SSO V5

Depois de restaurar a chave do segredo mestre em qualquer um desses cenários, SSO empresarial não pode descriptografar os dados contidos no banco de dados do SSO empresarial. Nessa situação, o Enterprise SSO registra o seguinte evento no log do aplicativo:

Identificação do evento: 10536
Fonte: ENTSSO
Nível: aviso
Função de auditoria de SSO: ID de controle GetConfigInfo ({11111111-6055-4cda-89CD-389E8A2B1640}): b084f15b-43fd-474e-a075-398943753c91 cliente computador: nome do computador (nome do executável: PID) usuário cliente: nome de usuário nome do aplicativo: nome do aplicativo de código de erro: 0x80090005, dados incorretos.

Além disso, o seguinte erro pop-up pode ser registrado quando você abrir o snap-in MMC de administração do BizTalk Server:

Administração do BizTalk Server
Dados incorretos.
(WinMgmt)
Botões:
Okey

Causa

Enterprise SSO V5 adiciona um carimbo de hora para o chave do segredo mestre para limitar o tempo de vida da chave. Além disso, uma verificação foi adicionada para determinar se a chave do segredo mestre contém um carimbo de hora. O problema descrito na seção "Sintomas" ocorre porque o serviço SSO empresarial determina incorretamente que o carimbo de hora está ausente quando o chave do segredo mestre é restaurado. Como um carimbo de hora foi adicionado para a chave do segredo mestre restaurada, a chave restaurada não coincide com a chave usada para criptografar os dados no banco de dados do SSO empresarial. Portanto, os dados não podem ser descriptografados e isso aciona as mensagens de erro descritas anteriormente.

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplica esse hotfix em todos os sistemas de Enterprise SSO V5 para evitar esse problema e para todos os sistemas que já estão enfrentando esse problema. Esse hotfix não requer nenhuma ação adicional para evitar e resolver o problema.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, envie uma solicitação ao suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=support

Observação: "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esse hotfix, você deve ter o Enterprise Single Sign-On V5 (9.0.2096) instalado.

Informações sobre reinicialização

Você terá que reiniciar o computador após aplicar esse hotfix.

Informações sobre o arquivo:

A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na Hora Universal Coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.

versão de 32 bits (x86)

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Infocache.dll

9.0.2187.0

130,536

01-Oct-2014

22:00

x86

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

113,128

01-Oct-2014

22:00

x86

versão de 64 bits (x64)

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Infocache.dll

9.0.2187.0

130,536

01-Oct-2014

22:00

x86

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

113,128

01-Oct-2014

22:00

x86

Infocache.dll

9.0.2187.0

151,528

01-Oct-2014

22:00

x64

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

124,392

01-Oct-2014

22:00

x64


Observação devido a dependências do arquivo, a correção mais recente que contém esses arquivos também pode conter arquivos adicionais.

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Mais informações

Você pode aplicar essa atualização em qualquer servidor de SSO empresarial que está apresentando o problema sem precisar de outras alterações. Além disso, esta atualização deve ser aplicada a todos os sistemas de Enterprise SSO V5 para evitar o problema quando você executar uma operação de restauração da chave secreta mestre.

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