Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

Considere o seguinte cenário:

  • Criar um modo de exibição de fonte de dados no Microsoft SQL Server Analysis Services (SSAS) que inclui uma fonte de dados do SQL Server e uma fonte de dados IBM DB2.

  • A fonte de dados do SQL Server está localizada em um sistema remoto de SQL Server de 64 bits.

  • Microsoft OLE DB Provider para DB2 4.0 está instalado na instância remota do SQL Server e do sistema em modo de exibição da fonte de dados está sendo criado.


Nesse cenário, a instrução de consulta que usa o modo de exibição de fonte de dados pode falhar com uma mensagem de erro semelhante à seguinte:

Classe não registrada

Causa

Provedor OLE DB para DB2 4.0 usa um valor ProgID de DB2OLEDB.1 quando um processo de 32 bits é carregado o provedor e um valor ProgID DB2OLEDB quando o provedor carregados por um processo de 64 bits. Nesse cenário, o Designer do SQL Server é executado como um processo de 32 bits. Portanto, ele passa a DB2OLEDB.1 para o sistema remoto do SQL Server. O processo do SQL Server de 64 bits não é possível localizar a classe DB2OLEDB.1 porque o provedor OLE DB para DB2 4.0 está registrado como DB2OLEDB. Essa situação faz com que a consulta falhe, pois o provedor OLE DB para DB2 4.0 não pode ser localizado.

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e Suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportObservação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esse hotfix, você deve primeiro desinstalar a instalação existente do Microsoft OLE DB Provider para DB2 4.0. Em seguida, use o arquivo. msi que está listado na seção "Informações sobre o arquivo" para instalar esse hotfix.

Informações sobre reinicialização

Você terá que reiniciar o computador após aplicar esse hotfix.

Informações sobre substituição

Esse hotfix não substitui nenhum hotfix lançado anteriormente.

Informações sobre o arquivo:

A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na Hora Universal Coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso Horário no item Data e Hora no Painel de Controle.

Provedor OLE DB da Microsoft para DB2 4.0

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Db2oledbv4_x64.msi

Não aplicável

4,073,472

26-Nov-2013

14:42

Não aplicável

Db2oledbv4_x86.msi

Não aplicável

2,992,640

26-Nov-2013

14:42

Não aplicável


Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Aviso de isenção de responsabilidade de informações de terceiros

Os produtos de terceiros descritos neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece nenhuma garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×