Sintomas

Considere o seguinte cenário: em um computador com o Microsoft Commerce Server 2009 instalado, executar o Assistente de configuração de serviços do Microsoft SharePoint Commerce (SharePointCommerceServicesConfiguration.exe) para criar um site padrão ou um site contemporâneo. Nesse cenário, o assistente não criar o site com êxito. Além disso, a seguinte mensagem de erro é registrada:

O trabalho de criar a chave de criptografia do perfil atingiu o out.* * * Erro: O trabalho de criar a chave de criptografia do perfil se esgotou. PILHA: em Microsoft.Commerce.Portal.Setup.CommandObjects.CreateProfileKeyCommand.Execute() em Microsoft.Commerce.Portal.Setup.UI.Confirmation.Timer_Tick (objeto remetente, EventArgs e) o trabalho de criar a chave de criptografia do perfil se esgotou. PILHA: Em Microsoft.Commerce.Portal.Setup.CommandObjects.CreateProfileKeyCommand.Execute() em Microsoft.Commerce.Portal.Setup.UI.Confirmation.Timer_Tick (objeto remetente, EventArgs e).

Causa

O problema ocorre porque o método CreateProfileKeyCommand.Execute() que usa o assistente define o tempo limite para 10 segundos. No entanto, em alguns ambientes pode levar mais de 10 segundos para criar uma chave de criptografia do perfil.

Resolução

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix. Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix. Observação caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportObservação o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.Observação Esse hotfix não se aplica ao pacote de modelos do Commerce Server 2009.

Pré-requisitos

Não existem pré-requisitos para instalar este hotfix.

Necessidade de reinicialização

Você não precisa reiniciar o computador após aplicar este hotfix.

Informações sobre a substituição de hotfixes

Este hotfix não substitui um pacote de hotfix lançado anteriormente.

Informações sobre os arquivos

A versão em inglês (Estados Unidos) deste hotfix usa um pacote do Microsoft Windows Installer para instalar o hotfix. As datas e horas desses arquivos estão listadas no tempo Universal Coordenado (UTC) na tabela a seguir. Quando você exibe as informações do arquivo, a data é convertida para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.

Nome do arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Microsoft.commerce.portal.setup.dll

1.0.20123.26

214,912

26-Sep-2010

21:37

x86

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a".

Informações adicionais

Para obter mais informações sobre como configurar o SharePoint Commerce Services, visite a seguinte página da Web do MSDN:

A configuração do SharePoint Commerce Services nos servidores Web

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.