Applies ToSystem Center Configuration Manager (current branch - version 1511)

Sintomas

Considere o seguinte cenário:

  • Você está executando o Microsoft System Center Configuration Manager versão 1511.

  • Você cria um grande número de pacotes (por exemplo, várias centenas) e os distribui para muitos pontos de distribuição de pull (por exemplo, milhares deles).

Quando o DistMgr processa arquivos .pul dos DPs (pontos de distribuição de pull) nesse cenário, o DistMgr executa a seguinte consulta, que leva de 3 a 4 segundos para ser executada quando há muitas linhas na tabela PkgStatus:

select s.ID, s.PkgServer, s.SiteCode, p.StoredPkgVersion, s.Status, r.PkgVersion, r.ActionState, r.ActionData, p.PkgFlags, p.ShareType from PullDPResponse r join PkgStatus s on r.PkgStatusID = s.PKID AND r.PkgStatusID = PUL_ID join SMSPackages p on s.ID = p.PkgID 

Causa

Esse problema ocorre porque a exibição PkgStatus usa uma instrução ISNULL e isso faz com que SQL executar uma Verificação de Índice em vez de uma Busca de Índice.

Resolução

Depois de aplicar esse hotfix e o DistMgr processar arquivos .pul dos DPs de pull, o DistMgr executará a seguinte consulta, que leva cerca de 28 milissegundos para ser executada:

select s.ID, s.PkgServer, s.SiteCode, p.StoredPkgVersion, s.Status, r.PkgVersion, r.ActionState, r.ActionData, p.PkgFlags, p.ShareType from PkgStatus2 s join PullDPResponse r on r.PkgStatusID = s.PKID AND s.PKID = 72057594038363660 join SMSPackages p on s.ID = p.PkgID 

Informações sobre o hotfix

Um hotfix com suporte está disponível Suporte da Microsoft. No entanto, esse hotfix destina-se a corrigir apenas o problema descrito neste artigo. Aplique esse hotfix somente a sistemas que estão enfrentando o problema descrito neste artigo. Esse hotfix pode receber testes adicionais. Portanto, se você não for gravemente afetado por esse problema, recomendamos aguardar a próxima atualização de software que contém esse hotfix.Se o hotfix estiver disponível para download, haverá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não aparecer, entre em contato com o Serviço de Atendimento ao Cliente e o Suporte da Microsoft para obter o hotfix. Observação Se ocorrerem problemas adicionais ou se alguma solução de problemas for necessária, talvez seja necessário criar uma solicitação de serviço separada. Os custos usuais de suporte serão aplicados a perguntas e problemas de suporte adicionais que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de Atendimento ao Cliente e Suporte da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportObservação O formulário "Download de hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter System Center Configuration Manager versão 1511 instalada.

Informações sobre reinicialização

Você não precisa reiniciar o computador depois de aplicar esse hotfix.

Informações sobre a substituição de hotfixes

Esse hotfix não substitui nenhum hotfix liberado anteriormente.

A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas em UTC (Tempo Universal Coordenado). Quando você exibe as informações sobre os arquivos, elas são convertidas no horário local. Para saber a diferença entre a hora UTC e a hora local, use a guia Fuso Horário no item Data e Hora do Painel de Controle.

File name

Versão do arquivo

Tamanho do arquivo

Data

Horário

Platform

Update.sql

Não Aplicável

20:46

24 de novembro de 2015

01:00

Não aplicável

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a".

Referências

Saiba mais sobre a terminologia que a Microsoft usa para descrever as atualizações de software.

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.