Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

Considere o seguinte cenário:

  • Você tem a atualização cumulativa 7 para Microsoft SQL Server 2012 Service Pack 1 (SP1) instalado.

  • Você ativa o recurso de grupos de disponibilidade do AlwaysOn no SQL Server 2012.

  • Você ativa o recurso de envio de Log para alguns bancos de dados no grupo de disponibilidade do AlwaysOn.

  • Definir a preferência de backup para o grupo de disponibilidade para Preferir secundário.

  • Executar a função de sistema sys.fn_hadr_backup_is_preferred_replica para determinar se o atual réplica é o preferencial backup tanto no banco de dados primário e secundário.

Nesse cenário, a função do sistema pode retornar 1 incorretamente a em ambos os lados.

Causa

Esse problema ocorre devido a uma regressão que ocorre quando é instalado o hotfix em 2887115 KB .

Cada nova atualização cumulativa para SQL Server contém todos os hotfixes e todas as correções de segurança que foram incluídas com as atualização cumulativa anterior. Confira as mais recentes atualizações cumulativas para o SQL Server:


Informações sobre o hotfixUm hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente aos sistemas que apresentarem esse problema específico.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, envie uma solicitação ao suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportObservação: "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Requisitos de reinicialização:Você não precisa reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:Esse hotfix não substitui um hotfix lançado anteriormente.

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×