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Sintomas

Considere o seguinte cenário:

  • Você tem um aplicativo da Web que está executando no Internet Information Services (IIS) 7.0 em um computador baseado no Windows Vista ou em um computador baseado no Windows Server 2008.

  • A autenticação do Windows e o modo Kernel autenticação estiver habilitada.

    Observação: Isso ocorre por padrão.

  • Você tem o useAppPoolCredentials atributo definido como verdadeiro na seção autenticação no arquivo applicationHost config. Você pode adicionar esse atributo para permitir o uso da autenticação Kerberos quando você usar uma conta de domínio para a identidade do pool de aplicativos. Por exemplo, esse atributo deve ser adicionado quando você estiver executando um site do Microsoft Office SharePoint Server. A seção de autenticação é semelhante ao seguinte.

    <windowsAuthentication enabled="true" useKernelMode="true" useAppPoolCredentials="true"/>

    Observação: O arquivo applicationHost config está localizado na unidade: \Windows\System32\inetsrv\config pasta.

Nesse cenário, o sistema operacional poderá falhar. Além disso, você recebe uma mensagem de erro 0x0000007e Stop em uma tela azul.

Observação: Esse problema normalmente ocorre em servidores Web que hospedam Office SharePoint Server 2007. Esse problema ocorre devido os requisitos de configuração do Office SharePoint Server 2007 quando a autenticação Kerberos é usada. No entanto, o problema pode ocorrer para qualquer tipo de site que está usando uma conta de domínio, a autenticação Kerberos e a autenticação de modo Kernel como a identidade do pool de aplicativos personalizado.

Causa

Esse problema ocorre devido a um bug em que o driver de modo kernel HTTP (http. sys).

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportObservação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Os hotfixes do Windows Vista e Windows Server 2008 importantes estão incluídos nos pacotes para o mesmos. No entanto, apenas um desses produtos pode estar listado na página "Solicitação de Hotfix". Para solicitar o pacote de hotfix que se aplica ao Windows Vista e Windows Server 2008, basta selecionar o produto que está listado na página.

Pré-requisitos:

Você deve ter o Windows Vista Service Pack 1 (SP1) ou Windows Server 2008 instalado para aplicar esse hotfix.

Requisitos de reinicialização:

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações sobre o arquivo:

A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na Hora Universal Coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso Horário no item Data e Hora no Painel de Controle.

O IIS 7.0, x86

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Http.sys

6.0.600 1.22375

401,408

12-Feb-2009

03:33

x86

O IIS 7.0, x64

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Http.sys

6.0.600 1.22375

596,480

12-Feb-2009

04:10

x64

IIS 7.0, IA-64

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Http.sys

6.0.600 1.22375

1,143,808

12-Feb-2009

02:54

IA-64

Solução alternativa

Para contornar esse problema, desative a autenticação de modo Kernel, usando um dos seguintes métodos.

Método 1

Defina o valor do elemento useKernelMode para false na seção windowsauthentication apropriado no arquivo applicationHost config.

<windowsAuthentication enabled="true" useKernelMode="false"/>

Método 2

Desabilite a autenticação de modo Kernel usando o Gerenciador do IIS. Para fazer isso, execute as seguintes etapas:

  1. Clique em Iniciar, Executar, tipo
    inetmgr.exee, em seguida, clique em OK.

  2. No Gerenciador do IIS, expanda
    nome do servidor, expanda sitese, em seguida, clique em site da Web que você deseja alterar.

  3. Clique duas vezes em autenticação, clique em Autenticação do Windows para realçá-lo e, em seguida, clique em Configurações avançadas no painel de ações.

  4. Clique para desmarcar a caixa Ativar autenticação de modo Kernel .

Depois que você desabilitar a autenticação de modo Kernel, você deve reiniciar o serviço HTTP. Isso irá parar o IIS. Execute os seguintes comandos em um prompt de comando elevado.

  • NET STOP HTTP

  • NET START HTTP

  • IISRESET /START

Observação: Esses comandos interromperá o serviço HTTP. Quando você parar o serviço HTTP, você recebe uma mensagem de aviso que os serviços que dependem do serviço HTTP também serão interrompidos. Tome cuidadosa nota desses serviços dependentes para que você possa determinar se deseja continuar e para que você possa reiniciá-los depois que você reiniciar o serviço HTTP. Os serviços que dependem do serviço HTTP dependem as funções do Windows e os aplicativos que estão instalados no computador.

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Mais informações

Saída de pilha de chamada

Se você usar as ferramentas de depuração para Windows e o Microsoft symbol server para examinar o arquivo de despejo de memória é criado após a falha ocorre, você notará uma pilha de chamadas semelhante à seguinte:
Child-SP RetAddr Call Sitefffffa60`02ff5b58 fffff800`01ba3644 nt!KeBugCheckEx
fffffa60`02ff5b60 fffff800`01b60f71 nt!PspUnhandledExceptionInSystemThread+0x24
fffffa60`02ff5ba0 fffff800`018c87d8 nt!PspSystemThreadStartup+0x9e
fffffa60`02ff5bd0 fffff800`018c86bd nt!_C_specific_handler+0x8c
fffffa60`02ff5c40 fffff800`018cfcff nt!RtlpExecuteHandlerForException+0xd
fffffa60`02ff5c70 fffff800`0188cd83 nt!RtlDispatchException+0x22f
fffffa60`02ff6360 fffff800`018b51a9 nt!KiDispatchException+0xc3
fffffa60`02ff6960 fffff800`018b3fa5 nt!KiExceptionDispatch+0xa9
fffffa60`02ff6b40 00000000`00010005 nt!KiPageFault+0x1e5
fffffa60`02ff6cd8 fffffa60`0805129e 0x10005
fffffa60`02ff6ce0 fffff800`01ad7ff3 HTTP!UlpThreadPoolWorker+0x28e
fffffa60`02ff6d50 fffff800`018ef546 nt!PspSystemThreadStartup+0x57
fffffa60`02ff6d80 00000000`00000000 nt!KxStartSystemThread+0x16
Observação: A parte da pilha de chamadas, o que indica que está ocorrendo esse travamento do sistema específico é HTTP! UlpThreadPoolWorker.

Referências

Para obter mais informações sobre como usar a autenticação Kerberos em conjunto com o Office SharePoint Server, visite os seguintes sites:

http://www.harbar.net/archive/2008/05/18/Using-Kerberos-with-SharePoint-on-Windows-Server-2008.aspx

http://blogs.msdn.com/webtopics/archive/2009/01/19/service-principal-name-spn-checklist-for-kerberos-authentication-with-iis-7-0.aspx

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