Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

BUG n º: 120793 (Manutenção do conteúdo)BUG #: 718934 (Dev10)

Sintomas

Quando você tenta instalar o Microsoft Commerce Server 2009 em um computador que esteja executando o Windows Server 2008 R2, a instalação falhará. Além disso, você recebe a seguinte mensagem de erro:

.NET Framework 3.5 com SP1 não está presente no computador. Você deverá instalar o.NET Framework 3.5 SP1 para continuar com a instalação.


Observação: Esse problema ocorre mesmo se você tiver o.NET Framework 3.5 Service Pack 1 (SP1) ou versões posteriores do.NET Framework instalado.

Causa

Durante a instalação do Commerce Server 2009, o programa de instalação procura uma chave do registro específica localizar o.NET Framework 3.5 SP1. No entanto, a versão do.NET Framework que é integrado ao Windows Server 2008 R2 não tem a chave do registro em questão. Portanto, o programa de instalação para de responder.

Resolução

Para resolver esse problema, aplique o seguinte hotfix no computador que está executando o Windows Server 2008 R2 antes de instalar o Commerce Server 2009.

Esse hotfix não atualiza os arquivos no seu computador. Esse hotfix irá criar as entradas do registro que são exigidas pelo instalador do Commerce Server 2009. Se as entradas necessárias do registro já existirem, o sistema exibirá a seguinte mensagem:

Você não precisa aplicar esse patch para esta máquina.É altamente recomendável que você remova esse hotfix depois que você instalou com êxito o Commerce Server 2009. Você pode desinstalar o hotfix usando o item programas e recursos no painel de controle.

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente aos sistemas que apresentarem esse problema específico.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, envie uma solicitação ao suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Números de telefone para obter uma lista completa de suporte e atendimento ao cliente Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:-

http://support.microsoft.com/contactus/?ws=supportObservação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Você deve ter o Windows Server 2008 R2 instalado para aplicar esse hotfix.

Requisitos de reinicialização:

Você não precisa reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui outros hotfixes.

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Mais informações

O suporte está disponível para a execução das seguintes versões do Commerce Server no Windows Server 2008 R2:

  • O Commerce Server 2009

  • Commerce Server 2007 Service Pack 2 (SP2)


Quando você atualiza do Windows Server 2008 para o Windows Server 2008 R2, Microsoft Commerce Server 2007 SP2 e Commerce Server 2009 funcionam conforme o esperado.

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×