Sintomas
Um dispositivo Thunderbolt pode parar de funcionar corretamente no Windows 10 nas seguintes situações:
Cenário 1: Quando várias vezes e rapidamente inserir e remover um dispositivo de Thunderbolt, a porta Thunderbolt pode parar de responder. Depois que a porta Thunderbolt está nesse estado, ele não reconhece mais nenhum dispositivo conectado.
Cenário 2: Quando você troca dois dispositivos Thunderbolt enquanto o computador está em um estado de hibernação, os dispositivos conectados do Thunderbolt podem não funcionar corretamente após o computador sair da hibernação. O Gerenciador de dispositivos indica que os dispositivos não estão funcionando com um ponto de exclamação amarelo e o código de erro 31.
Causa
Cenário 1: Esse problema ocorre porque o controlador de Thunderbolt está inacessível no momento em que o driver tenta acessá-lo.
Cenário 2: Essa situação pode resultar em portas de Thunderbolt configuradas incorretamente.
Resolução
Para resolver esses problemas, desconecte todos os dispositivos conectados às portas Thunderbolt, aguarde 5 segundos e, em seguida, reconecte os dispositivos.
O cenário 2 é resolvido na atualização de criadores de queda de 10 Windows (versão 1709). Para verificar se você instalou as atualizações mais recentes do Windows, Selecione Iniciar botão e selecione configurações > atualização & segurança > Windows Update . Em seguida, selecione Verificar se há atualizações.