Sintomas
Execute os procedimentos de limpeza após a migração no Microsoft Commerce Server 2009 R2. Quando você executa a ferramenta de CatalogCleanup.vbs ou o procedimento ctlg_DropPersistentTablesInScratchDB armazenado, você recebe uma mensagem de erro semelhante à seguinte:
Msg 245, nível 16, estado 1, linha 25
Falha ao converter o valor nvarchar 'Resultados' para o tipo de dados int. Falha ao converter o valor nvarchar 'Resultados' para o tipo de dados int.
Causa
Esse problema ocorre devido a um problema no procedimento ctlg_DropPersistentTablesInScratchDB armazenados.
Resolução
Para resolver esse problema, aplique esse hotfix.instruções de instalação".
Para concluir a instalação deste hotfix, consulte a seção "Informações sobre o hotfix
Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.
Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix. Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e Suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:http://support.microsoft.com/contactus/?ws=supportObservação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos:
Para aplicar esse hotfix, você deve ter o Service Pack 1 para o Commerce Server 2009 R2 instalado.
Instruções de instalação
Para resolver esse problema para novos bancos de dados do catálogo, execute o arquivo Cs2009r2sp1-kb2908786-x86.exe para atualizar o arquivo Catalogcreate.sql para o Commerce Server 2009 R2.
Além disso, você deve executar o arquivo Kb2908786.sql em relação os bancos de dados existentes do catálogo para atualizar os procedimentos armazenados.Informações sobre reinicialização
Você não precisa reiniciar o computador após aplicar esse hotfix.
Informações sobre remoção
Se você desinstalar esse hotfix, o Assistente de configuração do Commerce Server e o Assistente de atualização podem ser iniciada. Com segurança você pode clicar em Cancelar para cancelar novamente esses assistentes.
Informações sobre substituição
Esse hotfix não substitui um hotfix lançado anteriormente.
Informações sobre o arquivo:
A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na Hora Universal Coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso Horário no item Data e Hora no Painel de Controle.
Para o Commerce Server 2009 R2
Nome do Arquivo |
Versão do arquivo |
Tamanho do arquivo |
Data |
Hora |
Plataforma |
---|---|---|---|---|---|
Cs2009r2sp1-kb2908786-x86.exe |
9.0.60313.7 |
508,096 |
22-Nov-2013 |
08:55 |
x86 |
Kb2908786.sql |
Não aplicável |
5,669 |
22-Nov-2013 |
13:30 |
Não aplicável |
Catalogcreate.sql |
Não aplicável |
1,166,059 |
22-Nov-2013 |
00:40 |
Não aplicável |
Observação: Devido às dependências do arquivo, a correção mais recente que contém esses arquivos também pode conter arquivos adicionais.
Status
A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".
Referências
Consulte a terminologia Microsoft usa para descrever as atualizações de software.