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Sintomas

Falha na autenticação de fallback de autenticação (MFA) de multifatores através do Proxy de serviços de Federação do Active Directory (ADFS).

Causa

Esse problema ocorre devido a um limite embutido em código de proxy do ADFS. Quando o tempo limite ocorre, você não conseguirá acessar aplicativos.

Resolução

Para corrigir esse problema, instale o maio 2016 update rollup para o Windows RT 8.1, 8.1 para Windows e Windows Server 2012 R2 (KB3156418).

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Mais informações

Configuração de exemplo de tempo limite

A seguir está um exemplo da maneira como Windows Management Instrumentation (WMI) de tempo limite de atualização:

  • Comandos para atualizar tempo limite precisam ser executado no modo elevado PowerShell no computador de proxy. As etapas são as seguintes:

    $x = get-WmiObject-ProxyService - namespace raiz/ADFS de classe
    $x.CongestionControlConnectionTimeout=300
    $x.put()

  • O exemplo define um tempo limite de 300 segundos (5 minutos), refletida no C:\windows\adfs\Config\microsoft.proxyservice.config.txt.

Observação: Configure sempre connectionTimeoutInSec em C:\windows\adfs\Config\microsoft.proxyservice.config.txt usando o WMI como explicado acima. Não recomendamos que você configure manualmente o connectionTimeoutInSec .

Informações de desinstalação

Se você desinstalar o pacote, as configurações de tempo limite estão ainda no arquivo. Portanto, quando você reiniciar o serviço de proxy, ele falhará informando que connectionTimeoutInSec (entrada anterior) é desconhecido. Para corrigir esse problema, remova manualmente a propriedade connectionTimeoutInSec do arquivo config.

Referências

Saiba mais sobre a terminologia usada pela Microsoft para descrever as atualizações de software.

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