Imprimir arquivos em uma ordem incorreta quando é selecionada a opção Agrupar ou você recebe uma mensagem de erro quando você usar formulários personalizados: "Falha do aplicativo spoolsv.exe"

Sintomas

Esta atualização corrige os seguintes problemas de impressão em um computador que esteja executando o Windows Vista ou Windows Server 2008.

Problema 1

Considere o seguinte cenário:

  • Você tenta imprimir um arquivo em um computador que esteja executando o Windows Vista ou Windows Server 2008.

  • A impressora usa o processador de impressão WinPrint.

  • Imprimir uma cópia de um documento de várias páginas.

  • Imprimir várias cópias de um documento de uma página.

  • Selecione a opção Agrupar na caixa de diálogo Imprimir .

Nesse cenário, a saída é ordenada como se a opção Agrupar não estiver selecionada.


Observação: Impressoras podem ter vários recursos que podem fazer com que a saída impressa conter mais páginas do que o arquivo original. Isso inclui os seguintes recursos:

  • Adicionar tampas frontal ou traseira

  • Inserir páginas em locais especificados em um trabalho de impressão

  • Inserir páginas separadoras

  • Imprimir um trabalho salvo. Por exemplo, adicionando uma carta de apresentação para um documento salvo e imprimi-los juntos como um único trabalho.

Problema 2

Considere o seguinte cenário:

  • Configurar um cluster de failover do servidor de impressão em um computador baseado no Windows Server 2008.

  • Instalar uma impressora que ofereça suporte a formulários personalizados no cluster. O suporte a formulários personalizados permite imprimir formulários personalizados, como cartões de mensagens, cartões de visita e outros formulários personalizados.

  • Criar uma entrada de Registro DWORD chamada AllowUserManageForms sob a seguinte subchave:

    HKLM\Cluster\Resources\<PrintSpoolerGUID>\Parameters
    Em seguida, você definir o valor da entrada do registro como 1.

  • No Painel de controle, clique em impressorase, em seguida, você criar um formulário personalizado na caixa de diálogo Propriedades do servidor de impressão .

  • Definir preferências de impressão da impressora para que a impressora possa usar o formulário personalizado.

  • Você mover o recurso de spooler de impressão rapidamente entre os dois nós várias vezes.

Nesse cenário, o serviço de spooler de impressão (Spoolsv.exe) é chamado para este trabalho de impressão falha. Além disso, uma mensagem de erro semelhante à seguinte é registrada no log do aplicativo:


Erro do aplicativo: Evento ID 1000

Falha geral: Falha de aplicativo spoolsv.exe, versão 6.0.6002.18005, carimbo de data / hora 0x49e03626, com falha módulo Ntdll. dll, versão 6.0.6002.18005, carimbo de data / hora 0x49e0421d, código de exceção 0xc0000005, deslocamento < deslocamento >, id de processo < id >, hora de início aplicativo < horário de início >.







Quando esse problema ocorre, o status do recurso spooler de impressão é exibido como "Online"pendente","Off-line pendente"ou"Online".

Observação: Você pode ainda receber essa mensagem de erro quando o recurso de spooler de impressão neste nó é movido com êxito no snap-in Gerenciamento de Cluster de Failover. Esse comportamento ocorre porque o serviço de spooler de impressão foi reiniciado.

Causa

Esse problema ocorre porque o serviço de spooler de impressão tenta acessar memória liberada. Isso faz com que o serviço de spooler de impressão falha.

Resolução

Um hotfix está disponível para solucionar os problemas listados acima.

Observação: Fila de impressão do impressora deve explicitely conjunto de driver da chave de registro SinglePageKeepCollate por chamando SetPrinterData API. Este valor não é definido por padrão.

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

Observação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esse hotfix, seu computador deve estar executando um dos seguintes sistemas operacionais:

  • Windows Vista Service Pack 1 (SP1)

  • Windows Vista Service Pack 2 (SP2)

  • Windows Server 2008

  • Windows Server 2008 Service Pack 2 (SP2)

Para obter mais informações sobre como obter um service pack do Windows Vista, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:

como obter o service pack mais recente para o Windows Vista

Para obter mais informações sobre como obter um service pack do Windows Server 2008, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:

como obter o service pack mais recente para o Windows Server 2008

Requisitos de reinicialização:

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações sobre o arquivo:

A versão global deste hotfix instala arquivos que possuam os atributos listados nas tabelas a seguir. As datas e horas desses arquivos estão listadas no Tempo Universal Coordenado (UTC). As datas e horas desses arquivos em seu computador local são exibidas em sua hora local com a diferença de horário de verão (DST) atual. Além disso, as datas e as horas podem ser alteradas quando você realizar determinadas operações nos arquivos.

Informações sobre o arquivo do Windows Vista e Windows Server 2008

Importante: Os hotfixes do Windows Vista e Windows Server 2008 hotfixes estão incluídos nos pacotes para o mesmos. No entanto, apenas "Windows Vista" é listado na página solicitação de Hotfix. Para solicitar o pacote de hotfix que se aplica a um ou ambos os sistemas operacionais, selecione o hotfix listado em "Windows Vista" na página. Sempre consulte a seção "Aplica-se a" nos artigos para determinar o sistema operacional real que cada hotfix se aplica.

  • Os arquivos que se aplicam a um produto específico, SR_Level (RTM, SPn) e ramificação do serviço (LDR, GDR) podem ser identificados ao examinar os números de versão do arquivo conforme mostrado na tabela a seguir:

  • Service Pack 1 está integrado na versão de lançamento do Windows Server 2008. Portanto, os arquivos da etapa RTM se aplicam somente ao Windows Vista. Os arquivos da etapa RTM tem um número de versão 6.0.0000. número de versão xxxxxx .

  • Os arquivos MANIFEST (. manifest) e os arquivos MUM (. mum) instalados para cada ambiente são listados separadamente na seção "Informações adicionais sobre arquivos para Windows Server 2008 e Windows Vista". Os arquivos MUM e arquivos de manifesto e os arquivos de catálogo (. cat) de segurança associadas são extremamente importantes para manter o estado do componente atualizado. Os arquivos do catálogo de segurança, para os quais os atributos não estejam listados, são assinados com uma assinatura digital da Microsoft.

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×