Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

No Portal de Negócios do Microsoft Dynamics GP ou no Microsoft Dynamics SL, você pode receber a seguinte mensagem de erro quando clicar em Site Configurações e clique em Gerenciar Usuários:

Erro do servidor no aplicativo '/'.
-------------------------------------------------------------------------------- usuário


inválido.


Descrição: ocorreu uma exceção não acarretada durante a execução da solicitação da Web atual. Revise o rastreamento de pilha para obter mais informações sobre o erro e de onde ele se originou no código.



Detalhes da exceção: Microsoft.BusinessFramework.Security.AuthenticationException: usuário inválido.



Erro de origem: uma exceção não acarretada foi gerada durante a execução da solicitação da Web atual. As informações sobre a origem e o local da exceção podem ser identificadas usando o rastreamento de pilha de exceção abaixo.



Rastreamento de pilha:


[AuthenticationException: usuário inválido.] Microsoft.BusinessFramework.UserManager.VerifyUser() +695 Microsoft.BusinessFramework.EnterpriseSession.Initialize(String enterpriseUrl) +1061 Microsoft.BusinessFramework.Security.EnterpriseInitializationModule.OnAcquireRequestState(Object sender, EventArgs e) +150 System.Web.SyncEventExecutionStep.System. Web.HttpApplication+IExecutionStep.Execute() +60 System.Web.HttpApplication.ExecuteStep(etapa IExecutionStep, Boolean& completedSynchronously) +87


--------------------------------------------------------------------------------

Version Information:
Microsoft .NET Framework Version:1.1.4322.2032;
ASP.NET Versão:1.1.4322.2032

Causa

Esse problema ocorre quando uma ou mais das seguintes condições são verdadeiras:

  • A conta de usuário usada para instalar o Portal de Negócios não tem as permissões corretas no servidor que está executando Serviços de Informações da Internet da Microsoft (IIS). A conta de usuário não é membro das funções corretas no computador que está executando Microsoft SQL Server.

  • A conta de usuário é membro de um domínio diferente do domínio no qual o Portal de Negócios foi instalado.

  • A conta de usuário não existe nas tabelas do Portal de Negócios no banco de dados do Dynamics ou no banco de dados do sistema.

  • A conta de usuário está danificada no Portal de Negócios.

  • A Segurança Aprimorada da Internet está habilitada.

Resolução

Para resolver esse problema, siga estas etapas. Depois de concluir cada etapa, clique em Site Configuraçõese clique em Gerenciar Usuários no Portal de Negócios. Quando você não receber a mensagem de erro mencionada na seção "Sintomas", você resolverá o problema. Quando isso for verdadeiro, você não precisa concluir as etapas restantes nesta seção. Sempre que você receber a mensagem de erro, vá para a próxima etapa.

  1. Verifique se a conta de usuário usada para instalar o Portal de Negócios tem pelo menos permissões de administrador local no servidor que está executando o IIS. Além disso, certifique-se de que a conta de usuário tenha um Microsoft SQL Server logon. Certifique-se de que o logon seja membro das seguintes funções de servidor SQL Server:

    • Administradores de Segurança

    • Criadores de banco de dados

  2. Certifique-se de que a conta de usuário seja membro do domínio e da rede na qual o Portal de Negócios está instalado. Além disso, verifique se o domínio tem um ambiente confiável definido na rede.

  3. Certifique-se de que a conta de usuário que está recebendo a mensagem de erro exista nas seguintes tabelas:

    • MbfUserWindowsIdentity

    • MbfUser


    Para verificar se a conta de usuário existe, execute a instrução a seguir SQL Analisador de Consulta ou SQL Server Management Studio. Para o Microsoft Dynamics GP, execute a instrução no banco de dados do Dynamics. Para o Microsoft Dynamics SL, execute a instrução no banco de dados do sistema.

    SELECT WINDOWSCREDENTIALS FROM MbfUserWindowsIdentity
    SELECT ALIAS FROM MbfUser

    Se a conta de usuário não existir nessas tabelas, o usuário que instalou o Portal de Negócios deverá remover e adicionar a conta de usuário usando o Portal de Negócios. Para obter mais informações sobre como remover ou adicionar uma conta de usuário, consulte a seção "Mais Informações".

  4. Se o problema persistir, faça com que o usuário que instalou o Portal de Negócios tente executar a tarefa. Se o usuário que instalou o Portal de Negócios não receber a mensagem de erro, a conta de usuário do usuário que recebeu a mensagem de erro poderá ser danificada. O usuário que instalou o Portal de Negócios deve remover e adicionar a conta de usuário usando o Portal de Negócios. Para obter mais informações sobre como remover ou adicionar uma conta de usuário, consulte a seção "Mais Informações".

  5. No servidor IIS, clique em Iniciar, clique em Painel de Controle,clique em Adicionar ou Remover Programas e clique em Adicionar/Remover Windows Componentes. Desarmem a caixa de seleção Segurança Aprimorada da Internet e, em seguida, prossiga pelo assistente para remover o programa.




    Observações

    • Se você quiser usar a Segurança Aprimorada da Internet, certifique-se de fazer logon usando um domínio\nome de usuário userID juntamente com a senha apropriada.

    • A Segurança Aprimorada da Internet não é necessária para uma verificação de segurança porque o Portal de Negócios autentica no domínio para cada usuário que tenta fazer logoff no programa.

Informações adicionais

Para remover e adicionar uma conta de usuário no Portal de Negócios, siga estas etapas.

Remover um usuário

  1. Iniciar Portal de Negócios. Use a conta de usuário usada para instalar o Portal de Negócios.

  2. No Business Portal 3.0, clique em Site Configuraçõese clique em Gerenciar usuários do Portal de Negócios.

    No Portal de Negócios para Dynamics GP 10 (e versões posteriores), clique em Ações do Site,em SiteConfigurações e em Usuários na seção Administração do Portal De Negócios.

  3. Na lista Lista de Usuários, selecione a conta de usuário.

  4. Na área Escolher uma Tarefa, clique em Remover Usuários.

  5. Na janela Remover Usuários do Portal De Negócios, clique para selecionar a conta de usuário que você deseja remover.

  6. Clique em Remover.

Adicionar um usuário

  1. Iniciar Portal de Negócios. Use a conta de usuário usada para instalar o Portal de Negócios.

  2. No Business Portal 3.0, clique em Site Configuraçõese clique em Gerenciar usuários do Portal de Negócios.

    No Portal de Negócios para Dynamics GP 10 (e versões posteriores), clique em Ações do Site,em SiteConfigurações e em Usuários na seção Administração do Portal De Negócios.

  3. Na área Escolher uma Tarefa, clique em Adicionar novos usuários. Conclua as etapas no Assistente adicionar usuários para adicionar a conta de usuário ao Portal de Negócios.

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×