Sintomas

Considere o seguinte cenário no Microsoft SQL Server:

  • Você cria uma publicação de tipo de replicação de mesclagem.

  • Você configura esta publicação para usar um resolvedor baseado em COM da Microsoft para resolver conflitos.

  • Você configura um artigo que inclui uma coluna de tipo de dados aritmético (como int, smallint, numerice assim por diante).

  • Você configura a coluna tipo de dados aritmético como informações do resolvedor e o resolvedor de artigo como um dos seguintes:

    • Resolvedor de conflitos aditiva do Microsoft SQL Server

    • Resolvedor de conflitos em média do Microsoft SQL Server

    • Resolvedor de conflitos máximo do Microsoft SQL Server

    • Resolvedor de conflitos mínimo do Microsoft SQL Server

  • Crie uma assinatura para a publicação.

Nesse cenário, a sincronização falha quando um conflito é detectado e você recebe a seguinte mensagem de erro:

O resolvedor personalizado deste artigo exige o OLEAUT32. DLL com uma versão mínima do 2.40.4276.

Causa

Esse problema ocorre devido a uma verificação incorreta na versão do "C:\Windows\System32\OLEAUT32. DLL "File.

Resolução

Informações de atualização cumulativa do SQL Server:

Esse problema foi corrigido nas seguintes atualizações do SQL Server:

Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e correções de segurança que foram incluídos na atualização cumulativa anterior. Confira as atualizações cumulativas mais recentes do SQL Server:

Atualização cumulativa mais recente do SQL Server 2016

Atualização cumulativa mais recente do SQL Server 2014

Atualização cumulativa mais recente do SQL Server 2012 SP3

Informações do Service Pack para SQL Server:

Este problema foi corrigido no seguinte Service Pack para SQL Server:

      Service Pack 4 para SQL Server 2012

Para obter mais informações sobre como obter o Service Pack mais recente, consulte como obter o Service Pack mais recente para o SQL Server 2012

Sobre Service Packs para SQL Server

Service packs são cumulativos. Cada novo Service Pack contém todas as correções que estão em Service Packs anteriores, juntamente com qualquer nova correção. Nossa recomendação é aplicar o Service Pack mais recente e a atualização cumulativa mais recente para esse Service Pack. Você não precisa instalar um Service Pack anterior antes de instalar o Service Pack mais recente. Use a tabela 1 no artigo a seguir para encontrar mais informações sobre o Service Pack mais recente e a atualização cumulativa mais recente.

Como determinar o nível de versão, edição e atualização do SQL Server e seus componentes

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a".

Referências

Saiba mais sobre a terminologia usada pela Microsoft para descrever atualizações de software.

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade da tradução?
O que afetou sua experiência?

Obrigado por seus comentários!

×