Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

Suponha que você Execute uma imagem do contêiner do SQL Server 2017 Linux no Docker para Windows. Quando imagens do Docker são usadas para provisionar contêineres e você usa o local de montagem de volume (local padrão de/var/opt/MSSQL) ou qualquer diretório pai, o SQL Server não será iniciado. Além disso,você recebe uma mensagem de erro semelhante à seguinte:

data e hora do erro do spid6s: 17053, severidade: 16, estado: 1. data e hora do spid6s de/var/opt/MSSQL/Data/mastlog.ldf: erro de sistema operacional 31 (um dispositivo conectado ao sistema não está funcionando.) encontrado. data e hora do erro do spid6s: 9002, severidade: 17, estado: 0. data e hora spid6s o log de transação do banco de dados ' mestre ' está cheio por causa de ' Nothing '. data e hora do erro do spid6s: 928, severidade: 20, estado: 1.

Causa

Esse problema ocorre porque o diretório do Windows é montado como um CIFS (sistema de arquivos da Internet) comum dentro do contêiner do Docker. O CIFS não é oficialmente compatível com o sistema de arquivos do SQL Server no Linux.

Resolução

A correção para esse problema está incluída na atualização a seguir para SQL Server:

Atualização cumulativa 7 para SQL Server 2017

Sobre as compilações do SQL Server

Cada novo Build do SQL Server contém todos os hotfixes e correções de segurança que estavam na compilação anterior. Recomendamos instalar o Build mais recente para a sua versão do SQL Server:

A compilação mais recente do SQL Server 2017

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplicável a".

Referências

Saiba mais sobre a terminologia padrão que a Microsoft usa para descrever atualizações de software.

Os produtos de terceiros mencionados neste artigo são produzidos por empresas independentes da Microsoft. A Microsoft não oferece nenhuma garantia, implícita ou não, do desempenho ou da confiabilidade desses produtos.

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×