Observação: Este artigo documenta a resolução de um problema conhecido documentado no estado de funcionamento da versão do Windows e no centro de administração da Microsoft.
Sintomas
Um pequeno subconjunto de clientes do Azure Virtual Desktop que utilizam anfitriões de várias sessões (AVD) e instalaram o Windows Atualizações lançados entre 23 de julho de 2024 (KB5040525) e 8 de outubro de 2024 (KB5044273) podem ter os seguintes problemas:
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Um travamento prolongado de 10 a 30 minutos em uma tela preta após o login do usuário.
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As aplicações do Office, incluindo o Outlook e o Teams, experimentam falhas de início de sessão único (SSO), impedindo os utilizadores de se ligarem ou sincronizarem dados.
Causa
Este problema é causado por um impasse nas interações entre o mediador do Azure Active Directory (AAD) e o serviço de implementação appX subjacente (AppxSvc) e o serviço de infraestrutura de tarefas em segundo plano. É mais provável que se deparar com este problema se estiver a utilizar contentores de perfis de utilizador do FSLogix em ambientes de várias sessões. O FSLogix é uma ferramenta da Microsoft que ajuda a gerenciar e acelerar os perfis de usuário em computadores, especialmente em ambientes virtuais como áreas de trabalho remotas.
Windows 10 Education utilizadores da edição e utilizadores domésticos do Windows que utilizam as edições Home ou Pro são pouco prováveis de enfrentar este problema, uma vez que o Azure Virtual Desktop é mais utilizado em ambientes empresariais.
Resolução
Para resolve este problema, aplique uma das seguintes opções se observar o ID de Evento microsoft-Windows-AppModel-State 10 no Registo de Eventos da Aplicação com a seguinte assinatura,
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Descrição: Falha ao carregar as definições da aplicação para o pacote Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
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Código de Erro: -2147024893
Opção 1: voltar a imagem do dispositivo afetado
Siga estes passos para criar uma nova imagem personalizada com a imagem mais recente da galeria "Windows 10 Enterprise várias sessões, Versão 22H2" do Azure Marketplace:
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Aceda ao microsoft Azure Marketplace. Na barra de pesquisa Pesquisar no Marketplace, escreva Microsoft Windows 10.
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Na página microsoft Windows 10, clique em Obter Agora.
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Inicie sessão assim que lhe for pedido para introduzir o seu endereço de e-mail.
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Na página Criar esta aplicação no Azure, selecione Windows 10 Enterprise várias sessões, versão 22H2 na lista pendente Plano de software.
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Depois de selecionar a imagem, clique em Criar para criar uma nova máquina virtual.
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Siga estes passos na página Criar uma imagem dourada no Azure:
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Crie uma imagem a partir de uma VM do Azure para criar a imagem personalizada.
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Personalize a VM e, em seguida, instale o Windows Update de 24 de outubro de 2024 (KB5045594).
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Agora, pode recriar a imagem do seu dispositivo AVD afetado com a imagem personalizada recentemente criada no Passo 6.
NOTA Se quiser uma imagem que inclua a correção KB5045594 para este problema, terá de esperar até 19 de novembro de 2024 para recriar a imagem do seu dispositivo (para evitar o passo 6).
Opção 2: Instalar o KB5045594 de atualização do Windows e adicionar o script de início de sessão do utilizador
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Efetue uma atualização no local do dispositivo afetado com Windows 10 atualização 22H2 (KB5045594).
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Após a instalação da atualização do Windows (KB5045594), para os utilizadores que não têm um script de início de sessão existente, crie um novo ficheiro de script do PowerShell (.ps1) e, em seguida, adicione o comando do PowerShell mencionado abaixo:
Add-AppxPackage -Register -Path "C:\Windows\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\AppxManifest.xml" -DisableDevelopmentMode
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Se já tiver um script de início de sessão existente que utiliza um script do PowerShell no Política de Grupo, pode adicionar o comando do PowerShell mencionado no Passo 2 ao script do PowerShell existente.
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Para utilizar este script de início de sessão recentemente criado em dispositivos AVD associados ao ID híbrido do Entra ou associados a um domínio, siga o Passo 5 na secção Para atribuir o script de início de sessão do utilizador.
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Para utilizar este script de início de sessão recentemente criado em dispositivos AVD associados apenas ao Entra ID, siga o passo 5 na secção Para atribuir scripts de início de sessão do utilizador.
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Se tiver um script de início de sessão existente num formato diferente do PowerShell, como um ficheiro de .bat ou .cmd, pode fazer o seguinte
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Crie um novo ficheiro de scriptPowerShell.ps1 e adicione o comando do PowerShell mencionado no Passo 2.
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Em seguida, adicione um dos seguintes comandos ao ficheiro .bat ou .cmd para executar o script:
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Exemplo com um caminho SYSVOL de exemplo: powershell -File "scripts\script.ps1"
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Exemplo com um caminho local de exemplo: powershell -File "D:\scripts\script.ps1"
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Assistência adicional
Para obter assistência adicional sobre este problema, recomendamos que submeta um pedido de suporte ao Suporte do Azure.
Referências
Descrição da terminologia padrão usada para descrever atualizações de software da Microsoft