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Importante Este artigo contém informações sobre como modificar o registro. Certifique-se de fazer backup do registro antes de modificá-lo. Certifique-se de que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número seguinte do artigo para visualizar o artigo na Base de Conhecimento da Microsoft:

322756 Como fazer o backup e a restauração do Registro no Windows

Sintomas

Ao acessar um site através do Microsoft Internet Security and Acceleration (ISA) Server 2006 ou Microsoft Forefront Threat Management Gateway, Medium Business Edition, você recebe a seguinte mensagem de erro:

HTTP 400 - Pedido ruim

Esse problema pode ocorrer quando você acessa um site que é publicado no ISA Server 2006 ou no Microsoft Forefront Threat Management Gateway, Medium Business Edition. Esse problema também pode ocorrer quando você acessa um site por meio de uma regra de acesso HTTP que é definida no ISA Server 2006 ou no Microsoft Forefront Threat Management Gateway, Medium Business Edition.

Causa

Esse problema ocorre porque o ISA Server 2006 e o Microsoft Forefront Threat Management Gateway, a Medium Business Edition deixam as respostas http e solicitações http se seus cabeçalhos HTTP contivessem linhas de continuação.

Resolução

Os problemas sérios do aviso puderam ocorrer se você modifica o registro incorretamente usando o editor do registro ou usando um outro método. Esses problemas podem exigir que você reinstale o sistema operacional. A Microsoft não pode garantir que esses problemas possam ser resolvidos. Modifique o registro por sua conta e risco. Para resolver este problema, siga estas etapas:

  1. Para o ISA Server 2006, aplique o hotfix 941297. Para obter mais informações sobre este hotfix, clique no seguinte número do artigo para visualizar o artigo na Base de Conhecimento da Microsoft:

    941297 Descrição do pacote de hotfix ISA Server 2006: 15 de agosto de 2007

  2. Clique em Iniciar, em Executar, digite regedit e clique em OK.

  3. Localize e clique na seguinte subchave do Registro:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\Stingray\Debug\Web FiltersNota Se o subkey RAT\Stingray\Debug\Web Filters não existe, você deve criá-lo.

  4. No menu Editar, aponte para Novo e clique em Valor DWORD.

  5. Digite APPEND_CONTINUATION_LINES,e, em seguida, pressione ENTER.

  6. No menu Editar, clique em Modificar.

  7. Na caixa Dados do valor, digite 1 e clique em OK.

  8. Saia do Editor do Registro.

Depois de seguir esses passos, a primeira linha de continuação é anexada à linha de cabeçalho principal. As linhas de continuação restantes são deixadas cair.

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a".

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