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Sintomas

Quando você tenta se conectar a um volume de StorSimple para o ESX Server, você pode enfrentar problemas de conectividade ocasional. Esse problema ocorre quando os registros de controle de acesso (ACRs) estão configurados para o ESX Server usando endereços IP.

Este artigo descreve os detalhes sobre este problema e as práticas recomendadas para impedir que ele. Este artigo se aplica a v 1.2.1, v 2.0.1 e v2.1.1 StorSimple.

Causa

Quando um ACR é configurado usando um endereço IP em um ESX server, correspondência de endereço IP é executada antes que o acesso aos volumes de StorSimple está ativado. Isso significa que somente as conexões que correspondem ao endereço IP específico podem acessar os volumes. Se o servidor em questão tem vários endereços IP, mas os ACRs são configurados para que nem todos os caminhos para a rede são incluídos, o usuário poderá ter problemas de conectividade.

Por exemplo, suponha que o servidor host possuir dois endereços IP, 10.2.43.60 (iSCSI) e 10.2.43.61 (gerenciamento). Isso podem ser usados para conectar-se aos respectivos volumes de StorSimple. Em seguida, o usuário cria um ACR e o associa com apenas um desses endereços IP — 10.2.43.60, por exemplo. Nesse cenário, há um caminho de rede (para 10.2.43.61) para o qual não há ACR é definida. Se houver mais de um caminho de rede para o servidor, os ACRs devem ser configurados para incluir todos os caminhos.

Se um usuário tiver essa configuração, ele ou ela é provável encontrar problemas de conectividade. Por exemplo, se a conexão do usuário iniciador que usa o IP iSCSI endereço para e o iniciador se conecta novamente, usando o endereço IP de gerenciamento (com o kernel de máquina virtual habilitado), o usuário pode se conectar neste momento. No entanto, os volumes de StorSimple não serão expostos. Portanto, os volumes desaparecerá.

Resolução

Para resolver esse problema, configure a ACR para usar a correspondência de nome qualificado (IQN) iSCSI em vez de um endereço IP. Isso garante que uma conexão proveniente de qualquer porta de kernel VM terá acesso ao volume.

Essa resolução requer um processo de duas etapas.

Etapa 1: Localizando IQN no ESX server

  1. Desligue todas as VMs em execução são armazenadas no volume StorSimple.

  2. Acesse o servidor ESX para extrair o IQN dos iniciadores de iSCSI do ESX server. Para fazer isso, execute as seguintes etapas:

    1. Faça logon no seu VSphere.

    2. Clique em início, clique em estoquee, em seguida, clique em Clusters e Hosts.

    3. No painel de navegação, selecione o servidor ESX. No painel de detalhes, clique na guia configuração .

    4. Selecione adaptadores de armazenamento.

    5. Em iSCSI Software adaptador para o dispositivo, clique em vmhba # #. No painel de detalhes, clique em Propriedades.

    6. No painel Propriedades , selecione o IQN é exibido e, em seguida, copiá-lo.

  3. Repita a etapa 2 em todos os servidores ESX.


A interface web do usuário (UI) também deve ser configurada. Para fazer isso, o IQN deve ser aplicado sob o registro de controle de acesso na interface de usuário da Web do aparelho StorSimple:

  1. Faça logon no Web StorSimple da interface do usuário.

  2. Clique em configuração, clique em Configurações de segurançae, em seguida, clique em Registro de controle de acesso.

  3. Para o registro de controle de acesso especificado para o ESX server que é mencionado na etapa 2 da "etapa 1: Localizando IQN no ESX server" seção, clique no ícone Editar.

  4. Na caixa endereço IP , exclua o endereço IP que inclui um asterisco (*) e, em seguida, colar na caixa IQN IQN que você copiou na etapa 2F da "etapa 1: Localizando IQN no ESX server" seção.

  5. Clique na marca de seleção verde para salvar o registro de controle de acesso.

Repita estas etapas em todos os servidores ESX.

Observação: A conexão iSCSI do ESX server deve ser desconectada e reconectada.

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