Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

Considere o seguinte cenário:

  • Você tem um computador que esteja executando o Windows 8 ou o Windows Server 2012.

  • Imprimir um arquivo usando um aplicativo de 32 bits.

  • O trabalho de impressão é concluído com êxito.

Nesse cenário, o processo de Splwow64.exe não finalizar imediatamente.

Observação: O processo de Splwow64.exe é usado para converter o modelo de driver de um sistema operacional de 64 bits e um programa de 32 bits. Splwow64.exe é usado para suportar o recurso de isolamento de Driver de impressora. A versão de 32 bits do Windows 8 tem seu próprio arquivo de Splwow64.exe e a versão de 32 bits do Splwow64.exe também é afetada por esse problema. Para obter mais informações sobre o isolamento de aplicativos, consulte o seguinte site da MSDN:

Causa

Esse problema ocorre porque o processo de Splwow64.exe permanece na memória por mais tempo do que o necessário para aumentar o desempenho do sistema após a conclusão de um trabalho de impressão.

Resolução

Esse hotfix também está disponível no .

Depois de aplicar esse hotfix, o hotfix define o valor de tempo limite padrão para o processo de Splwow64.exe permaneça na memória para dois minutos. Portanto, o processo de Splwow64.exe termina dois minutos após o último trabalho de impressão. Além disso, você pode configurar esse valor de tempo limite, alterando o valor do registro. Para configurar o valor de tempo limite, execute essas etapas:

Importante: essa seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer caso você modifique o registro incorretamente. Portanto, certifique-se de seguir estes passos cuidadosamente. Para obter mais proteção, faça backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro caso ocorra um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número do artigo a seguir para visualizá-lo na Base de Dados de Conhecimento da Microsoft:

como fazer backup e restaurar o registro no Windows

  1. Passe o dedo na borda direita da tela e, em seguida, toque em Pesquisar. Ou, se você estiver usando um mouse, aponte para o canto inferior direito da tela e, em seguida, clique em Pesquisar.

  2. Na caixa Pesquisar, digite regedite, em seguida, toque ou clique em regedit.

    UAC Se você for solicitado a digitar uma senha de administrador, digite a senha. Se você for solicitado a fornecer confirmação, forneça a confirmação.

  3. Localize e, em seguida, toque ou clique na seguinte subchave do registro:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print

  4. No menu Editar , aponte para novoe, em seguida, toque ou clique em Valor DWORD.

  5. Tipo SplWOW64TimeOutSeconds.

  6. Pressione e mantenha ou clique SplWOW64TimeOutSecondse, em seguida, toque ou clique em Modificar.

  7. Na caixa dados do valor , digite um valor e, em seguida, toque ou clique em OK.

  8. Saia do Editor de Registro.

Observação: Você deve inserir um valor que é maior do que zero na caixa dados do valor . O valor que você inserir é de segundos que o sistema aguarda periodicamente enquanto verifica se o processo de Splwow64.exe é descarregado. Esse comportamento ocorre quando o mesmo número de segundos decorrido após ter fechado o último processo de impressão de 32 bits. Portanto, quando um impressões de processo de serviço, o recurso de impressão não será lançada até que o serviço é fechada e a passou pelo menos o tempo que você especificar na caixa dados do valor . Por exemplo, se você digitar 15 na caixa dados do valor e o último processo de 32 bits leva dois minutos para imprimir e, em seguida, fechar, o recurso de impressão é liberado entre dois minutos e 15 segundos e dois minutos e 30 segundos. Se nenhum valor de tempo limite é especificado, o valor de tempo limite padrão é 2 minutos.

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente aos sistemas que apresentarem esse problema específico.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, envie uma solicitação ao suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

Observação: "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esse hotfix, você deve estar executando o Windows 8 ou o Windows Server 2012.

Informações do registro:

Para usar o hotfix neste pacote, não é necessário efetuar quaisquer alterações no registro.

Requisitos de reinicialização:

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui um hotfix lançado anteriormente.



A versão global deste hotfix instala arquivos que possuam os atributos listados nas tabelas a seguir. As datas e horas desses arquivos estão listadas no Tempo Universal Coordenado (UTC). As datas e horas desses arquivos em seu computador local são exibidas em sua hora local com a diferença de horário de verão (DST) atual. Além disso, as datas e as horas podem ser alteradas quando você realizar determinadas operações nos arquivos.





Informações sobre o arquivo do Windows 8 e o Windows Server 2012Importante: Os hotfixes do Windows 8 e os hotfixes do Windows Server 2012 estão incluídos nos pacotes para o mesmos. No entanto, apenas "Windows 8" é listado na página solicitação de Hotfix. Para solicitar o pacote de hotfix que se aplica a um ou ambos os sistemas operacionais, selecione o hotfix listado em "Windows 8" na página. Sempre consulte a seção "Aplica-se a" nos artigos para determinar o sistema operacional real que cada hotfix se aplica.

  • Os arquivos que se aplicam a um produto, etapa (RTM, SPn) e ramificação do serviço (LDR, GDR) específicos podem ser identificados examinando os números de versão do arquivo, conforme exibido na seguinte tabela:

  • As ramificações do serviço GDR contêm somente correções amplamente disponibilizadas para resolver problemas críticos que sejam bastante conhecidos. As ramificações do serviço LDR contém hotfixes, além de correções amplamente disponibilizadas.

  • Os arquivos MANIFEST (. manifest) e os arquivos MUM (. mum) instalados para cada ambiente são listados separadamente na seção "Informações adicionais sobre arquivos para Windows 8 e Windows Server 2012". MUM e arquivos de manifesto e os arquivos de catálogo (. cat) de segurança associadas são extremamente importantes para manter o estado dos componentes atualizados. Os arquivos do catálogo de segurança, para os quais os atributos não estejam listados, são assinados com uma assinatura digital da Microsoft.

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Mais informações

Para obter mais informações sobre o problema semelhante, clique nos números abaixo para visualizar os artigos na Base de Conhecimento da Microsoft:

Splwow64.exe processo não termina após a conclusão de um trabalho de impressão na versão de 64 bits do Windows 7 ou Windows Server 2008 R2

não é possível usar o comando "runas" para imprimir a partir de diferentes contas de usuário em uma única sessão de um programa de 32 bits em um computador que esteja executando a versão de 64 bits do Windows Server 2008 ou Windows Vista
Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:

descrição da terminologia padrão usada para descrever as atualizações de software

Informações sobre arquivo adicional para Windows 8 e o Windows Server 2012

Arquivos adicionais para todas as versões com suporte para o Windows 8 x86

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×