Aplica-se a
Exchange Server 2019

Sintomas

Depois de instalar uma atualização para o Microsoft Exchange Server 2019, você pode obter resultados incompletos ao pesquisar itens em uma caixa de correio.

Causa

Durante cada Exchange Server atualização, o Pesquisa da Microsoft Foundation é reinstalado. Embora esse processo nem sempre seja concluído com êxito, essa falha não impede que a atualização Exchange Server seja concluída.

Nessa situação, o servidor atualizado parece estar totalmente funcional. No entanto, vários problemas afetarão os serviços associados ao Pesquisa da Microsoft Foundation. Por exemplo, o serviço Exchange Pesquisa da Microsoft está desabilitado ou o processo Noderunner.exe é interrompido. Devido a esses problemas, o servidor que está executando o Exchange Server interrompe a indexação de itens de caixa de correio. Se a falha de indexação continuar por um período estendido, os itens de caixa de correio que não são indexados entrarão em um estado de falha permanente.

A qualquer momento após os itens entrarem nesse estado de falha, se os problemas que afetam os processos de pesquisa são corrigidos, o servidor retomará a indexação de itens. Por padrão, no entanto, o servidor não tentará indexar os itens que entraram em um estado de falha permanente. Portanto, esses itens não aparecerão nos resultados da pesquisa.

Resolução

Para resolver esse problema, crie uma nova substituição para os itens que estão em um estado de falha permanente e, em seguida, reindexe os itens. Execute as seguintes etapas:

  1. Crie uma substituição de configuração executando o seguinte cmdlet:New-SettingOverride -Name "Big Funnel Permanent Retry" -Component "BigFunnel" -Section "BigFunnelFailedItemsQuerySettings" -Parameters @("ExcludePermanentFailures=false") -Reason "Re-Index Messages" -MinVersion "<Build Number>" -MaxVersion "<Build Number>"Observação Neste cmdlet, substitua <Build Number> pelo número do build Exchange Server que está sendo executado no servidor que contém a caixa de correio afetada.

  2. Atualize a configuração executando o seguinte cmdlet:Get-ExchangeDiagnosticInfo -Process Microsoft.Exchange.Directory.TopologyService -Component VariantConfiguration -Argument Refresh Depois de executar esse cmdlet, você deverá ver o arquivo BigFunnel.Overrides.ini no diretório %ExchangeInstallPath%\v15\config.

  3. Acionar Exchange Server para indexar os itens de caixa de correio que não foram indexados anteriormente. Para fazer isso, execute o seguinte cmdlet:Start-MailboxAssistant -Identity <mailbox ID> -AssistantName BigFunnelRetryFeederTimeBasedAssistant

    Observações: 

    • Neste cmdlet, substitua <ID da caixa de correio> pelo nome da caixa de correio afetada.

    • O nome do assistente usado no cmdlet (BigFunnelRetryFeederTimeBasedAssistant) é sensível a minúsculas.

    • O cmdlet está disponível Exchange Server atualização cumulativa 11 e versões posteriores do 2019.

    Este cmdlet não aborda todos os problemas relacionados ao índice. Em vez disso, ele lembra o Exchange de Pesquisa para indexar itens que nunca foram indexados e estão no estado Não Indexado.

Observação: A substituição de configuração ajuda você a evitar ter que mover caixas de correio para reindexar itens. No entanto, recomendamos que você não deixe o conjunto de substituição no ambiente permanentemente porque ele pode causar maior uso da CPU. Depois que os itens são reindexados, remova a substituição usando o cmdlet Remove-SettingOverride .

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.