Serviço de grupo de resposta redireciona chamadas para a ação de chamar de estouro da fila em um ambiente do Lync Server 2010

Sintomas

Considere o seguinte cenário:

  • Implantar o serviço de grupo de resposta (RGS) em um ambiente do Microsoft Lync Server 2010.

  • Criar uma fila de grupo de resposta com estouro de fila habilitado. Além disso, você definir as configurações de ação de chamada para quando o limite da fila do estouro é atendido.

  • Alguns usuários chamam o RGS.

  • O RGS transfere com êxito as chamadas de entrada para alguns agentes.

  • O limite de estouro da fila não for atendido.

Nesse cenário, RGS redireciona inesperadamente uma nova chamada de entrada para a ação de chamar de estouro da fila.

Observação: A ação esperada é que a nova chamada de entrada aguarda na fila ou transferida para um agente disponível.

Causa

Esse problema ocorre devido a uma condição de corrida no RGS. A condição de corrida impede que uma chamada manipulado com êxito pelo RGS sejam excluídas do banco de dados. Quando várias chamadas não são excluídas, o limite da fila do estouro é excedido. Portanto, a ação de chamar de estouro da fila é acionada.

Resolução

Para resolver esse problema, instale a seguinte atualização cumulativa:

2847888 descrição da atualização cumulativa para o Lync Server 2010, Unified Communications Managed API 3.0 em tempo de execução: julho de 2013

Mais informações

Para obter mais informações sobre como criar uma fila de grupo de resposta, consulte o seguinte site da Microsoft:

Como criar uma fila de grupo de respostaPara obter mais informações sobre como gerenciar fluxos de trabalho de grupo de resposta, consulte o seguinte site da Microsoft:

Como gerenciar fluxos de trabalho de grupo de resposta

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Obrigado por seus comentários!

×