Sintomas
Considere o seguinte cenário:
-
Você cria muitas coleções dinâmicas em um System Center Configuration Manager de sites do Service Pack 2 (SP2) usando as regras baseadas em consulta. Por exemplo, você cria vários milhares dessas coleções.
-
No console Configuration Manager, clique em Atualizar para exibir a associação mais recente em uma coleção dinâmica.
Nesse cenário, o console Configuration Manager requer muito tempo para exibir a associação mais recente. Esse atraso dura de vários minutos a várias horas.
Causa
Esse problema ocorre porque o Avaliador de Coleção mantém uma fila FIFO (primeiro a entrar, primeiro a sair) para lidar com as solicitações de avaliação da coleção.
Quando você clica em Atualizar para exibir a associação mais recente de uma coleção, essa solicitação é colocada no final de uma fila FIFO. Se o número de solicitações anteriores for muito grande, o Avaliador de Coleção exigirá muito tempo para concluir as solicitações anteriores. Portanto, um longo atraso ocorre antes de você exibir os resultados atualizados no Configuration Manager console.
Resolução
Depois de instalar esse hotfix, o Avaliador de Coleção prioriza a fila para dar alta prioridade a qualquer solicitação da interface do usuário. Portanto, uma solicitação de interface do usuário é tratada em tempo hábil, mesmo que haja muitas solicitações de back-end na fila.
Informações sobre o hotfix
Um hotfix com suporte está disponível na Microsoft. No entanto, esse hotfix destina-se a corrigir apenas o problema descrito neste artigo. Aplique esse hotfix somente a sistemas que estão enfrentando o problema descrito neste artigo. Esse hotfix pode receber testes adicionais. Portanto, se você não for gravemente afetado por esse problema, recomendamos aguardar a próxima atualização de software que contém esse hotfix.
Se o hotfix estiver disponível para download, haverá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não aparecer, entre em contato com o Serviço de Atendimento ao Cliente e o Suporte da Microsoft para obter o hotfix.
Observação Se ocorrerem problemas adicionais ou se alguma solução de problemas for necessária, talvez seja necessário criar uma solicitação de serviço separada. Os custos usuais de suporte serão aplicados a perguntas e problemas de suporte adicionais que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de Atendimento ao Cliente e Suporte da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=supportObservação O formulário "Download de hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Para aplicar esse hotfix, você deve ter System Center Configuration Manager 2007 Service Pack 2 (SP2) instalado.
Instruções de instalação
Observação O seguinte pacote de hotfix pode ser instalado em um servidor do site do System Center Configuration Manager 2007 SP2 que está executando uma versão baseada em x86 de um sistema operacional ou uma versão baseada em x64 de um sistema operacional:
SCCM2007-SP2-KB982400-ENU.msi
Necessidade de reinicialização
Você não precisa reiniciar o computador depois de aplicar esse hotfix.
Informações sobre a substituição de hotfixes
Esse hotfix não substitui nenhum hotfix lançado anteriormente.
Informações do arquivo
A versão em inglês (Estados Unidos) deste hotfix instala arquivos que têm os atributos listados nas tabelas a seguir. As datas e as horas desses arquivos estão listados no formato UTC (Tempo Universal Coordenado). As datas e as horas desses arquivos no computador local são exibidas no horário local, com o ajuste de DST (horário de verão) atual. Além disso, as datas e as horas poderão ser alteradas quando você realizar algumas operações nos arquivos.
System Center Configuration Manager de informações do arquivo 2007
File name |
Versão do arquivo |
Tamanho do arquivo |
Data |
Horário |
Platform |
---|---|---|---|---|---|
Colleval.dll |
4.0.6487.2135 |
102,248 |
01 de fevereiro de 2010 |
1,150 |
x86 |
Status
A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a".
Informações adicionais
Para obter mais informações sobre a terminologia de atualização de software, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento Microsoft:
824684 Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft