Aplica-se a
Windows 11 Windows 10 Windows 8 Windows 8.1 Windows 7 Enterprise Windows 7 Home Premium Windows 7 Home Basic Windows 7 Professional Windows 7 Ultimate

Sintomas

Os dispositivos SATA internos (HDDs ou SSDs) podem mostrar como mídia removível na barra de tarefas.

Causa

Se um dispositivo é ou não considerado removível é determinado pelo BIOS do seu sistema e como ele marca as várias portas SATA na placa-mãe. O driver de caixa de entrada inspeciona diretamente as portas SATA e considera os dispositivos conectados a essas portas marcados como "externos" como dispositivos removíveis. Nem todos os drivers de armazenamento fazem isso, o que pode ser uma causa potencial para corrupção ou perda de dados.

Resolução

Primeiro, marcar para e instalar atualizações de BIOS disponíveis do fabricante do computador. Se nenhum estiver disponível, você poderá seguir estas etapas para substituir a maneira como o driver de caixa de entrada apresenta dispositivos em determinadas portas:

  1. Abra um prompt de comando com privilégios de administrador.

  2. Na janela prompt de comando, digite o seguinte comando no hit Enter: devmgmt.msc

  3. Em Unidades de Disco, identifique o dispositivo SATA que você gostaria que o driver de caixa de entrada considerasse propriedades internas e abertas para este dispositivo clicando com o botão direito do mouse e selecionando Propriedades.

  4. Observe o número do barramento da visão geral das propriedades ("1" no exemplo abaixo).

  5. Para Windows 7:

    1. Digite o seguinte comando no prompt de comando aberto anteriormente e clique em Enter:reg.exe adicionar "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channelx\" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001Where xcorresponds to the Bus Number you noted in step 4.

  6. Para Windows 8 e posterior:

    1. Digite o seguinte comando no prompt de comando aberto anteriormente e clique em Enter:reg.exe adicionar "HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device" /f /v TreatAsInternalPort /t REG_MULTI_SZ /d xOnde x corresponde ao Número do Barramento que você observou na etapa 4.

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.