Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

Considere o seguinte cenário:

  • Você instala o serviço de Gateway de área de trabalho remota (RD Gateway) em um computador que esteja executando o Windows Server 2008 R2.

  • Existem várias ligações de certificado na porta 443 deste computador.

Nesse cenário, o Gateway de área de trabalho remota pode não funcionar corretamente. O comportamento incorreto depende o nome do armazenamento de certificado da ligação de certificado selecionado. Estes dois valores do certificado armazenam nome para os associação causa problemas diferentes:

  • Nome do armazenamento de certificado não é nulo para a ligação

    Nesse caso, todas as conexões de percorrer exceto nas seguintes situações:

    • Autenticação de cartão inteligente está configurada do lado de Gateway de área de trabalho remota.

    • Verificações de integridade de proteção de acesso à rede são aplicadas no lado do cliente.

  • Nome do armazenamento de certificado é NULL para a ligação

    Nesse caso, todas as conexões falharem juntos, e você recebe a seguinte mensagem de erro:

    Seu computador não pode se conectar ao computador remoto, pois nenhum certificado foi configurado para usar no servidor Gateway de área de trabalho remota. Contate o administrador da rede para obter assistência.

    Ao mesmo tempo, o seguinte evento de TerminalServices Gateway que tem a ID 306 é adicionado ao log de TerminalServices Gateway:
    Observação: Para verificar se o nome do armazenamento de certificado é NULL, siga estas etapas:

    1. No prompt de comando, digite o seguinte comando e pressione ENTER:

      Netsh http show sslcert

    2. Verifique o valor para o Nome do armazenamento de certificado da primeira vinculação que está escutando na porta 443. Um valor de (nulo) indica que o nome do armazenamento de certificado é NULL para essa ligação específica.

Causa

Os problemas ocorrem porque o serviço de Gateway de área de trabalho remota recupera uma ligação de certificado incorreto.

Resolução

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportObservação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esse hotfix, o computador deve estar executando o Windows Server 2008 R2.

Requisitos de reinicialização:


Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:


Esse hotfix não substitui nenhum outro hotfix.

Informações sobre o arquivo:


A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na Hora Universal Coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a
Fuso horário
Guia de
Data e hora
item no painel de controle.

Para todas as versões compatíveis baseadas em x64 do Windows Server 2008 R2

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Aaedge.dll

6.1.7600.20546

304,128

10-Oct-2009

06:12

x64

Aaedge.mof

Não aplicável

1,268

10-Jun-2009

20:31

Não aplicável

Aatspp.dll

6.1.7600.16385

65,024

14-Jul-2009

01:39

x64

Aatspp.mof

Não aplicável

1,271

10-Jun-2009

20:31

Não aplicável

Rap.xml

Não aplicável

895

10-Jun-2009

20:31

Não aplicável

Tsgateway.xml

Não aplicável

429

10-Jun-2009

20:31

Não aplicável

Tsgclean.exe

6.1.7600.16385

428,032

14-Jul-2009

01:39

x64

Tsproxy-edgeadapter-ppdlic.xrm-ms

Não aplicável

3,018

10-Oct-2009

08:55

Não aplicável



Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Mais informações

Para obter mais informações, clique no número de artigo a seguir para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:

824684 descrição da terminologia padrão usada para descrever as atualizações de software



Informações sobre arquivo adicional para Windows Server 2008 R2


Arquivos adicionais para todas as versões compatíveis baseadas em x64 do Windows Server 2008 R2

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Amd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7600.20546_none_9ab543bbff629cbd.manifest

Não aplicável

99,560

11-Oct-2009

19:00

Não aplicável

Package_for_kb976484_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mum

Não aplicável

1,458

11-Oct-2009

19:00

Não aplicável

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×