Adicionar conectores entre as formas do Visio

Aplica-se a
Visio Plano 1 Visio Professional 2024 Visio Standard 2024 Visio Professional 2021 Visio Standard 2021 Visio Professional 2016 Visio Standard 2016

O Visio facilita a conexão de formas no seu desenho.

Use a Conexão Automática para conectar as formas enquanto as adiciona e conecte as formas existentes usando a ferramenta Conector. Você também pode alterar as formas que aparecem na minibarra de ferramentas e ativar ou desativar a Conexão Automática.

Conectar-se automaticamente a uma forma

Conectar as formas que já estejam na página

Conectar-se a uma forma em outra página

Usar temas para alterar a aparência do conector

Usar formas alternativas de conectores

Alterar as formas na minibarra de ferramentas Conexão Automática

Ativar ou desativar a Conexão Automática

Conectar automaticamente uma forma

Uma maneira de conectar as formas é permitir que o Visio as conecte automaticamente quando você adiciona uma forma a uma página. Isto é especialmente prático quando você está criando um fluxograma.

  1. Verifique se a Conexão Automática está ativa. Na guia Visualizar, no grupo Auxílios Visuais, verifique se a Conexão Automática está selecionada.

  2. Arraste uma forma do painel Formas para a página.

  3. Mantenha o ponteiro sobre a forma até que as setas de Conexão Automática apareçam ao redor da forma.

    Captura de tela mostrando que a Conexão Automática está ativa, passe o mouse sobre uma forma para exibir as setas de conexão.

  4. Mantenha o ponteiro sobre a seta na direção desejada para adicionar uma forma.

    Captura de tela mostrando o passar o mouse sobre uma seta de Conexão Automática exibindo uma barra de ferramentas de formas a serem adicionadas.

    Aparece uma minibarra de ferramentas que contém as quatro primeiras Formas Rápidas que estão atualmente no estêncil Formas Rápidas. Quando você deixa o ponteiro sobre uma forma na barra de ferramentas, o Visio exibe uma prévia dessa forma na página.

  5. Selecione a forma que deseja adicionar.

  6. Se quiser continuar, deixe o ponteiro sobre uma seta Conexão Automática em uma forma recém-adicionada para adicionar outra forma que também será automaticamente conectada.

    A captura de tela que mostra que passar o mouse sobre a forma recém-adicionada exibe setas de Conexão Automática para adicionar outra forma.

Início da página

Conectar as formas que já estejam na página

Dica

Os comandos no grupo Ferramentas na guia Página inicial colocam o Visio em um estado ou modo diferente, o que, de certa forma, pode confundir às vezes. Use o teclado para alternar convenientemente entre as ferramentas Selecionar objetos da ferramenta Ponteiro (pressione Ctrl+1) e Imagem do botãodo conector (pressione Ctrl+3). Seja qual for a ferramenta que estiver usando, como o Bloco de Texto ou o Ponto de Conexão, pressione Esc várias vezes para retornar à Ferramenta de Ponteiro.

  1. Na guia Página Inicial, no grupo Ferramentas, selecione a imagem do Botãodo Conector ou pressione Ctrl+3.
  2. Selecione uma forma e arraste um conector para outra forma.
  3. Quando terminar, selecione Ferramenta PonteiroSelecionar Objetos na guia Página Inicial no grupo Ferramentas ou pressione Ctrl+1.

Mostrar ou ocultar animação

Captura de tela mostrando que a ferramenta Conector se conecta a formas com uma conexão de ponto em cada extremidade.

Como alternativa, o comando Conectar Formas pode ser adicionado à faixa de opções e usado para conectar várias formas na ordem em que forem selecionadas.

Captura de tela mostrando o vídeo das formas de conexão

Dica

Para adicionar comandos úteis que não estejam visíveis na faixa de opções, use a seleção deOpções>de Arquivo>, Personalizar a Faixa de Opções.

Início da página

Conectar-se a uma forma em outra página

Você só pode usar conectores entre formas na mesma página. Para se conectar a uma forma em outra página, use a forma Referência Fora da Página para criar um hiperlink de uma página para a próxima, ou adicionar uma ação Hiperlink e Clicar Duas Vezes em qualquer forma para navegar para uma página diferente no mesmo documento.

Usar Referência Fora da Página

  1. Abra o estêncil Formas de Fluxograma Básico e arraste a forma Referência fora da página na página atual.

    Captura de tela mostrando a forma de referência fora da página

  2. Na caixa de diálogo Referência fora da página , selecione OK para adicionar a forma à página atual e a uma página recém-criada.

  3. Na nova página, continue criando seu diagrama.

  4. Para alterar a aparência da forma Referência fora da página, clique com o botão direito do mouse na forma e selecione Saída, Entrada, Círculo ou Seta.

Para mover-se entre as páginas, clique duas vezes na forma Referência fora da página em qualquer uma das páginas. Confira mais informações em Caixa de diálogo Referência fora da página.

  1. Clique com o botão direito do mouse na forma e selecione Hiperlink ou selecione a forma e pressione Ctrl+K*.

  2. Selecione Procurar ao lado do campo Subendereço e, em seguida, selecione a lista suspensa ao lado de Página para selecionar a página desejada.

    Captura de tela mostrando a caixa de diálogo Hiperlink

    Observação

    O nome de uma forma na página de destino também pode ser especificado em um hiperlink. Selecione a guia Desenvolvedor e selecione Nome da Forma ou use o nome padrão no campo Nome ou edite-o e selecione OK.

    Os usuários podem precisar habilitar a guia Desenvolvedor antes de seguir as instruções de Nome da Forma e Comportamento.

  3. Para definir a ação de duplo clique para uma forma, selecione a guia Desenvolvedor e, em seguida, selecione Comportamento.

  4. Selecione a guia Clique Duplo , selecione a opção Ir para a página e, em seguida, selecione a lista suspensa para selecionar a página desejada.

    Captura de tela mostrando a ação do Visio Double-Click

    Observação

    Faça isso apenas depois de editar os nomes de página porque aqui eles não são atualizados automaticamente.

Início da página

Usar temas para alterar a aparência do conector

A aparência padrão dos conectores pode ter linhas simples, mas também pode ser projetada para funcionar com temas que adicionam ornamentos, como pontas de seta. Os temas internos podem ser aplicados da galeria Temas na guia Design . Para alterar um atributo de um conector, como estilo, cor, peso etc., consulte Edição de formas de conector.

Mostrar ou ocultar animação

Captura de tela mostrando as animações ocultas

Observação

Para ver mais ornamentos, selecione a guia Design . No grupo Variantes , selecione a seta suspensa e, em seguida, selecione Conectores. Captura de tela mostrando as animações ocultas-1

Usar formas alternativas de conectores

As formas de conectores, como as disponíveis no estêncil Extras doVisio>Mais Formas>, podem ser usadas para conectar formas juntas, em vez de usar a forma de conector Dinâmico padrão. Essas formas de conector podem ser arrastadas e soltas em uma página, selecionadas para uso com as ferramentas Conector e Conectar Formas ou simplesmente podem ser usadas para substituir conectores existentes.

  1. Abra o estêncil que contém as formas de conector alternativas.
  2. Selecione os conectores existentes a serem substituídos na página.
  3. Na guia Página Inicial do grupo Edição , selecione Alterar Forma e selecione a forma de conector desejada.

Mostrar ou ocultar animação

Captura de tela mostrando a animação oculta de alterar forma

Observação

O recurso Alterar Forma foi introduzido no Visio 2013, mas as ferramentas Conector e Conectar Formas foram introduzidas antes do Visio 2007.

Início da Página

Alterar as formas na minibarra de ferramentas Conexão Automática

As formas na minibarra de ferramentas vêm do estêncil Formas Rápidas de um diagrama. A minibarra de ferramentas exibe até quatro formas. Você pode personalizar as formas que aparecem na minibarra de ferramentas. O procedimento a seguir usa o Diagrama Básico como exemplo.

  1. Por padrão, as formas na minibarra de ferramentas são as quatro primeiras no estêncil logo após o estêncil Formas Rápidas. Por exemplo, estas são as primeiras quatro formas no estêncil Básico.

    Captura de tela mostrando a minibarra de ferramentas usando formas básicas padrão

  2. Para exibir diferentes formas na minibarra de ferramentas para um determinado estêncil, você pode reordenar as formas arrastando-as para o topo do estêncil. Por exemplo, você pode arrastar as formas de Estrela de 4 Pontas, Estrela de 5 Pontas, Estrela de 6 Pontas e Estrela de 7 Pontas para o topo do estêncil Básico.

    Captura de ecrã a mostrar a minibarra de ferramentas com novas formas básicas

  3. Você também pode alterar a ordem dos estênceis arrastando-os mais acima ou abaixo no painel Formas. É apresentado um subconjunto destas formas no stencil Formas Rápidas e pela mesma ordem em que estão no painel Formas. Por exemplo, depois de arrastar o estêncil Formas Decorativas imediatamente após o estêncil Formas Rápidas no painel Formas, a sequência muda no estêncil Formas Rápidas.

    Captura de ecrã a mostrar a minibarra de ferramentas a utilizar um stencil diferente ao reordenar

    Observação

    Quando você fecha e reabre um diagrama, a ordem padrão dos estênceis no painel Formas é restaurada automaticamente e refletida nas Formas Rápidas.

  4. Para usar um estêncil diferente como a base para a minibarra de ferramentas, no estêncil Formas Rápidas, selecione uma forma no subconjunto dessas formas para um estêncil. Por exemplo, selecione Diagrama Venn no estêncil Formas Gráficas e Matemáticas.

    Captura de ecrã a mostrar a minibarra de ferramentas a utilizar um novo stencil ao selecionar

Dica

Para retornar à sequência padrão de formas em um estêncil, clique com o botão direito do mouse no nome do estêncil no painel Formas e selecione Restaurar o Estêncil.

Observação

Nem todos os estênceis têm formas que podem ser usadas na minibarra de ferramentas. Por exemplo, as formas no estêncil Formas de Seta não aparecem na minibarra de ferramentas.

Início da página

Ativar ou desativar a Conexão Automática

A Ligação Automática é uma opção ao nível dos ficheiros. Se você ativar a opção, ela continuará assim para o arquivo atual, mas ao trabalhar em um arquivo diferente, você precisará habilitá-la novamente. Para determinados modelos, opção ativada por padrão. 

Ativar ou desativar a Conexão Automática no diagrama ativo

  • Na guia Exibir, no grupo Auxílios Visuais, marque ou desmarque a Conexão Automática.

    Captura de ecrã a mostrar como selecionar ou desmarcar a Ligação Automática no separador Ver para ativar ou desativar a Ligação Automática.

Se a opção Ligação Automática estiver desativada, pode corrigir esta situação ao aceder aOpções>de Ficheiro>Avançadas e selecionar Ativar Ligação Automática:

Ativar ou desativar a Conexão Automática

  1. Selecione a guia Arquivo e, em seguida, selecione Opções.

  2. Nas Opções do Visio, selecione Avançadas.

  3. Em Opções de Edição, selecione Ativar Conexão Automática para ativar a Conexão Automática. Ou desmarque essa caixa de seleção para desativar a Conexão Automática.

    Captura de ecrã a mostrar como selecionar ou desmarcar Ativar Ligação Automática para ativar ou desativar a Ligação Automática para todos os diagramas & desenhos.

  4. Selecione OK.

Início da Página

Veja Também

Editar as linhas de conector, setas ou pontos

Adicionar e editar o texto do conector

Criar um conector personalizado

Associar ou desassociar conectores manualmente

Tudo o que você precisa saber sobre os conectores de desktop do Visio

Treinamento do Visio