Criar ou executar uma macro

Aplica-se a
Word para Microsoft 365 Word 2024 Word 2021 Word 2019 Word 2016

No Word, pode automatizar tarefas utilizadas frequentemente ao criar e executar macros. Uma macro é uma série de comandos e instruções que agrupa como um único comando para realizar uma tarefa automaticamente.

Para poupar tempo em tarefas que você costuma realizar com frequência, compacte as etapas em uma macro. Em primeiro lugar, grave a macro. Em seguida, para executá-la, basta clicar num botão na Barra de Ferramentas de Acesso Rápido ou premir uma combinação de teclas. Isso dependerá de como você a configurar.

Gravar uma macro com um botão

  1. Selecione Ver>MacrosGravar Macro.>
    Comando Gravar Macro

  2. Digite um nome para a macro.
    Caixa de nome da macro

  3. Para usar essa macro em qualquer novo documento que você criar, verifique se a caixa Armazenar macro em exibe Todos os Documentos (Normal.dotm).
    Caixa para escolher onde armazenar uma macro

  4. Para executar a macro quando clicar num botão, selecione Botão.
    Clique para atribuir a macro a um botão

  5. Selecione a macro nova (o nome deverá ser semelhante a Normal.MacrosNovas.<o nome> da macro) e selecione Adicionar.
    A macro e o botão Adicionar

  6. Selecionar Modificar.
    Botão Modificar na caixa Personalizar a Barra de Ferramentas de Acesso Rápido

  7. Selecione uma imagem para o botão, escreva o nome que pretende e selecione OK duas vezes.
    Opções de botão na caixa Modificar Botão

  8. Agora é altura de gravar os passos. Selecione os comandos ou prima as teclas relativas a cada passo da tarefa. O Word grava seus cliques e pressionamentos de teclas.

    Observação

    Utilize o teclado para selecionar o texto enquanto está a gravar a macro. As macros não gravam seleções feitas com o rato.

  9. Para parar a gravação, selecione Ver>Macros>Parar Gravação.
    Comando Parar Gravação

O botão da sua macro aparece na Barra de Ferramentas de Acesso Rápido.

Botão da macro na Barra de Ferramentas de Acesso Rápido

Para executar a macro, selecione o botão.

Gravar uma macro com um atalho de teclado

  1. Selecione Ver>MacrosGravar Macro.>
    Comando Gravar Macro

  2. Digite um nome para a macro.
    Caixa de nome da macro

  3. Para usar essa macro em qualquer novo documento que você criar, verifique se a caixa Armazenar macro em exibe Todos os Documentos (Normal.dotm).
    Caixa para escolher onde armazenar uma macro

  4. Para executar a macro quando prime um atalho de teclado, selecione Teclado.
    Clique para atribuir a macro a um atalho de teclado

  5. Escreva uma combinação de teclas na caixa Premir nova tecla de atalho .

  6. Verifique se a combinação já foi atribuída a outro item. Se estiver, tente uma combinação diferente.

  7. Para usar esse atalho de teclado em qualquer novo documento criado, verifique se a caixa Salvar alterações em indica Normal.dotm.

  8. Selecione Atribuir.

  9. Agora é altura de gravar os passos. Selecione os comandos ou prima as teclas relativas a cada passo da tarefa. O Word grava seus cliques e pressionamentos de teclas.

    Observação

    Utilize o teclado para selecionar o texto enquanto está a gravar a macro. As macros não gravam seleções feitas com o rato.

  10. Para parar a gravação, selecione Ver>Macros>Parar Gravação.
    Comando Parar Gravação

Para executar a macro, pressione as teclas de atalho do teclado.

Executar uma macro

Para executar uma macro, selecione o botão na Barra de Ferramentas de Acesso Rápido, prima o atalho de teclado ou pode executar a macro a partir da lista de Macros .

  1. Selecione Ver>Macros>Ver Macros.
    Comando Exibir Macros
  2. Na lista em Nome da macro, selecione a macro que pretende executar.
  3. Selecione Executar.

Disponibilizar uma macro em todos os documentos

Para disponibilizar uma macro de um documento em todos os novos documentos, adicione-a ao modelo Normal.dotm.

  1. Abra o documento que contém a macro.
  2. Selecione Ver>Macros>Ver Macros.
    Comando Exibir Macros
  3. Selecione Organizador.
    Botão Organizador na caixa Exibir Macros
  4. Selecione a macro que pretende adicionar ao modelo Normal.dotm e, em seguida, selecione Copiar.

Adicionar um botão de macro à faixa de opções

  1. SelecioneOpções>de Ficheiros>, Personalizar Friso.
  2. Em Escolher comandos de, selecione Macros.
  3. Selecione a macro que pretende.
  4. Em Personalizar o friso, selecione o separador e grupo personalizado onde pretende adicionar a macro.

Se não tiver um grupo personalizado, selecione Novo Grupo. Em seguida, selecione Mudar o nome e escreva um nome para o grupo personalizado.

  1. Selecione Adicionar.
  2. Selecione Mudar o Nome para selecionar uma imagem para a macro e escreva o nome que pretende.
  3. Selecione OK duas vezes.

Escrever uma macro de raiz no Visual Basic

  1. No separador Programador , no grupo Código , selecione Macros.

  2. Na caixa Nome da macro, digite um nome para a macro.

    Observação

    Se atribuir a uma nova macro o mesmo nome que uma macro incorporada no Word, as novas ações de macro irão substituir a macro incorporada. Para ver uma lista de macros incorporadas, selecione Word Comandos na lista pendente Macros em.

  3. Na lista Macros em , selecione o modelo ou documento no qual pretende armazenar a macro.
    Para disponibilizar a macro em todos os documentos, certifique-se de que seleciona Normal.dotm.

  4. Selecione Criar para abrir o Visual Basic Editor.

Depois de abrir o Visual Basic Editor, poderá querer obter mais informações sobre como trabalhar com Visual Basic for Applications. Para obter mais informações, selecione Ajuda do Microsoft Visual Basic no menu Ajuda ou pressione F1.