Destacar (agrupar) dados numa folha de cálculo

Aplica-se A
Excel para Microsoft 365 Excel 2024 Excel 2021 Excel 2019 Excel 2016

Se tiver uma lista de dados que pretenda agrupar e resumir, pode criar um destaque com um máximo de oito níveis. Cada nível interno, representado por um número mais elevado nos símbolos de destaque, apresenta dados detalhados relativos ao nível externo precedente, representado por um número mais baixo nos símbolos de destaque. Utilize um destaque para apresentar rapidamente linhas ou colunas de resumo ou para revelar os dados detalhados de cada grupo. Pode criar um destaque de linhas (conforme mostrado no exemplo abaixo), um destaque de colunas ou um destaque de linhas e de colunas.

Dados com um destaque de três níveis
1. Para apresentar linhas para um nível, selecione um ou dois símbolos de destaque apropriados.

  • O nível 1 contém o total de vendas de todas as linhas de detalhes.
  • O nível 2 contém o total de vendas mensais de cada região.
  • O nível 3 contém linhas de detalhes – neste caso, as linhas 17 a 20.
2. Para expandir ou fechar os dados no seu destaque, clique nos símbolos de destaque mais e menos ou prima ALT+SHIFT+= para expandir e ALT+SHIFT+- para fechar.

Criar um destaque de linhas

  1. Certifique-se de que cada coluna de dados que pretende destacar tem uma etiqueta na primeira linha (por exemplo, Região), que contém factos semelhantes em cada coluna e que o intervalo que pretende destacar não tem linhas nem colunas em branco.

  2. Se quiser, as suas linhas de detalhes agrupadas podem ter uma linha de resumo correspondente, um subtotal. Para criá-las, siga um dos seguintes procedimentos:

    • Insira linhas de resumo utilizando o comando Subtotal 
      Utilize o comando Subtotal, que insere a função SUBTOTAL imediatamente abaixo ou acima de cada grupo de linhas de detalhe e cria automaticamente o destaque. Para obter mais informações sobre como utilizar a função Subtotal, consulte a função SUBTOTAL.
    • Inserir linhas de resumo próprias 
      Insira as suas próprias linhas de resumo, com fórmulas, imediatamente abaixo ou acima de cada grupo de linhas de detalhes. Por exemplo, abaixo (ou acima) das linhas de dados de vendas de março e abril, utilize a função SOMA para obter o subtotal das vendas desses meses. A tabela apresentada mais adiante neste tópico mostra-lhe um exemplo disto.
  3. Por predefinição, o Excel procura linhas de resumo abaixo dos detalhes que resumem, mas é possível criá-las acima das linhas de detalhes. Se criou linhas de resumo abaixo dos detalhes, avance para o passo seguinte (passo 4). Se criou as linhas de resumo acima das linhas de detalhes, aceda aDestaque de Dados> e, em seguida, selecione o iniciador de caixa de diálogo.
    No grupo Destaques, clique no iniciador de caixa de diálogo
    A caixa de diálogo Configurações é aberta.
    A caixa de diálogo Definições para destaques
    Na caixa de diálogo Configurações, desmarque a caixa de seleção Linhas de resumo abaixo dos detalhes e selecione OK.

  4. Destaque os dados. Siga um dos seguintes procedimentos:
    Destacar os dados automaticamente

    1. Selecione uma célula no intervalo de células que pretende destacar.
    2. Aceda aGrupo deGrupos>de Destaques de Dados> e, em seguida, selecione Destaque Automático>.
      Clique na seta por baixo de Agrupar e, em seguida, clique em Destacar automaticamente

    Destacar os dados manualmente

    Importante

    Ao agrupar níveis de destaque manualmente, é melhor ter todos os dados apresentados para evitar agrupar as linhas incorretamente.

    1. Para destacar o grupo externo (nível 1), selecione todas as linhas contidas no grupo externo (ou seja, as linhas de detalhes e, caso as tenha adicionado, as linhas de resumo).

      Uma seleção de dados pronta para criar um grupo externo
      1. A primeira linha contém etiquetas e não está selecionada.
      2. Uma vez que este é o grupo externo, selecione todas as linhas com subtotais e detalhes.
      3. Não selecione o total geral.
    2. Ir para oGrupo doGrupo>Destaques>de Dados>. Na caixa de diálogo Grupo, selecione Linhas e, em seguida, selecione OK.

      Sugestão

      Se selecionar linhas inteiras em vez de apenas as células, o Excel agrupa automaticamente por linha - a caixa de diálogo Grupo nem sequer é aberta.

      Clique em Linhas e, em seguida, clique em OK
      Os símbolos de destaque surgem junto ao grupo no ecrã.

    3. Opcionalmente, destaque um grupo interno aninhado – as linhas de detalhes de uma determinada secção dos seus dados.

      Nota

      Se não precisar de criar grupos internos, avance para o passo F abaixo.

      Para cada grupo interno aninhado, selecione as linhas de detalhes adjacentes à linha que contém a linha de resumo.

      Dados selecionados para agrupar no nível 2 numa hierarquia.
      1. Pode criar múltiplos grupos em cada nível interior. Aqui, duas secções já estão agrupadas no nível 2.
      2. Esta secção está selecionada e pronta para ser agrupada.
      3. Não selecione a linha de resumo dos dados que está a agrupar.
    4. Ir para oGrupo doGrupo>Destaques>de Dados>.
      Clique em Agrupar no separador Dados
      Na caixa de diálogo Grupo, selecione Linhas e, em seguida, selecione OK. Os símbolos de destaque surgem junto ao grupo no ecrã.

      Sugestão

      Se selecionar linhas inteiras em vez de apenas as células, o Excel agrupa automaticamente por linha - a caixa de diálogo Grupo nem sequer é aberta.

    5. Continue a selecionar e a agrupar as linhas internas até ter criado todos os níveis que deseja no destaque.

    6. Se pretender desagrupar linhas, selecione as linhas e, em seguida, aceda aDesagrupar>Destaquesde Dados>>.
      Também é possível desagrupar secções do destaque sem remover o nível inteiro. Mantenha premida a tecla Shift enquanto seleciona a caixa Mais ou a Caixa de Subtração do grupo e, em seguida, aceda aDesagrupar> Destaques deDados>>.

      Importante

      Se desagrupar um destaque enquanto os dados de detalhe estiverem ocultos, as linhas de detalhe permanecerão ocultas. Para mostrar os dados, arraste o cursor sobre os números das linhas visíveis adjacentes às linhas ocultas. Em seguida, aceda aFormatar Células Domésticas>, aponte paraOcultar>& Mostrar e, em seguida, selecione Mostrar Linhas.

Criar um destaque de colunas

  1. Certifique-se de que cada linha de dados que pretende destacar tem uma etiqueta na primeira coluna, com factos semelhantes em cada linha, e que o intervalo não inclui linhas nem colunas em branco.

  2. Insira as suas próprias colunas de resumo com fórmulas imediatamente à direita ou à esquerda de cada grupo de colunas de detalhes. A tabela listada no passo 4 abaixo mostra-lhe um exemplo.

    Nota

    Para destacar os dados por colunas, tem de ter colunas de resumo com fórmulas que façam referência às células em cada uma das colunas de detalhe do grupo.

  3. Se a coluna de resumo estiver à esquerda das colunas de detalhes, aceda aDestaque de Dados> e, em seguida, selecione o iniciador de caixa de diálogo.
    No grupo Destaques, clique no iniciador de caixa de diálogo
    A caixa de diálogo Configurações é aberta.
    A caixa de diálogo Definições para destaques
    Na caixa de diálogo Definições, desmarque a caixa de verificação Colunas de resumo à direita do detalhe e, em seguida, selecione OK.

  4. Para destacar os dados, efetue um dos seguintes procedimentos:
    Destacar os dados automaticamente

    1. Selecione uma célula do intervalo.
    2. Aceda aGrupo deGrupos>de Destaques de Dados> e, em seguida, selecione Destaque Automático>.

    Destacar os dados manualmente

    Importante

    Ao agrupar manualmente os níveis de destaque, é melhor ter todos os dados apresentados para evitar agrupar colunas incorretamente.

    1. Para destacar o grupo externo (nível 1), selecione todas as colunas de resumo subordinadas, bem como os respetivos dados de detalhes.

      Dados dispostos em colunas para serem agrupados
      1. A coluna A contém rótulos.
      2. Selecione todas as colunas de detalhes e subtotais. Tenha em atenção que, se não selecionar colunas inteiras, quando selecionar Grupo (Grupode Destaques> de Dados>) a caixa de diálogo Grupo será aberta e pedir-lhe-á para selecionar Linhas ou Colunas.
      3. Não selecione a coluna total geral.
    2. Ir para oGrupo doGrupo>Destaques de Dados>.>
      Clique em Agrupar no separador Dados
      O símbolo hierárquico é apresentado acima do grupo.

    3. Para destacar um grupo interno aninhado de colunas de detalhes (nível 2 ou superior), selecione as colunas de detalhes adjacentes à coluna que contém a coluna de resumo.

      Dados agrupados por colunas
      1. Pode criar múltiplos grupos em cada nível interior. Aqui, duas secções já estão agrupadas no nível 2.
      2. Estas colunas estão selecionadas e prontas para serem agrupadas. Tenha em atenção que, se não selecionar colunas inteiras, quando selecionar Grupo (Grupode Destaques> de Dados>) a caixa de diálogo Grupo será aberta e pedir-lhe-á para selecionar Linhas ou Colunas.
      3. Não selecione a coluna de resumo dos dados que está a agrupar.
    4. Ir para ogrupoDestaques>de Dados>.
      Clique em Agrupar no separador Dados
      Os símbolos de destaque surgem junto ao grupo no ecrã.

  5. Continue a selecionar e a agrupar as colunas internas até ter criado todos os níveis que deseja no destaque.

  6. Se pretender desagrupar colunas, selecione as colunas e, em seguida, aceda aDesagruparDestaquesde Dados>>.

No separador Dados clique em Desagrupar

Também é possível desagrupar secções do destaque sem remover o nível inteiro. Mantenha premida a tecla Shift enquanto seleciona a caixa Mais ou a Caixa de Subtração para o grupo e, em seguida, aceda aDesagruparDestaquesde Dados>>.

Se desagrupar um destaque enquanto os dados de detalhe estiverem ocultos, as colunas de detalhes permanecerão ocultas. Para mostrar os dados, arraste o cursor sobre as letras das colunas visíveis adjacentes às colunas ocultas. Aceda a>Formatar Células>Inicial, aponte para Ocultar & Mostrar e, em seguida, selecione Mostrar Colunas.

Mostrar ou ocultar dados destacados

  1. Se não vir os símbolos de destaque um, dois, três, mais e menos, aceda aOpções>de Ficheiro> Avançadas e, na secçãoOpções de visualizaçãopara esta folha de cálculo, selecione a caixa de verificação Mostrar símbolos de destaque se estiver aplicado um destaque e, em seguida, selecione OK.

  2. Efetue um ou mais dos seguintes procedimentos:

    • Mostrar ou ocultar os dados de detalhe de um grupo 
      Para mostrar os dados de detalhe de um grupo, selecione o botão de adição do grupo ou prima ALT+SHIFT+=.
    • Para ocultar os dados de detalhe de um grupo, selecione o botão de subtração do grupo ou prima ALT+SHIFT+-.
    • Expandir ou fechar todos os destaques a um determinado nível 
      Nos dois três símbolos de destaque, selecione o número do nível que pretende. Os dados de detalhe dos níveis inferiores são ocultados.
      Por exemplo, se um destaque tiver quatro níveis, pode ocultar o quarto nível enquanto visualiza os restantes níveis, selecionando três .
    • Mostrar ou ocultar todos os dados de detalhe destacados 
      Para mostrar todos os dados detalhados, selecione o nível mais baixo nos dois símbolos de três destaques. Por exemplo, se existirem três níveis, selecione três .
    • Para ocultar todos os dados detalhados, selecione um .

Personalizar um destaque com estilos

Nas linhas destacadas, o Microsoft Excel utiliza estilos, como, por exemplo, RowLevel_1 e RowLevel_2. Nas colunas destacadas, o Excel utiliza estilos, como, por exemplo, NívelColuna_1 e NívelColuna_2. Estes estilos utilizam negrito, itálico e outras formatações de texto para diferenciar as linhas ou colunas de resumo nos dados. Ao alterar a forma como cada um destes estilos é definido, pode aplicar texto e formatos de células diferentes para personalizar o aspeto do destaque. Pode aplicar um estilo a um destaque no momento em que o cria ou posteriormente.

Efetue um ou mais dos seguintes procedimentos:

Aplicar automaticamente um estilo a novas linhas ou colunas de resumo 

  1. Aceda a Destaque de Dados> e, em seguida, selecione o iniciador de caixa de diálogo.
    No grupo Destaques, clique no iniciador de caixa de diálogo
    A caixa de diálogo Configurações é aberta.
    A caixa de diálogo Definições para destaques
  2. Selecione a caixa de verificação Estilos automáticos.

Aplicar um estilo a uma linha ou coluna de resumo existente 

  1. Selecione as células às quais pretende aplicar um estilo.
  2. Aceda a Destaque de Dados> e, em seguida, selecione o iniciador de caixa de diálogo.
    No grupo Destaques, clique no iniciador de caixa de diálogo
    A caixa de diálogo Configurações é aberta.
    A caixa de diálogo Definições para destaques
  3. Selecione a caixa de verificação Estilos automáticos e, em seguida, selecione Aplicar Estilos.
    Caixa de diálogo Definições com Estilos Automáticos seleccionados

Também é possível formatar dados destacados através de formatação automática.

Copiar dados destacados

  1. Se não vir os símbolos de destaque um, dois, três, mais e menos , aceda aOpções de Ficheiro>>Avançadas e, em seguida, na secção Opções de visualização para esta folha de cálculo, selecione a caixa de verificação Mostrar símbolos de destaque se um destaque estiver aplicado.
  2. Utilize os símbolos de destaque um, dois, três , menos e mais para ocultar os dados de detalhe que não pretende que sejam copiados.
    Para obter mais informações, consulte a secção Mostrar ou ocultar dados destacados.
  3. Selecione o intervalo das linhas de resumo.
  4. Ir para Edição em Início>Localizar>& Selecionar e, em seguida, selecione Ir para Especial.
    Clique em Localizar & Selecionar e, em seguida, clique em Ir Para
  5. Selecionar Apenas células visíveis.
  6. Selecione OK e, em seguida, copie os dados.

Ocultar ou remover um destaque

Nota

Nenhum dado é eliminado quando oculta ou remove um destaque.

Ocultar um destaque

  • Aceda a Opções >de Ficheiro> Avançadas e, em seguida, na secção Opções de visualização para esta folha de cálculo, desmarque a caixa de verificação Mostrar símbolos de destaque se um destaque estiver aplicado.

Remover um destaque

  1. Clique na folha de cálculo.

  2. Aceda aDestaquesde Dados>>,Desagrupar e, em seguida, selecione Limpar Destaque.
    Clique em Desagrupar e, em seguida, clique em Limpar destaques

    Importante

    Se remover um destaque enquanto os dados de detalhe estiverem ocultos, as linhas ou colunas de detalhes podem permanecer ocultas. Para mostrar os dados, arraste o cursor rato sobre os números das linhas ou letras das colunas adjacentes às linhas e colunas ocultas. Aceda aFormatar Células>Inicial>, aponte para Ocultar & Mostrar e, em seguida, selecione Mostrar Linhas ou Mostrar Colunas.

Criar um relatório de resumo com um gráfico

Imagine que pretende criar um relatório de resumo dos dados que só apresenta os totais acompanhados de um gráfico desses totais. Em geral, é possível efetuar o seguinte:

  1. Criar um relatório de resumo

    1. Destaque os dados.
      Para obter mais informações, consulte as secções Criar um destaque de linhas ou Criar um destaque de colunas.
    2. Oculte os detalhes ao selecionar os símbolos de destaque um, dois, três , mais e menos para mostrar apenas os totais, conforme apresentado no exemplo seguinte de destaque de linha:
      Lista destacada apresentando apenas as linhas com os totais
    3. Para obter mais informações, consulte a secção Mostrar ou ocultar dados destacados.
  2. Crie um gráfico do relatório de resumo

    1. Selecione os dados de resumo cujo gráfico pretende criar.
      Por exemplo, para fazer um gráfico apenas dos totais de Ferreira e Gonçalves, mas não dos totais gerais, selecione as células A1 a C19, conforme mostrado no exemplo acima.
    2. Selecione Inserir>Gráficos>,Gráficos Recomendados e, em seguida, selecione o separador Todos os Gráficos e escolha o seu tipo de gráfico.
      Caixa de diálogo Inserir Gráfico
      Por exemplo, se escolhesse a opção de Colunas Agrupadas, o seu gráfico teria o seguinte aspeto:
      Gráfico criado a partir de dados de subtotais
      Se mostrar ou ocultar detalhes da lista de dados destacada, o gráfico também será atualizado para mostrar ou ocultar os dados.

Precisa de mais ajuda?

Pode sempre colocar uma pergunta a um especialista da Comunidade Tecnológica do Excel ou obter suporte nas Comunidades.

Consulte Também

Agrupar ou desagrupar dados numa tabela dinâmica