Como desinstalar ou remover conjuntos de aplicações do Microsoft Office 2007

Sumário
Este artigo fornece métodos que pode seguir para desinstalar ou remover conjuntos de aplicações do Microsoft Office 2007.

Pretende desinstalar uma versão diferente do Microsoft Office?

Para visualizar as informações sobre como remover ou desinstalar outra versão do Microsoft Office, clique na ligação correspondente à sua versão do Office:

Como desinstalar ou remover conjuntos de aplicações do Microsoft Office 2010
Como desinstalar ou remover conjuntos de aplicações do Microsoft Office 2003
Como desinstalar ou remover o Microsoft Office for Mac 2011
Como desinstalar ou remover o Microsoft Office for Mac 2008
Resolução
Recomendamos que siga os métodos fornecidos neste artigo por ordem. No entanto, se já tiver tentado um dos métodos para remover o Office e tiver falhado, pode avançar rapidamente para outro método, a partir desta lista:

Método 1: Desinstalar conjuntos de aplicações do Microsoft Office 2007 a partir do Painel de controlo

Clique aqui para mostrar informações sobre como desinstalar conjuntos de aplicações do Microsoft Office a partir do Painel de controlo.

Para remover o Microsoft Office 2007 a partir do Painel de Controlo, siga estes passos:
  1. Clique em Iniciar.
  2. Clique em Todos os Programas e, em seguida, abra a pasta Acessórios (ignore este passo no Windows XP).
  3. Clique em Executar e, em seguida, clique na caixa Abrir.
  4. Escreva appwiz.cpl e clique em OK.
  5. Localize a entrada Microsoft Office na lista dos programas actualmente instalados.
  6. Seleccione-a e, em seguida, clique em Desinstalar (ou Remover no Windows XP).
Se tiver problemas ao desinstalar o Microsoft Office system de 2007 no Painel de Controlo, passe ao método seguinte.


Método 2: Desinstalar conjuntos de aplicações do Microsoft Office 2007 com o Microsoft Fix it

Clique aqui para mostrar informações sobre como desinstalar conjuntos de aplicações do Microsoft Office com o Microsoft Fix it.

AVISO: A solução Fix it não remove programas individuais do Office que foram instalados em separado no seu computador. Por exemplo, se tiver o Microsoft Office Professional 2007 e o Microsoft Office Visio 2007, a solução Fix it irá remover apenas o Microsoft Office Professional 2007. O Visio 2007 não será removido. Clique aqui para ver informações relativas à remoção de programas individuais do Office.

IMPORTANTE - Leia estas notas antes de utilizar a solução Fix it:
  • Se tem um sistema operativo Windows de 64 bits, transfira e guarde a solução Fix it no ambiente de trabalho, clique duas vezes na mesma e execute-a no seu computador. Se tentar executar a solução directamente a partir do artigo, deparar-se-á com problemas ao tentar executá-la.
  • Será necessário reiniciar o computador se utilizar a solução Fix it.
  • O assistente pode estar apenas em inglês. Contudo, a correcção fix it automática também funciona para versões do Windows noutros idiomas.
  • Se não estiver a trabalhar no computador que tem o problema, pode guardar a solução Fix it numa unidade flash ou num CD ou DVD e, em seguida, executá-la no computador que tem o problema.
A solução Fix it para conjuntos de aplicações do Microsoft Office 2007 irá remover todas as edições do Office 2007. Isto inclui todas as edições de avaliação do Office 2007.

Para desinstalar o conjunto de aplicações do Microsoft Office 2007 automaticamente, clique no botão ou hiperligação Corrigir este problema. Clique em Executar na caixa de diálogo Transferência de Ficheiros e, em seguida, siga os passos indicados no assistente Fix it.


Se ainda não conseguir desinstalar o conjunto de aplicações do Microsoft Office, passe ao método seguinte.


Método 3: Desinstale conjuntos de aplicações do Microsoft Office 2007 com a resolução de problemas de Instalação e Desinstalação de Programas

Clique aqui para mostrar informações sobre como desinstalar conjuntos de aplicações do Microsoft Office 2007 com a resolução de problemas de Instalação e Desinstalação de Programas.

Pode tentar desinstalar o conjunto de aplicações do Microsoft Office ao executar a resolução de problemas de Instalação e Desinstalação de Programas. Para executar a resolução de problemas, visite o seguinte artigo da base de dados de conhecimento Microsoft:



Se ainda não conseguir desinstalar o conjunto de aplicações do Microsoft Office, passe ao método seguinte.


Método 4: Remover manualmente os conjuntos de aplicações do Microsoft Office 2007

Clique aqui para mostrar informações sobre como remover manualmente conjuntos de aplicações do Microsoft Office 2007.

Nota Para executar este método, tem de ter iniciado sessão no Windows com uma conta de administrador do computador. Se este for o seu computador pessoal, é provável que já tenha iniciado sessão com uma conta de administrador. Se este computador fizer parte de uma rede de trabalho, poderá ter de pedir ajuda ao administrador do sistema. Para verificar se iniciou sessão no Windows com a conta de um utilizador que seja administrador do computador, visite o seguinte artigo da base de dados de conhecimento Microsoft:



IMPORTANTE - Informações que tem de saber antes de remover o Office 2007:
  • Para utilizar o menu Ver ou Ferramentas no Windows 7 ou Vista, primeiro tem de premir a tecla ALT para visualizar a barra de menus.
  • Terá de ver os ficheiros e pastas ocultos. Para o fazer, siga estes passos:
    1. Abra o Explorador do Windows.
    2. No menu Ferramentas, clique em Opções de Pastas. No Windows 7 ou Vista, prima a tecla ALT para visualizar a barra de menus.
    3. Clique no separador Ver.
    4. No painel Definições avançadas, clique em Mostrar ficheiros e pastas ocultos em Ficheiros e pastas ocultos.
    5. Desmarque Ocultar extensões para tipos de ficheiro conhecidos.
    6. Clique em OK e, em seguida, feche as janelas.

Passo 1: Remova todos os pacotes do Windows Installer restantes do Microsoft Office system de 2007.
  1. Clique em Iniciar.
  2. Clique em Todos os Programas e, em seguida, abra a pasta Acessórios (ignore este passo no Windows XP).
  3. Clique em Executar e, em seguida, clique na caixa Abrir.
  4. Escreva installer e clique em OK.
    Assim abre-se a pasta %windir%\Installer.

  5. No menu Ver, clique em Escolher Detalhes.
  6. Clique para seleccionar a caixa de verificação Assunto, escreva 340 na caixa Largura da coluna seleccionada (em pixels) e, em seguida, clique em OK.
    Nota Pode demorar vários minutos até que os assuntos sejam apresentados junto de cada ficheiro .MSI.

  7. No menu Ver, aponte para Ordenar por no Windows 7 ou Vista, ou aponte para Dispor ícones por no Windows XP e, em seguida, clique em Assunto.
  8. Se a caixa de diálogo Controlo de Conta de Utilizador for apresentada, clique em Permitir para continuar.
  9. Localize cada ficheiro .MSI onde o assunto seja "Microsoft Office <nome de produto> 2007," clique com o botão direito do rato no ficheiro .MSI e, em seguida, clique em Desinstalar.
    Nota <nome do produto> é um marcador de posição para o nome do produto do Microsoft Office de 2007.
Passo 2: Pare o serviço Office Source Engine.
  1. Clique em Iniciar.
  2. Clique em Todos os Programas e, em seguida, abra a pasta Acessórios (ignore este passo no Windows XP).
  3. Clique em Executar e, em seguida, clique na caixa Abrir.
  4. Escreva services.msc e, em seguida, clique em OK.
  5. Na janela Serviços, determine se o serviço Office Source Engine está em execução (Aparecerá "Iniciado" na coluna Estado). Se o serviço não estiver em execução, clique com o botão direito do rato emOffice Source Engine e, em seguida, clique em Parar.
  6. Feche a janela Serviços.
Passo 3: Remova todas as pastas de instalação restantes do Microsoft Office de 2007.
  1. Clique em Iniciar.
  2. Clique em Todos os Programas e, em seguida, abra a pasta Acessórios (ignore este passo no Windows XP).
  3. Clique em Executar e, em seguida, clique na caixa Abrir.
  4. Escreva %CommonProgramFiles%\Microsoft Shared e clique em OK.
    Nota Num computador com uma versão de 64 bits do Windows 7 ou Vista, escreva %CommonProgramFiles(x86)%\Microsoft Shared e, em seguida, clique em OK.

  5. Elimine as seguintes pastas, caso existam:
    • Office12
    • Source Engine
  6. Clique em Iniciar.
  7. Clique em Todos os Programas e, em seguida, abra a pasta Acessórios (ignore este passo no Windows XP).
  8. Clique em Executar e, em seguida, clique na caixa Abrir.
  9. Escreva %ProgramFiles%\Microsoft Office e clique em OK.
    Nota Num computador com uma versão de 64 bits do Windows 7 ou Vista, escreva %ProgramFiles(x86)%\Microsoft Office e, em seguida, clique em OK.

  10. Elimine a pasta Office12.
  11. Na pasta raiz de cada unidade de disco rígido, localize e abra a pasta MSOCache. Se não conseguir ver esta pasta, siga estes passos:
    1. Abra o Explorador do Windows e clique em Opções de Pastas no menu Ferramentas.
    2. Clique no separador Ver.
    3. No painel Definições avançadas, clique em Mostrar ficheiros e pastas ocultos em Ficheiros e pastas ocultos.
    4. Desmarque a caixa de verificação Ocultar ficheiros protegidos do sistema operativo e clique em OK.
  12. Abra a pasta Todos os Utilizadores na pasta MSOCache e, em seguida, elimine todas as pastas que contenham o texto 0FF1CE}- no nome de pasta.
    Nota Este texto contém um zero e um 1 para as letras "O" e "I".
    Exemplo {90140000-001B-0409-0000-0000000FF1CE}-C
Passo 4: Remova todos os ficheiros de instalação restantes do Microsoft Office de 2007.
  1. Clique em Iniciar.
  2. Clique em Todos os Programas e, em seguida, abra a pasta Acessórios (ignore este passo no Windows XP).
  3. Clique em Executar e, em seguida, clique na caixa Abrir.
  4. Escreva %appdata%\microsoft\templates e, em seguida, clique em OK.
  5. Elimine os seguintes ficheiros:
    • Normal.dotm
    • Normalemail.dotm
  6. Clique em Iniciar.
  7. Clique em Todos os Programas e, em seguida, abra a pasta Acessórios (ignore este passo no Windows XP).
  8. Clique em Executar e, em seguida, clique na caixa Abrir.
  9. Escreva %appdata%\microsoft\document building blocks e clique em OK.
  10. Abra a subpasta encontrada na pasta Blocos Modulares de Documento.
    Nota O título da subpasta será um número de quatro dígitos que representa o idioma do conjunto de aplicações do Microsoft Office.

  11. Elimine o ficheiro building blocks.dotx.
  12. Feche todos os programas antes de seguir os passos restantes.
  13. Clique em Iniciar.
  14. Clique em Todos os Programas e, em seguida, abra a pasta Acessórios (ignore este passo no Windows XP).
  15. Clique em Executar e, em seguida, clique na caixa Abrir.
  16. Escreva %temp% e clique em OK.
  17. No menu Editar, clique em Seleccionar Tudo.
  18. No menu Ficheiro, clique em Eliminar.
  19. Clique em Iniciar.
  20. Clique em Todos os Programas e, em seguida, abra a pasta Acessórios (ignore este passo no Windows XP).
  21. Clique em Executar e, em seguida, clique na caixa Abrir.
  22. Escreva %AllUsersprofile%\Application Data\Microsoft\Office\Data e clique em OK.
  23. Elimine o ficheiro opa12.dat (e APENAS este ficheiro).
Passo 5: Remova as subchaves de registo do Microsoft Office system de 2007.
Aviso Podem ocorrer problemas graves se modificar incorrectamente o registo utilizando o Editor de Registo ou qualquer outro método. Estes problemas poderão exigir a reinstalação do sistema operativo. A Microsoft não garante que estes problemas possam ser resolvidos. Todo e qualquer risco decorrente da modificação do registo é da responsabilidade do utilizador.

Importante Este artigo contém informações sobre como modificar o registo. Certifique-se de que cria uma cópia de segurança do registo antes de o modificar. Certifique-se de que sabe como restaurar o registo se ocorrer um problema. Para mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento Microsoft:
322756 Como criar uma cópia de segurança e restaurar o registo no Windows

Localize e elimine as subchaves do registo do Office 2007, caso existam. Para tal, siga estes passos:
  1. Clique em Iniciar.
  2. Clique em Todos os Programas e, em seguida, abra a pasta Acessórios (ignore este passo no Windows XP).
  3. Clique em Executar e, em seguida, clique na caixa Abrir.
  4. Escreva regedit e clique em OK.
  5. Clique na seguinte subchave de registo:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  6. No menu Ficheiro, clique em Exportar, escreva DeletedKey01 e, em seguida, clique em Guardar.
  7. No menu Editar, clique em Eliminar e clique em Sim para confirmar.
  8. Repita estes passos (1 até 7) para cada subchave de registo na lista seguinte. Altere o nome da chave exportada para um nome de cada subchave.
    Exemplo Escreva DeletedKey02 para a segunda chave, escreva DeletedKey03 para a terceira chave e assim sucessivamente.
Nota: nas seguintes chaves de registo, o carácter (*) representa um ou mais caracteres no nome da subchave.

Versões de 32 bits do Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\*Office12*
Versões de 64 bits do Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\*Office12*
Continue com estas subchaves de registo:
  1. Localize a seguinte subchave do registo:

    32 bits: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
    64 bits: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

  2. No menu Ficheiro, clique em Exportar, escreva UninstallKey01 e clique em Guardar.
  3. Na subchave Desinstalar localizada no passo 1, clique em cada subchave e, em seguida, verifique se a subchave tem o seguinte valor atribuído:
    • Nome: UninstallString
    • Dados: caminho nome_do_ficheiro caminho\Office Setup Controller\Setup.exe

      Nota Neste exemplo, nome_do_ficheiro é um marcador de posição para o nome de um programa de instalação e caminho é um marcador de posição para o caminho do ficheiro.
  4. Se a subchave incluir o nome e os dados descritos no passo 3, clique em Eliminar no menu Editar. Caso contrário, avance para o passo 5.
  5. Repita os passos 3 e 4 até ter localizado e eliminado todas as subchaves que correspondam ao nome e dados descritos no passo 3.
  6. Feche o Editor de Registo.
Passo 6: Reinicie o computador.
Reinicie o computador. Se a remoção foi bem-sucedida, o processo está concluído e já pode reinstalar o Microsoft Office, se o desejar. Se a remoção não tiver sido bem-sucedida, consulte a secção "Referências" neste artigo.

Mais Informação
Referências

Mais Opções de Suporte:

Se as informações neste artigo da base de dados de conhecimento não o ajudaram a resolver o seu problema de desinstalação, seleccione uma das opções seguintes:
OFF2007 Office2007 Office 2007 cleansweep clean sweep manual manually fixit fix it remove uninstall control panel
Propriedades

ID do Artigo: 928218 - Última Revisão: 01/29/2013 15:52:00 - Revisão: 7.0

  • Microsoft Office Professional Plus 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Basic 2007
  • kbexpertiseinter kberrmsg kbregistry kbsetup kbinstallation kbtshoot kbprb kbfixme kbmsifixme kbcip KB928218
Esta informação foi útil?