A função ÍNDICE devolve um valor ou a referência a um valor de uma tabela ou intervalo.

O seu browser não suporta vídeo.

Existem duas formas de utilizar a função ÍNDICE:

  • Se quiser devolver o valor de uma determinada célula ou matriz de células, consulte Forma de matriz.

  • Se quiser devolver uma referência para determinadas células, consulte Forma de referência.

Forma de matriz

Descrição

Devolve o valor de um elemento numa tabela ou numa matriz, selecionado pelos índices do número de linha e coluna.

Utilize a forma de matriz quando o primeiro argumento de ÍNDICE for uma constante de matriz.

Sintaxe

ÍNDICE(matriz, núm_linha, [núm_coluna])

A forma de matriz da função ÍNDICE tem os seguintes argumentos:

  • matriz    Obrigatório. É um intervalo de células ou uma constante de matriz.

    • Se a matriz contiver apenas uma linha ou coluna, a row_num ou column_num argumento correspondente é opcional.

    • Se a matriz tiver mais do que uma linha e mais do que uma coluna e for utilizada apenas row_num ou column_num, ÍNDICE devolve uma matriz da linha ou coluna inteira na matriz.

  • núm_linha    Obrigatório, a menos column_num que esteja presente. Seleciona a linha na matriz a partir da qual é devolvido um valor. Se row_num for omitido, é column_num necessário.

  • column_num    Opcional. Seleciona a coluna na matriz a partir da qual é devolvido um valor. Se column_num for omitido, é row_num necessário.

Observações

  • Se os argumentos row_num e column_num argumentos da célula são utilizados, ÍNDICE devolve o valor na célula na interseção de row_num e column_num.

  • row_num e column_num têm de apontar para uma célula na matriz; Caso contrário, ÍNDICE devolve um #REF! #CAMPO!.

  • Se definir row_num ou column_num como 0 (zero), ÍNDICE devolve a matriz de valores de toda a coluna ou linha, respetivamente. Para utilizar os valores devolvidos como matriz, introduza a função ÍNDICE como uma fórmula de matriz.

    Nota: Se tiver uma versão atual do Microsoft 365,pode introduzir a fórmula na célula superior esquerda do intervalo de saída e, em seguida, premir Enter para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula tem de ser introduzida como uma fórmula de matriz legada ao selecionar primeiro o intervalo de saída, introduzir a fórmula na célula superior esquerda do intervalo de saída e, em seguida, premir Ctrl+Shift+Enter para confirmar. O Excel insere automaticamente parênteses retos no início e no fim da fórmula. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Exemplos

Exemplo 1

Estes exemplos utilizam a função ÍNDICE para encontrar o valor na célula de interceção entre uma linha e uma coluna.

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem os resultados, selecione-as, prima F2 e, em seguida, prima Enter.

Dados

Dados

Maçãs

Limões

Bananas

Peras

Fórmula

Descrição

Resultado

=ÍNDICE(A2:B3,2,2)

Valor do cruzamento da segunda linha e da segunda coluna no intervalo A2:B3.

Peras

=ÍNDICE(A2:B3,2,1)

Valor do cruzamento da segunda linha e da primeira coluna no intervalo A2:B3

Bananas

Exemplo 2

Este exemplo utiliza a função ÍNDICE numa fórmula de matriz para encontrar os valores em duas células especificadas numa matriz 2x2.  

Nota: Se tiver uma versão atual do Microsoft 365,pode introduzir a fórmula na célula superior esquerda do intervalo de saída e, em seguida, premir Enter para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula tem de ser introduzida como uma fórmula de matriz legada ao selecionar primeiro duas células em branco, introduzir a fórmula na célula superior esquerda do intervalo de saída e, em seguida, premir Ctrl+Shift+Enter para confirmar. O Excel insere automaticamente parênteses retos no início e no fim da fórmula. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Fórmula

Descrição

Resultado

=ÍNDICE({1,2;3,4},0,2)

Valor encontrado na primeira linha, segunda coluna da matriz. A matriz contém 1 e 2 na primeira linha e 3 e 4 na segunda linha.

2

Valor encontrado na segunda linha, segunda coluna na matriz (mesma matriz que em cima).

4

Início da Página


Formulário de referência

Descrição

Devolve a referência da célula na interseção de uma determinada linha e coluna. Se a referência for formada por seleções não adjacentes, pode escolher a seleção em que procurar.

Sintaxe

núm_linha(referência;núm_linha;[núm_coluna];[núm_área])

A forma de referência da função ÍNDICE tem os seguintes argumentos:

  • referência    Obrigatório. É uma referência a um ou mais intervalos de células.

    • Se estiver a introduzir um intervalo não adjacente para a referência, entre parênteses.

    • Se cada área na referência contiver apenas uma linha ou coluna, o argumento row_num ou column_num, respetivamente, é opcional. Por exemplo, para uma referência a uma única linha, utilize ÍNDICE(referência;núm_coluna).

  • row_num    Obrigatório. É o número da linha na referência a partir da qual é devolvida uma referência.

  • column_num    Opcional. É o número da coluna na referência a partir da qual é devolvida uma referência.

  • area_num    Opcional. Seleciona um intervalo na referência a partir do qual é devolva a interseção de row_num e column_num. A primeira área selecionada ou introduzida está numerada 1, a segunda é 2 e assim por agora. Se area_num for omitido, ÍNDICE utiliza a área 1.  As áreas aqui listadas têm de estar todas localizadas numa folha.  Se especificar áreas que não estão na mesma folha que as outras, irá causar um #VALUE! #CAMPO!.  Se precisar de utilizar intervalos localizados em folhas diferentes, recomenda-se que utilize a forma de matriz da função ÍNDICE e utilize outra função para calcular o intervalo que forma a matriz.  Por exemplo, pode utilizar a função SELECIONAR para calcular o intervalo que será utilizado.

Por exemplo, se a Referência descrever as células (A1:B4,D1:E4,G1:H4), area_num 1 é o intervalo A1:B4, area_num 2 é o intervalo D1:E4 e area_num 3 é o intervalo G1:H4.

Observações

  • Após a referência e area_num selecionarem um intervalo específico, row_num e column_num selecionar uma célula específica: row_num 1 é a primeira linha do intervalo, column_num 1 é a primeira coluna e assim por cima. A referência devolvida por ÍNDICE é a interseção de row_num e column_num.

  • Se definir uma row_num ou column_num como 0 (zero), ÍNDICE devolve a referência de toda a coluna ou linha, respetivamente.

  • row_num, column_num e area_num têm de apontar para uma célula numa referência; Caso contrário, ÍNDICE devolve um #REF! #CAMPO!. Se row_num e column_num área são omitidas, ÍNDICE devolve a área na referência especificada pela area_num.

  • O resultado da função ÍNDICE é uma referência e é interpretado como tal por outras fórmulas. Dependendo da fórmula, o valor devolvido de ÍNDICE pode ser utilizado como uma referência ou como um valor. Por exemplo, a fórmula CÉL ("largura";ÍNDICE(A1:B2;1;2)) é equivalente a CÉL ("largura";B1). A função CÉL utiliza o valor devolvido de ÍNDICE como uma referência de célula. Por outro lado, uma fórmula como 2*ÍNDICE(A1:B2;1;2) converte o valor devolvido por ÍNDICE no número da célula B1.

Exemplos

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima Enter.

Fruta

Preço

Contagem

Maçãs

0,69 €

40

Bananas

0,34 €

38

Limões

0,55 €

15

Laranjas

0,25 €

25

Peras

0,59 €

40

Amêndoas

2,80 €

10

Acajus

3,55 €

16

Amendoins

1,25 €

20

Nozes

1,75 €

12

Fórmula

Descrição

Resultado

=ÍNDICE(A2:C6;2;3)

A interseção da segunda linha e da terceira coluna no intervalo A2:C6, que é o conteúdo da célula C3.

38

=ÍNDICE((A1:C6;A8:C11);2;2;2)

A interseção da segunda linha e da segunda coluna na segunda área de A8:C11, que é o conteúdo da célula B9.

1,25

=SOMA(ÍNDICE(A1:C11;0;3;1))

A soma da terceira coluna na primeira área do intervalo A1:C11, que é a soma de C1:C11.

216

=SOMA(B2:ÍNDICE(A2:C6;5;2))

A soma do intervalo com início em B2 e fim na interseção da quinta linha e da segunda coluna do intervalo A2:A6, que é a soma de B2:B6.

2,42

Início da Página

Consulte Também

Função PROCV

Função CORRESP

Função INDIRETO

Diretrizes e exemplos de fórmulas de matriz

Funções de pesquisa e referência (referência)

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft insiders

As informações foram úteis?

Quão satisfeito está com a qualidade da tradução?

O que afetou a sua experiência?

Comentários adicionais? (Opcional)

Obrigado pelos seus comentários!

×