Iniciar sessão com uma conta Microsoft
Inicie sessão ou crie uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Escolha a conta com a qual pretende iniciar sessão.

A função ÍNDICE devolve um valor ou a referência a um valor de uma tabela ou intervalo.

O seu browser não suporta vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Existem duas formas de utilizar a função ÍNDICE:

  • Se quiser devolver o valor de uma determinada célula ou matriz de células, consulte Forma de matriz.

  • Se quiser devolver uma referência para determinadas células, consulte Forma de referência.

Forma de matriz

Descrição

Devolve o valor de um elemento numa tabela ou numa matriz, selecionada pelos índices do número de linha e coluna.

Utilize a forma de matriz quando o primeiro argumento de ÍNDICE for uma constante de matriz.

Sintaxe

ÍNDICE(matriz, núm_linha, [núm_coluna])

A forma de matriz da função ÍNDICE tem os seguintes argumentos:

  • matriz    Obrigatório. É um intervalo de células ou uma constante de matriz.

    • Se a matriz contiver apenas uma linha ou coluna, o argumento núm_linha ou núm_coluna correspondente é opcional.

    • Se a matriz apresentar mais de uma linha e mais de uma coluna e se for utilizado apenas núm_linha ou núm_coluna, ÍNDICE devolve uma matriz da linha ou coluna inteira na matriz.

  • núm_linha    Obrigatório, a menos que núm_coluna esteja presente. Seleciona a linha na matriz a partir da qual é devolvido um valor. Se núm_linha for omitido, é necessário núm_coluna.

  • núm_coluna    Opcional. Seleciona a coluna na matriz a partir da qual é devolvido um valor. Se núm_coluna for omitido, é necessário núm_linha.

Observações

  • Se os argumentos núm_linha e núm_coluna forem utilizados, ÍNDICE devolve o valor da célula na interseção de núm_linha com núm_coluna.

  • núm_linha e núm_coluna têm de apontar para uma célula na matriz; caso contrário, ÍNDICE devolve o valor de erro #REF!. .

  • Se definir núm_linha ou núm_coluna como 0 (zero), ÍNDICE devolve a matriz de valores de toda a coluna ou de toda a linha, respetivamente. Para utilizar valores devolvidos como uma matriz, introduza a função ÍNDICE como uma fórmula de matriz.

    Nota: Se tiver uma versão atual do Microsoft 365, pode introduzir a fórmula na célula superior esquerda do intervalo de saída e, em seguida, premir ENTER para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula tem de ser introduzida como uma fórmula de matriz legada ao selecionar primeiro o intervalo de saída, inserir a fórmula na célula superior esquerda do intervalo de saída e, em seguida, premir CTRL+SHIFT+ENTER para confirmar. O Excel insere automaticamente parênteses retos no início e no fim da fórmula. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Exemplos

Exemplo 1

Estes exemplos utilizam a função ÍNDICE para encontrar o valor na célula de interceção entre uma linha e uma coluna.

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem os resultados, selecione-as, prima F2 e, em seguida, prima Enter.

Dados

Dados

Maçãs

Limões

Bananas

Peras

Fórmula

Descrição

Resultado

=ÍNDICE(A2:B3,2,2)

Valor do cruzamento da segunda linha e da segunda coluna no intervalo A2:B3.

Peras

=ÍNDICE(A2:B3,2,1)

Valor do cruzamento da segunda linha e da primeira coluna no intervalo A2:B3

Bananas

Exemplo 2

Este exemplo utiliza a função ÍNDICE numa fórmula de matriz para encontrar os valores em duas células especificadas numa matriz 2x2.  

Nota: Se tiver uma versão atual do Microsoft 365, pode introduzir a fórmula na célula superior esquerda do intervalo de saída e, em seguida, premir ENTER para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula tem de ser introduzida como uma fórmula de matriz legada ao selecionar primeiro duas células em branco, inserir a fórmula na célula superior esquerda do intervalo de saída e, em seguida, premir Ctrl+Shift+Enter para confirmar. O Excel insere automaticamente parênteses retos no início e no fim da fórmula. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Fórmula

Descrição

Resultado

=ÍNDICE({1,2;3,4},0,2)

Valor encontrado na primeira linha, segunda coluna da matriz. A matriz contém 1 e 2 na primeira linha e 3 e 4 na segunda linha.

2

Valor encontrado na segunda linha, segunda coluna na matriz (mesma matriz que em cima).

4

Início da Página


Forma de referência

Descrição

Devolve a referência da célula na interseção de uma determinada linha e coluna. Se a referência for formada por seleções não adjacentes, pode escolher a seleção em que deseja procurar.

Sintaxe

núm_linha(referência;núm_linha;[núm_coluna];[núm_área])

A forma de referência da função ÍNDICE tem os seguintes argumentos:

  • referência    Obrigatório. É uma referência a um ou mais intervalos de células.

    • Se estiver a introduzir um intervalo não adjacente para a referência, coloque a referência entre parênteses.

    • Se cada área na referência contiver apenas uma linha ou coluna, o argumento núm_linha ou núm_coluna, respetivamente, é opcional. Por exemplo, para uma referência a uma única linha, utilize ÍNDICE(referência;núm_coluna).

  • núm_linha    Obrigatório. É o número da linha na referência a partir da qual é devolvida uma referência.

  • núm_coluna    Opcional. É o número da coluna na referência a partir da qual é devolvida uma referência.

  • núm_área    Opcional. Seleciona um intervalo na referência a partir do qual é devolvida a interseção de núm_linha e núm_coluna. A primeira área selecionada ou introduzida recebe o número 1, a segunda recebe o número 2 e assim sucessivamente. Se núm_área for omitido, ÍNDICE utiliza a área 1.  As áreas listadas aqui têm de estar localizadas numa única folha.  Se especificar áreas que não se encontram na mesma folha, será apresentado um erro #VALOR! .  Se precisar de utilizar intervalos localizados em folhas diferentes, recomendamos que utilize a forma de matriz da função ÍNDICE e que utilize outra função para calcular o intervalo que constitui a matriz.  Por exemplo, pode utilizar a função SELECIONAR para calcular o intervalo que será utilizado.

Por exemplo, se a Referência descrever as células (A1:B4,D1:E4,G1:H4), núm_área 1 representa o intervalo A1:B4, núm_área 2 o intervalo D1:E4 e núm_área 3 o intervalo G1:H4.

Observações

  • Depois de a referência e de o núm_área terem selecionado um intervalo específico, núm_linha e núm_coluna selecionam uma célula específica: núm_linha 1 é a primeira linha do intervalo, núm_coluna 1 é a primeira coluna e assim sucessivamente. A referência devolvida por ÍNDICE é a interceção entre núm_linha e núm_coluna.

  • Se definir núm_linha ou núm_coluna como 0 (zero), ÍNDICE devolve a referência para a coluna ou linha inteira, respetivamente.

  • núm_linha, núm_coluna e núm_área têm de apontar para uma célula na referência; caso contrário, ÍNDICE devolve o valor de erro #REF! . Se núm_linha e núm_coluna forem omitidos, ÍNDICE devolve a área na referência especificada por núm_área.

  • O resultado da função ÍNDICE é uma referência e é interpretado como tal por outras fórmulas. Dependendo da fórmula, o valor devolvido de ÍNDICE pode ser utilizado como uma referência ou como um valor. Por exemplo, a fórmula CÉL ("largura";ÍNDICE(A1:B2;1;2)) é equivalente a CÉL ("largura";B1). A função CÉL utiliza o valor devolvido de ÍNDICE como uma referência de célula. Por outro lado, uma fórmula como 2*ÍNDICE(A1:B2;1;2) converte o valor devolvido por ÍNDICE no número da célula B1.

Exemplos

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima Enter.

Fruta

Preço

Contagem

Maçãs

0,69 €

40

Bananas

0,34 €

38

Limões

0,55 €

15

Laranjas

0,25 €

25

Peras

0,59 €

40

Amêndoas

2,80 €

10

Acajus

3,55 €

16

Amendoins

1,25 €

20

Nozes

1,75 €

12

Fórmula

Descrição

Resultado

=ÍNDICE(A2:C6;2;3)

A interseção da segunda linha e da terceira coluna no intervalo A2:C6, que é o conteúdo da célula C3.

38

=ÍNDICE((A1:C6;A8:C11);2;2;2)

A interseção da segunda linha e da segunda coluna na segunda área de A8:C11, que é o conteúdo da célula B9.

1,25

=SOMA(ÍNDICE(A1:C11;0;3;1))

A soma da terceira coluna na primeira área do intervalo A1:C11, que é a soma de C1:C11.

216

=SOMA(B2:ÍNDICE(A2:C6;5;2))

A soma do intervalo com início em B2 e fim na interseção da quinta linha e da segunda coluna do intervalo A2:A6, que é a soma de B2:B6.

2,42

Início da Página

Consulte Também

Função PROCV

Função CORRESP

Função INDIRETO

Diretrizes e exemplos de fórmulas de matriz

Funções de pesquisa e referência (referência)

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft Office insiders

As informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?

Obrigado pelo seu feedback!

×