ÍNDICE (Função ÍNDICE)

A função ÍNDICE devolve um valor ou a referência a um valor de uma tabela ou intervalo.

Cause um grande impacto com os Anúncios

Existem duas formas de utilizar a função ÍNDICE:

  • Se quiser devolver o valor de uma determinada célula ou matriz de células, consulte Forma de matriz.

  • Se quiser devolver uma referência para determinadas células, consulte Forma de referência.

Forma de matriz

Descrição

Devolve o valor de um elemento numa tabela ou numa matriz, selecionada pelos índices de números da linha e da coluna.

Utilize a forma de matriz quando o primeiro argumento de ÍNDICE for uma constante de matriz.

Sintaxe

ÍNDICE(matriz, núm_linha, [núm_coluna])

A forma de matriz da função INDEX tem os seguintes argumentos:

  • matriz    Obrigatório. É um intervalo de células ou uma constante de matriz.

    • Se a matriz contiver apenas uma linha ou coluna, o argumento correspondente row_num ou column_num é opcional.

    • Se a matriz tiver mais de uma linha e mais de uma coluna, e apenas for utilizado row_num ou column_num, o INDEX devolve uma série de toda a linha ou coluna na matriz.

  • núm_linha    Obrigatório, a menos que column_num esteja presente. Seleciona a linha na matriz a partir da qual é devolvido um valor. Se row_num for omitida, é necessário column_num.

  • column_num    Opcional. Seleciona a coluna na matriz a partir da qual é devolvido um valor. Se column_num for omitida, é necessário row_num.

Observações

  • Se forem utilizados argumentos row_num e column_num, o INDEX devolve o valor da célula na intersecção entre row_num e column_num.

  • row_num e column_num devem apontar para uma célula dentro da matriz; caso contrário, o INDEX devolve uma #REF! .

  • Se definir row_num ou column_num a 0 (zero), o INDEX devolve a gama de valores para toda a coluna ou linha, respectivamente. Para utilizar os valores devolvidos como uma matriz, introduza a função INDEX como uma fórmula de matriz.

    Nota: Se tiver uma versão atual do Microsoft 365, então pode inserir a fórmula na célula superior esquerda da gama de saída, em seguida, prima ENTER para confirmar a fórmula como uma fórmula dinâmica de matriz. Caso contrário, a fórmula deve ser inserida como uma fórmula de matriz legado selecionando primeiro a gama de saída, insira a fórmula na célula superior-esquerda da gama de saída e, em seguida, prima CTRL+SHIFT+ENTER para confirmá-la. O Excel insere os suportes encaracolados no início e no fim da fórmula para si. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Exemplos

Exemplo 1

Estes exemplos utilizam a função ÍNDICE para encontrar o valor na célula de interceção entre uma linha e uma coluna.

Copie os dados de exemplo da tabela seguinte e cole-os na célula A1 de uma folha de cálculo nova do Excel. Para que as fórmulas mostrem os resultados, selecione-as, prima F2 e, em seguida, prima Enter.

Dados

Dados

Maçãs

Limões

Bananas

Peras

Fórmula

Descrição

Resultado

=ÍNDICE(A2:B3,2,2)

Valor do cruzamento da segunda linha e da segunda coluna no intervalo A2:B3.

Peras

=ÍNDICE(A2:B3,2,1)

Valor do cruzamento da segunda linha e da primeira coluna no intervalo A2:B3

Bananas

Exemplo 2

Este exemplo utiliza a função ÍNDICE numa fórmula de matriz para encontrar os valores em duas células especificadas numa matriz 2x2.  

Nota: Se tiver uma versão atual do Microsoft 365, então pode inserir a fórmula na célula superior esquerda da gama de saída, em seguida, prima ENTER para confirmar a fórmula como uma fórmula dinâmica de matriz. Caso contrário, a fórmula deve ser inserida como uma fórmula de matriz legado selecionando primeiro duas células em branco, insira a fórmula na célula superior-esquerda da gama de saída e, em seguida, prima CTRL+SHIFT+ENTER para confirmá-la. O Excel insere os suportes encaracolados no início e no fim da fórmula para si. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Fórmula

Descrição

Resultado

=ÍNDICE({1,2;3,4},0,2)

Valor encontrado na primeira linha, segunda coluna da matriz. A matriz contém 1 e 2 na primeira linha e 3 e 4 na segunda linha.

2

Valor encontrado na segunda linha, segunda coluna na matriz (mesma matriz que em cima).

4

Início da Página


Formulário de referência

Descrição

Devolve a referência da célula na interseção de uma determinada linha e coluna. Se a referência for composta por seleções não adjacentes, pode escolher a seleção para ver.

Sintaxe

núm_linha(referência;núm_linha;[núm_coluna];[núm_área])

A forma de referência da função INDEX tem os seguintes argumentos:

  • referência    Obrigatório. É uma referência a um ou mais intervalos de células.

    • Se estiver a introduzir uma gama não adjacente para a referência, encerre referência seletiva em parênteses.

    • Se cada área de referência contiver apenas uma linha ou coluna, o argumento row_num ou column_num, respectivamente, é opcional. Por exemplo, para uma referência a uma única linha, utilize ÍNDICE(referência;núm_coluna).

  • row_num    Obrigatório. É o número da linha na referência a partir da qual é devolvida uma referência.

  • column_num    Opcional. É o número da coluna na referência a partir da qual é devolvida uma referência.

  • area_num    Opcional. Seleciona uma gama de referência para devolver o cruzamento de row_num e column_num. A primeira área selecionada ou inserida é numerada 1, a segunda é 2, e assim por diante. Se area_num for omitida, o INDEX utiliza a área 1.  As áreas aqui listadas devem estar todas localizadas numa folha.  Se especificar áreas que não estão na mesma folha umas das outras, irá causar uma #VALUE! .  Se precisar de utilizar gamas que estejam localizadas em folhas diferentes umas das outras, recomenda-se que utilize a forma de matriz da função INDEX e utilize outra função para calcular a gama que compõe a matriz.  Por exemplo, pode utilizar a função CHOOSE para calcular qual o intervalo que será utilizado.

Por exemplo, se a Referência descreve as células (A1:B4,D1:E4,G1:H4), area_num 1 é o intervalo A1:B4, area_num 2 é o intervalo D1:E4, e area_num 3 é o intervalo G1:H4.

Observações

  • Após referência e area_num selecionou uma determinada gama, row_num e column_num selecionar uma determinada célula: row_num 1 é a primeira linha da gama, column_num 1 é a primeira coluna, e assim por diante. A referência devolvida pelo INDEX é a intersecção de row_num e column_num.

  • Se definir row_num ou column_num a 0 (zero), o INDEX devolve a referência para toda a coluna ou linha, respectivamente.

  • row_num, column_num e area_num devem apontar para uma célula de referência; caso contrário, o INDEX devolve uma #REF! . Se row_num e column_num forem omitidos, o INDEX devolve a área em referência especificada por area_num.

  • O resultado da função ÍNDICE é uma referência e é interpretado como tal por outras fórmulas. Dependendo da fórmula, o valor devolvido de ÍNDICE pode ser utilizado como uma referência ou como um valor. Por exemplo, a fórmula CÉL ("largura";ÍNDICE(A1:B2;1;2)) é equivalente a CÉL ("largura";B1). A função CÉL utiliza o valor devolvido de ÍNDICE como uma referência de célula. Por outro lado, uma fórmula como 2*ÍNDICE(A1:B2;1;2) converte o valor devolvido por ÍNDICE no número da célula B1.

Exemplos

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima Enter.

Fruta

Preço

Contagem

Maçãs

0,69 €

40

Bananas

0,34 €

38

Limões

0,55 €

15

Laranjas

0,25 €

25

Peras

0,59 €

40

Amêndoas

2,80 €

10

Acajus

3,55 €

16

Amendoins

1,25 €

20

Nozes

1,75 €

12

Fórmula

Descrição

Resultado

=ÍNDICE(A2:C6;2;3)

A interseção da segunda linha e da terceira coluna no intervalo A2:C6, que é o conteúdo da célula C3.

38

=ÍNDICE((A1:C6;A8:C11);2;2;2)

A interseção da segunda linha e da segunda coluna na segunda área de A8:C11, que é o conteúdo da célula B9.

1,25

=SOMA(ÍNDICE(A1:C11;0;3;1))

A soma da terceira coluna na primeira área do intervalo A1:C11, que é a soma de C1:C11.

216

=SOMA(B2:ÍNDICE(A2:C6;5;2))

A soma do intervalo com início em B2 e fim na interseção da quinta linha e da segunda coluna do intervalo A2:A6, que é a soma de B2:B6.

2,42

Início da Página

Consulte Também

Função PROCV

Função CORRESP

Função INDIRETO

Diretrizes e exemplos de fórmulas de matriz

Funções de pesquisa e referência (referência)

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Precisa de mais ajuda?

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×