Iniciar sessão com a Microsoft
Iniciar sessão ou criar uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Selecione a conta com a qual pretende iniciar sessão.

Sintomas

Quando tenta aceder a um Web site que requer que Silverlight apresente o conteúdo, recebe uma mensagem de erro que diz que tem de instalar silverlight.

Causa

Este comportamento pode ocorrer por várias razões:

  • O seu sistema tem uma versão anterior do plug-in e não cumpre os requisitos para o plug-in que o site está a utilizar.

  • Não tem o plug-in instalado.

  • O navegador está definido para "Executar usando Rosetta", o que fará com que o computador seja identificado incorretamente como um Mac baseado em PowerPC.

Resolução

Antes de determinar como lidar com o problema, deve avaliar o ambiente atual em que o software está em execução. Para tal, siga estes passos:

  1. No menu Apple, selecione Sobre este Mac.

  2. Note o tipo de processador, velocidade, RAM e informações do sistema operativo, uma vez que alguns web sites têm requisitos específicos para visualizar o seu conteúdo.

  3. Feche a janela.

  4. Feche todas as janelas abertas do navegador.

  5. Clique duas vezes no ícone do disco rígido no ambiente de trabalho.

  6. Clique duas vezes na pasta Library.

  7. Abra a pasta Plug-ins da Internet.

  8. Há algum ficheiro chamado Silverlight.plugin? Se este ficheiro existir, o plug-in é instalado. Para determinar a versão, clique para selecionar o ficheiro. Em seguida, selecione Obter Informações no menu 'Ficheiro'. Note o número de versão que é apresentado.

    • Se o número de versão que é apresentado for 1.0.xxx e o seu tipo de processador é um PowerPC, tem a versão correta do plug-in instalado.

    • Se tiver um Processador Intel, todas as versões de Silverlight são suportadas. Mas recomendamos que execute a versão mais recente para que possa aceder a Web sites que utilizem as funcionalidades mais recentes e tirar partido das mais recentes melhorias do produto.

Agora podemos abordar as causas e as resoluções individuais.

O seu sistema tem uma versão anterior do plug-in e não cumpre os requisitos do Web site

A causa mais comum deste problema é que o Web site está a usar silverlight 3 para o seu conteúdo. Se um site necessitar da versão 3, reconhece se o seu sistema cumpre o requisito. Se o sistema não o fizer, é-lhe pedido que atualize. Está direcionado para o local de Silverlight. Se estiver a utilizar um PowerPC, o site reconhece-o e só a versão 1 pode ser instalada. (Esta situação teria de ser abordada pela equipa de suporte do Web site, uma vez que a decisão sobre qual a versão da Silverlight a utilizar é tomada pelos designers do web site.)

Não tem o plug-in instalado

Se silverlight ainda não tiver sido instalada, siga estes passos para instalar o plug-in:

  1. Inicie um navegador web e, em seguida, visite o seguinte Web site:

    http://silverlight.net/getstarted/

  2. Localize a área "Instalar a Silverlight" na parte inferior direita da janela.

    • Se estiver a executar um processador Intel, clique em Mac Runtime ao lado de "Silverlight 3".

    • Caso contrário, clique em Runtime para Mac PowerPC ao lado de "Silverlight 1.0".

  3. Após o download estar concluído, a instalação deve iniciar-se automaticamente. Siga os passos do assistente de instalação.

  4. Depois de concluída a instalação, deve ser solicitado que saia do seu navegador. Feche as janelas do navegador e, em seguida, reinicie o navegador. O navegador deve reconhecer o novo plug-in.

Nota Se tiver algum problema com a instalação, consulte o seguinte artigo da Base do Conhecimento do Microsoft para obter informações sobre como instalar manualmente o plug-in:

970064 Como remover e reinstalar manualmente Silverlight 2 para Mac

O navegador está definido para "Executar usando Rosetta", o que fará com que o computador seja identificado incorretamente como um Mac baseado em PowerPC

Se o navegador estiver programado para funcionar no motor Roseta, identificará incorretamente o computador como um Mac baseado em PowerPC, ou o Web site não reconhecerá que o plug-in apropriado está instalado. Se o plug-in apropriado for instalado como descrito na secção anterior, siga estes passos:

  1. Clique duas vezes no ícone do disco rígido no ambiente de trabalho.

  2. Escolha a pasta Aplicações.

  3. Encontre o ícone para o navegador que está a usar. Segure a tecla CONTROL enquanto clica neste ícone.

  4. Selecione Obter Informações.

  5. Localize a corrida utilizando a opção Roseta e certifique-se de que esta caixa de verificação não está selecionada. Se for selecionado, clique para limpar a caixa de verificação. Feche a janela.

  6. No menu Apple, clique em Reiniciar.

  7. Depois de o computador reiniciar, tente novamente aceder ao Web site que gerou a mensagem de erro.

Nota Se a versão adequada do plug-in não for instalada, certifique-se de que a caixa de verificação de Roseta não está selecionada e, em seguida, siga os passos na secção anterior para instalar o plug-in.

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.

Estas informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?
Ao selecionar submeter, o seu feedback será utilizado para melhorar os produtos e serviços da Microsoft. O seu administrador de TI poderá recolher estes dados. Declaração de Privacidade.

Obrigado pelo seu feedback!

×