Мы обновили Excel, чтобы добавить поддержку новой японской эры, которая началась с 1 мая 2019 г.  Это обновление включает числовой формат Ганнэн (японский год 1). Теперь вы можете редактировать и сохранять книги Excel с этим форматом.  

Чтобы применить числовой формат Ганнэн, выделите одну или несколько ячеек, к которым нужно применить этот формат, и нажмите клавиши Ctrl+1. В диалоговом окне Формат ячеек выберите Дата на вкладке Число. Выберите Японский в раскрывающемся списке Языковой стандарт (расположение), затем выберите Японский (от начала правления императора) в раскрывающемся списке Тип календаря. Убедитесь, что флажок Использовать Ганнэн для отображения 1-го года установлен, затем нажмите кнопку ОК.

Изображение диалогового окна "Формат ячеек" в области "Число" с примененным форматом даты Ганнэн.

Примечания: 

  • Мы в настоящее время развертываем эту возможность для Microsoft 365 пользователей. Для настольных Excel, она доступна в версии 1909 (сборка 12026.20320)для Current Channel. Мы работаем над реализацией поддержки этой функции и в других конечных точках (Mac, iOS и Android) в ближайшем будущем.

  • Если вы не используете Current Channel (Excel 2013, Excel 2016, Excel 2019, Microsoft 365 Semi-Annual Enterprise Channel (Preview) или Semi-Annual Enterprise Channel), или если у вас есть Excel с формулами, макросами или пользовательскими форматами, которые зависят от представления японской эры, вы можете использовать параметры пользовательского форматирования для даты Ганнэн, рассмотренные ниже.

  • Чтобы отправить отзыв об отображении японской эры в Excel или сообщить о проблемах, перейдите в меню Excel > Файл > Отзывы и воспользуйтесь командами Отправить смайлик/нахмуренный смайлик/предложение.

Отображение дат Ганнэн с помощью пользовательского числового формата при использовании более старой версии Excel

  1. Выделите ячейку или диапазон, которые требуется отформатировать.

  2. Нажмите клавиши CTRL+1, чтобы открыть диалоговое окно Формат ячеек.

  3. Откройте вкладку Число, а затем выберите пункт Дополнительный в разделе Категория.

  4. Скопируйте и вставьте следующую строку в текстовом поле Тип:

    [<=43585][$-ja-JP]ggge"?"m"?"d"?";[>=43831]ggge"?"m"?"d"?";ggg"??"m"?"d"?"

    Применение формата Ганнэн с пользовательским числовым форматом из диалогового окна Ctrl+1 > вкладка "Число" > "Дополнительный".

  5. Нажмите кнопку ОК, чтобы применить этот формат к выделенным ячейкам.

    В приведенном ниже примере показано, как дата отображалась до применения пользовательского числового формата.

    Изображение примененной японской даты без Ганнэн

    А так она будет выглядеть после применения пользовательского числового формата:

    Изображение с примененной эрой Ганнэн

    Обратите внимание, что выходные данные представлены в формате "Дополнительный", поэтому некоторые текстовые функции не будут работать, если сослаться на эти ячейки. Однако многие функции для работы с датами, например ЧИСТРАБНИ(), будут работать.

Отображение дат Ганнэн с помощью текстовой функции

Для отображения дат в формате Ганнэн также можно использовать текстовую функцию.

В приведенном ниже примере ячейки A5:A13 содержат значения дат, а ячейка A2 содержит строку формата, использованную в предыдущем примере:

[<=43585][$-ja-JP]ggge"?"m"?"d"?";[>=43831]ggge"?"m"?"d"?";ggg"??"m"?"d"?"

Формула =ТЕКСТ(A5;$A$2) была введена в ячейку C5 и скопирована в ячейки C5:C13.

Изображение применения формата Ганнэн с помощью функции ТЕКСТ: =ТЕКСТ(A1,$B$2), ячейка B2 содержит строку в формате Ганнэн.

Обратите внимание, что выходные данные представлены в формате "Общий", поэтому многие функции для работы с датами и текстом не будут работать, если сослаться на эти ячейки.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×