KB4490136 - ИСПРАВЛЕНО: Assertion error occurs when you use sys.dm_exec_query_statistics_xml in SQL Server 2016 and 2017

Применяется к
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 Developer Windows SQL Server 2017 Enterprise Windows SQL Server 2017 Enterprise Core Windows SQL Server 2017 Standard Windows

Проблема

Предположим, что вы используете sys.dm_exec_query_statistics_xml функции динамического управления (DMF) в Microsoft SQL Server 2016 и 2017. Если запрос, выполняемый в целевом ИД сеанса, уже завершен и DMF одновременно пытается получить план выполнения запроса, возникает ошибка утверждения.

Состояние

Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».

Решение

Проблема устранена в следующих накопительных обновлениях для SQL Server:

Сведения о накопительных обновлениях для SQL Server:

Каждый новый накопительный пакет обновления для SQL Server содержит все исправления и исправления безопасности, которые входили в состав предыдущего накопительного пакета обновления. Ознакомьтесь с последними накопительными пакетами обновления для SQL Server:

Ссылки

Узнайте о терминологии, используемой корпорацией Майкрософт для описания обновлений программного обеспечения.