KB4040519 - ИСПРАВЛЕНО: автоматическое заполнение в группах доступности случайным образом вызывает ошибку 41169 в SQL Server 2016 или 2017

Применяется к
SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 on Windows (all editions) SQL Server 2017 on Linux (all editions)

Проблема

Автоматическое заполнение группы доступности AlwaysOn настраивается в экземпляре Microsoft SQL Server 2016 или 2017. После добавления базы данных в группу доступности в экземпляре, содержащем вторичную реплику, появляется сообщение об ошибке, похожее на следующее:

Примечание

Ошибка 41169: при попытке доступа к базе данных группы доступности с идентификатором "%.*ls" в группе доступности "%.*ls" произошла ошибка. База данных доступности не найдена в конфигурации группы доступности. Убедитесь в правильности имени группы доступности и идентификатора базы данных доступности, а затем повторите команду.

Причина

Эта проблема возникает из-за того, что при автоматическом заполнении может случайным образом не удалось инициализировать базу данных доступности.

Решение

Это исправление входит в следующие накопительные пакеты обновления для SQL Server:

Накопительный пакет обновления 1 для SQL Server 2017

Накопительный пакет обновления 5 для SQL Server 2016 с пакетом обновления 1 (SP1)

Сведения о сборках SQL Server

Каждая новая сборка для SQL Server содержит все исправления и исправления безопасности, которые были включены в предыдущую сборку. Рекомендуется установить последние накопительные пакеты обновления для SQL Server:

Последний накопительный пакет обновления для SQL Server 2017

последняя сборка для SQL Server 2016

Состояние

Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».

Ссылки

Узнайте о терминологии, используемой корпорацией Майкрософт для описания обновлений программного обеспечения.