У вас есть различные возможности редактирования соединительных линий и работы с ними. Вы можете изменять цвет, толщину, стиль и кривизну линии, управлять внешним видом конечных точек и стрелок, придавать соединительной линии изогнутую, ломаную или прямую форму и управлять точками соединения различными способами.
Совет.
Команды в группе Инструменты на вкладке Главная позволяют переводить Visio в различные состояния и режимы, что иногда вызывает сложности. Используйте клавиатуру для удобного переключения между инструментами "Указатель" (нажмите CTRL+1) и "
соединителя" (нажмите CTRL+3). Независимо от того, какой инструмент вы используете, например Блок текста или Точка соединения, несколько раз нажмите клавишу ESC, чтобы вернуться к инструменту Указатель.
Эта статья в основном относится к стандартной фигуре Динамическая соединительная линия, которая может автоматически изменять направление для огибания других фигур. Существует несколько типов соединительных линий, например, большинство из набора элементов Дополнительные фигуры \ Дополнительные решения Visio \ Соединительные линии, которые не изменяют направление автоматически.
Что необходимо сделать
Придание соединительной линии изогнутой, ломаной или прямой формы
Вы можете изменить отдельную соединительную линию или изменить форму по умолчанию для всех новых соединительных линий.
Изменение соединительной линии
- Выделите соединительную линию.
- На вкладке " Конструктор " в группе "Макет " выберите "Соединительные линии", а затем выберите нужный стиль трассировки (прямоугольные, прямые илиизогнутые).
- Кроме того , можно изменить стиль соединительной линии в контекстном меню действий фигуры "Соединительная линия".
Изменение формы по умолчанию для новых соединительных линий
Установка прямоугольной, прямой или изогнутой формы в качестве формы по умолчанию:
- Отменить выделение всех фигур с помощью выбора страницы. Перейдите на вкладку "Конструктор ", а затем выберите раскрывающееся меню "Соединительные линии " в группе "Макет ". Выберите Прямой угол, Прямые линии или Кривые линии.
- Можно также перейти на вкладку "Файл ", выбрать "Печать", выбрать " Параметры страницы", открыть вкладку "Макеты и маршруты ", а затем в списке "Внешний вид " выбрать " Прямая " или "Изогнутая".
Добавление стрелок или других наконечников к соединительной линии
Вы можете добавлять к соединительной линии стрелки, точки или другие наконечники.
Выделите соединительную линию.
Выберите параметр «Формат фигуры » в меню действий, вызываемом правой кнопкой мыши. Или на вкладке Главная в группе Стили фигур выберите Линия, затем выберите Параметры линии.
В области Формат фигуры в разделе Линия выберите параметр Сплошная линия, затем выберите тип, размер и тип завершения.
Изменение толщины, стиля, цвета или кривизны соединительной линии
Выделите соединительную линию.
Выберите параметр «Формат фигуры » в меню действий, вызываемом правой кнопкой мыши. Или на вкладке Главная в группе Стили фигур выберите Линия, затем выберите Параметры линии.
В области Формат фигуры в разделе Линия задайте цвет, ширину, стиль и параметры округления.
Изменение направления соединительной линии на противоположное
Примечание
Для некоторых типов схем, например, для различных технологических схем, важным является направление соединения. Поэтому для таких соединительных линий должна использоваться команда Обратить концы вместо изменения формата концов. Кнопку команды "Обратные концы " можно легко добавить на ленту с помощью функции "Файл" \ "Параметры" \ "Настройка ленты... ". Эта команда дает возможность изменить направление всех выбранных соединительных линий на противоположное.
Или, чтобы изменить направление соединительной линии без использования команды Обратить концы, добавьте новую стрелку на том конце линии, где ее нет, и удалите стрелку на другом конце.
Выделите соединительную линию.
На вкладке Главная в группе Стили фигурвыберите Линия, затем выберите Параметры линии.
В области Формат фигуры в разделе Линия выберите:
Тип начальной стрелки и выполните действие 4.
Тип конечной стрелки и выполните действие 4.
Чтобы добавить, изменить или удалить стрелку в начале и конце выделенной соединительной линии, выберите стрелку или вариант Нет в меню стрелок.
Изменение направления или пересечение соединительных линий
В большинстве случаев вы можете использовать поведение соединительной линии по умолчанию. Но бывают случаи, когда вам нужно самостоятельно задать направление и пересечение соединительных линий на своей схеме.
Совет
Используйте функцию Масштаб, чтобы лучше разглядеть мелкие детали и более точно управлять точками: Увеличить (нажмите клавиши ALT+F6), Уменьшить (нажмите клавиши ALT+SHIFT+F6) и Вписать в окно (нажмите клавиши CTRL+SHIFT+W).
Выполните одно или несколько из указанных ниже действий:
Чтобы соединить соединительную линию с другой соединительной линией, сначала добавьте ее к фигуре, а затем перетащите к нужной соединительной линии.
Чтобы изменить направление соединительной линии, выделите ее, а затем перетащите среднюю точку в новое положение.
Чтобы изменить положение соединительной линии с шагом в один пиксель, выделите соединительную линию, затем нажмите SHIFT+КЛАВИШИ СО СТРЕЛКАМИ в необходимом направлении.
Примечание
Сведения о создании дерева см. в статье Создание дерева.
Изменение цвета текста соединительной линии
- Выделите текст, цвет которого вы хотите изменить.
- На вкладке Главная ленты в группе Шрифт нажмите раскрывающуюся стрелку Цвет шрифта, а затем выберите цвет в коллекции.
Другие способы работы с точками соединения
В следующих разделах мы рассмотрим несколько способов управления точками соединения.
Совет
Используйте функцию Масштаб, чтобы лучше разглядеть мелкие детали и более точно управлять точками: Увеличить (нажмите клавиши ALT+F6), Уменьшить (нажмите клавиши ALT+SHIFT+F6) и Вписать в окно (нажмите клавиши CTRL+SHIFT+W).
Обзор точек соединения
Точка соединения — это специальная точка на фигуре, к которой "приклеиваются" соединительные линии и другие фигуры. После приклеивания соединительной линии или фигуры к точке соединения они остаются соединенными даже при перемещении одной из фигур.
Точки соединения становятся видимыми при попытке соединить две фигуры. Вы видите эти точки при наведении на фигуру инструмента "Соединительная линия" рядом с фигурой, а также при подведении соединительной линии к фигуре, у которой имеется точка соединения.
Примечание.
Приклеивать соединительные линии можно не только к точкам соединения. Их, как и линии, можно также приклеивать к маркерам, вершинам и контурам фигур. Дополнительные сведения см. в статье Диалоговое окно "Привязать и приклеить".
Использование соединений точка-точка или динамических соединений
В Visio для фигур доступны два вида соединений: точка-точка (иногда называемое статическим соединением) и динамическое. Для разных концов соединительной линии можно использовать разные типы соединения. Если вы используете Автосоединение или команду Соединить фигуры, для обоих концов соединителя применяется динамическое соединение. При выборе точки соединения соединительной линии с фигурой вручную вы можете задать тип соединения. Дополнительные сведения об использовании динамических соединений см. в статье Автоматическое выравнивание, автоматическое определение интервалов и изменение расположения фигур на схеме.
На схеме, показанной ниже, между фигурами A и C используется соединение точка-точка, и при перемещении фигуры C соединитель, выходящий из фигуры A, остается приклеенным к одной и той же точке. Фигура B, в свою очередь, соединена с фигурой C с помощью динамического соединения, поэтому при перемещении фигуры C соединитель прикрепляется к ближайшей точке соединения.
Показать иллюстрацию с анимацией
Создание соединения точка-точка
В случае соединения точка-точка соединительная линия остается приклеенной к определенной точке фигуры даже при ее перемещении или вращении.
- Перетащите точку соединения на первой фигуре к точке соединения на второй фигуре.
- После соединения фигур конечные точки соединительной линии становятся зелеными.
Создание динамического соединения
В случае динамического соединения при перемещении или вращении фигуры соединительная линия будет прикрепляться к точке соединения, ближайшей к ее началу.
- Расположите соединительную линию в центре первой фигуры и дождитесь появления зеленой рамки вокруг фигуры.
- Удерживайте нажатой кнопку мыши и перетащите указатель в центр второй фигуры.
- Когда вокруг второй фигуры появится зеленая рамка, отпустите кнопку мыши.
Добавление точки соединения на фигуру
Если фигура, к которой требуется приклеить соединительную линию, не имеет в нужном месте точки соединения, вы можете легко ее создать.
- Выделите фигуру.
- На вкладке "Главная" в группе "Инструменты" выберите
"Точка соединения". - Если точки соединения не видны, на вкладке Вид в группе Визуальные подсказки установите флажок Точки соединения.
- Нажав клавишу CTRL, выберите, куда нужно добавить точку соединения. Новая точка соединения автоматически выделяется после добавления.
- На вкладке " Главная " в группе "Инструменты " выберите инструмент "Указатель ", чтобы возобновить обычное редактирование.
Перемещение точки соединения на фигуре
Если точка соединения расположена неудобно, ее можно переместить.
- Выделите фигуру.
- На вкладке "Главная" в группе "Инструменты" выберите
"Точка соединения". - Если точки соединения не видны, на вкладке Вид в группе Визуальные подсказки установите флажок Точки соединения.
- Нажмите клавишу CTRL и перетащите точку соединения, которую вы хотите переместить.
- На вкладке " Главная " в группе "Инструменты " выберите инструмент " Указатель ", чтобы возобновить обычное редактирование.
Если не удается переместить точки соединения именно туда, куда требуется, попробуйте изменить параметры привязки. Дополнительные сведения см. в статье Регулирование силы привязки и ее отключение.
Удаление точки соединения
Иногда точка соединения мешает. В этом случае вы можете ее удалить.
- Выделите фигуру с точкой соединения, которую хотите удалить.
- На вкладке Главная в группе Инструменты выберите инструмент Точка соединения.
- Если вы не видите точки соединения, на вкладке "Вид" в группе "Визуальные подсказки" установите флажок "Проверка точек соединения".
- Выделите точку соединения, которую вы хотите удалить. Она станет пурпурной.
- Нажмите клавишу DELETE.
- На вкладке " Главная " в группе "Инструменты " выберите инструмент " Указатель ", чтобы возобновить обычное редактирование.
Скрытие точек соединения
Иногда, чтобы лучше разглядеть схему, вам нужно скрыть точки соединения.
- На вкладке Вид в группе Визуальные подсказки снимите флажок Точки соединения.
Добавление текста рядом с точкой соединения
Добавить текст непосредственно к точке соединения невозможно. Однако можно добавить текст к фигуре, а затем поместить его рядом с точкой соединения.
Выделите фигуру, на которую хотите добавить текст, и начинайте ввод текста. Вводимый текст появляется на фигуре.
Выберите Главная \ Инструменты \ Инструмент Блок текста
( Ctrl + Shift + 4 ). Будет выбран блок текста.
Перетащите блок текста, чтобы переместить его и измените его размер, при необходимости
Выберите инструмент "Указатель" (CTRL+1), если вы хотите выйти из инструмента "Блок текста".
Другой способ – создание нескольких фигур с уникальными названиями, каждая с одной соединительной точкой, с их последующей группировкой для создания большей фигуры. Точки соединения по-прежнему будут использоваться.
Точка соединения типа "внутрь", "наружу" или "внутрь и наружу"
Используйте точки соединения "внутрь" и "наружу", чтобы управлять "притягиванием" конечных точек соединительных линий к фигурам.
Выделите фигуру.
На вкладке "Главная" в группе "Инструменты" выберите
"Точка соединения".Если точки соединения не видны, на вкладке Вид в группе Визуальные подсказки установите флажок Точки соединения.
Если вы хотите использовать точку соединения типа "наружу" или "внутрь" & "наружу", щелкните ее правой кнопкой мыши и выберите:
- Внутрь Чаще всего используется точка соединения типа "внутрь". Она "притягивает" к себе конечные точки соединительных линий, а также точки соединения типов наружу и внутрь и наружу на двумерных фигурах.
- Наружу Чтобы приклеить двумерную фигуру к другой фигуре, используйте точку соединения типа «наружу». Точка соединения типа "наружу" "притягивается" к точкам соединения типа "внутрь".
- Внутрь & наружу Если у вас есть фигура и вы не знаете, каким способом ее следует приклеить к другим фигурам, возможно, вам потребуется использовать точку соединения типа "внутрь" & наружу".
См. также
Добавление и изменение текста соединителя
Добавление соединительных линий между фигурами
Включение и выключение приклеивания
Создание пользовательской соединительной линии
Добавление и удаление значков пересечения соединительных линий
Все, что нужно знать о соединителях в классической версии Visio (блог команды разработчиков Visio)