Проблема
После установки обновления безопасности (SU) Microsoft Exchange Server ноября 2024 г. (версия 1 или версия 2) возникают проблемы при обработке Exchange Server сведений и файлов, связанных с календарем, таких как ICAL или .ics вложения. В этом случае вы не сможете просмотреть файлы или добавить их в календарь.
Эта проблема возникает при использовании Outlook в Интернете (OWA) и почтового клиента Exchange Active Sync (EAS) на мобильном устройстве. Кроме того, эта проблема может повлиять на службу транспорта Exchange при обработке сообщений электронной почты с файлами ICAL или .ics.
Если Exchange Server не обрабатывает сведения календаря, он создает записи журнала событий, например один из следующих примеров:
w3wp#MSExchangeOWAAppPool,M.Exchange.Net, M.E.E.ExIanaTimeZoneProvider+Cache.AddTimeZone, M.E.ExchangeSystem.InvalidTimeZoneException
Microsoft.Exchange.ExchangeSystem.InvalidTimeZoneException: Time zone id already exists
Причина
Эта проблема возникает из-за того, что Exchange Server использует дубликат записи в файлеIanaTimeZoneMappings.xml.
Временное решение
Чтобы удалить повторяющиеся записи, используйте одно из следующих обходных решений.
Способ 1
Выполните действия, описанные в разделе Remove-DuplicateEntriesFromIanaMappings.
Способ 2
-
Сохраните файл IanaTimeZoneMappings.xml, расположенный в следующей папке:
<ExchangeInstallationPath>\Microsoft\Exchange Server\V15\Bin -
Откройте файл с помощью Блокнота или другого текстового редактора и найдите следующую запись (она отображается два раза):
<Карта IANA="Азия/Бишкек" Win="Центральная Азия Standard время" /> -
Удалите одну из двух записей, а затем сохраните файл.
-
Откройте окно PowerShell с повышенными привилегиями и выполните следующие команды:
Restart-Service -Name W3SVC, WAS -Force
Restart-Service -Name MSExchangeTransport
Состояние
Корпорация Майкрософт подтвердила, что эта проблема затрагивает продукты, перечисленные в разделе "Применимо к". Корпорация Майкрософт активно работает над решением проблемы в будущем обновлении.