Проблемы
Рассмотрим следующий сценарий.
-
Клиент веб-прокси обеспечивает безопасное подключение SSL к внешнему веб-серверу с помощью сервера с Microsoft Forefront Threat Management Gateway 2010.
-
HttpS inspection is not involved. Таким образом, устанавливается конечный SSL-туннель между клиентом и веб-сервером.
-
При таком подключении клиент загружает данные на веб-сервер.
-
Подключение и поток TCP к веб-серверу медленные.
В этом случае отправка в определенных случаях завершается неправильно.
Причина
Эта проблема возникает после того, как клиент успешно отправляет все свои данные на TMG-прокси-сервер, клиент делает это, даже если прокси-сервер TMG еще не отправил все данные на веб-сервер назначения из-за медленной пропускной способности между TMG-прокси-сервером и веб-сервером назначения.
В этом случае прокси-сервер TMG неправильно обрабатывает буфер напоминания, который отправляется на веб-сервер назначения, а подключение TCP закрыто.
Решение
Чтобы устранить эту проблему, установите пакет обновления, описанный в следующей статье базы знаний Майкрософт:
2555840 Описание Пакет обновления 2 для Microsoft Forefront Threat Management Gateway 2010Note, чтобы включить этот hotfix, необходимо запустить сценарий setProxySocketSendBufSize.vbs на сервере со шлюзом Forefront Threat Management Gateway 2010.
Чтобы мы запускали сценарий setProxySocketSendBufSize.vbs для вас, перейдите в раздел"Исправить для меня" Если вы хотите создать и запустить сценарий самостоятельно, перейдите в раздел"Самостоятельноерешение проблемы".
Помощь в решении проблемы
Чтобы устранить эту проблему автоматически, нажмите кнопку или ссылку "Исправить". В диалоговом окне "Загрузка файла" нажмите кнопку "Выполнить" и следуйте шагам мастера Fix it (Мастер исправления).
Примечания
-
Возможно, мастер доступен только на английском языке. При этом автоматическое исправление подходит для любых языковых версий Windows.
-
Решения по устранению проблем можно скачать на любой компьютер, а затем сохранить их на устройство флэш-памяти или компакт-диск и запустить на нужном компьютере.
Затем перейдите в раздел"Проблема была исправлена?"
Самостоятельное решение проблемы
Чтобы создать и запустить сценарий, выполните следующие действия:
-
Запустите программу Блокнот. Для этого нажмите кнопку "Начните", выберите "Выполнить", введите notepad.exe в поле "Открыть" и нажмите кнопку "ОК".
-
В новый файл Блокнота в можете ввести следующий сценарий:
Const SE_VPS_GUID = "{143F5698-103B-12D4-FF34-1F34767DEabc}"
Const SE_VPS_NAME = "ProxySocketSendBufSize"
Const SE_VPS_VALUE = 8192
Sub SetValue()
' Create the root object.
Dim root ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")
'Declare the other objects that are needed.
Dim array ' An FPCArray object
Dim VendorSets ' An FPCVendorParametersSets collection
Dim VendorSet ' An FPCVendorParametersSet object
' Obtain references to the array object
' and the network rules collection.
Set array = root.GetContainingArray
Set VendorSets = array.VendorParametersSets
On Error Resume Next
Set VendorSet = VendorSets.Item( SE_VPS_GUID )
If Err.Number <> 0 Then
Err.Clear
' Add the item
Set VendorSet = VendorSets.Add( SE_VPS_GUID )
CheckError
WScript.Echo "New VendorSet added... " & VendorSet.Name
Else
WScript.Echo "Existing VendorSet found... value- " & VendorSet.Value(SE_VPS_NAME)
End If
if VendorSet.Value(SE_VPS_NAME) <> SE_VPS_VALUE Then
Err.Clear
VendorSet.Value(SE_VPS_NAME) = SE_VPS_VALUE
If Err.Number <> 0 Then
CheckError
Else
VendorSets.Save false, true
CheckError
If Err.Number = 0 Then
WScript.Echo "Done with " & SE_VPS_NAME & ", saved!"
End If
End If
Else
WScript.Echo "Done with " & SE_VPS_NAME & ", no change!"
End If
End Sub
Sub CheckError()
If Err.Number <> 0 Then
WScript.Echo "An error occurred: 0x" & Hex(Err.Number) & " " & Err.Description
Err.Clear
End If
End Sub
SetValue -
В меню "Файл" выберите пункт"Сохранить как" и сохраните сценарий setProxySocketSendBufSize.vbs.
-
В меню "Файл" выберите "Выход", чтобы выйти из Блокнота.
-
Дважды щелкните VBS-файл, сохраненный на шаге 3.
Проблема устранена?
-
Проверьте, устранена ли проблема. Если устранена, пропустите дальнейшие инструкции, приведенные в этом разделе. Если нет, обратитесь в службу технической поддержки.
-
Мы ценим ваши замечания. Чтобы оставить отзыв или сообщить о проблемах с этим решением, оставьте комментарий в блоге«Fix it for me»или отправьте нам сообщение электронной почты.
Статус
Корпорация Майкрософт подтверждает наличие этой проблемы в своих продуктах, которые перечислены в разделе "Применяется к".
Ссылки
Дополнительные сведения о терминах, используемых при описании обновлений программного обеспечения, см. в указанной ниже статье базы знаний Майкрософт.
824684 Стандартная терминология, используемая при описании обновлений программных продуктов Майкрософт