Внимание! Статья содержит сведения о внесении изменений в системный реестр. Перед внесением изменений рекомендуется создать резервную копию системного реестра и изучить процедуру его восстановления. Дополнительные сведения о создании резервной копии, восстановлении и изменении реестра см. в следующей статье базы знаний Майкрософт:

256986 Описание реестра Microsoft Windows

Проблема

При использовании приложений Microsoft Office, перечисленных в разделе «Информация в данной статье применима к» данной статьи, могут возникать следующие проблемы:

  • Изменения рабочей области документа в Microsoft Word не сохраняются при закрытии приложения. К таким изменениям относятся следующие:

    • Создание макроса.

    • Изменение шрифта по умолчанию.

    • Добавление элемента автотекста.

    • Добавление панели инструментов.

  • При повторном запуске Word элементы, которые были добавлены или изменены, отсутствуют.

    Примечание. Подобное поведение наблюдается даже при установленном флажке Запрос на сохранение шаблона Normal.dot.

  • При попытке запустить одно из приложений Office появляется следующее сообщение об ошибке:

    visual c++ runtime error

    Microsoft visual c++ runtime library

    Program files\Microsoft office\office10\имя_продукта.exe

    This application has requested the runtime to terminate it in an unusual way.

  • При открытии документа Word появляется следующее сообщение об ошибке:

    Недостаточно памяти или места на диске. Невозможно отобразить требуемый шрифт.

  • Программа Word закрыта, и пользователь дважды щелкает файл, чтобы открыть его в Word. В данном случае программа Word перестает отвечать на запросы (зависает).

Причина

Данная проблема может возникать после установки приложений Adobe Acrobat 7.0 Professional, Adobe Acrobat 7.0 Standard или Adobe Acrobat 7.0 Elements.

Acrobat 7.0 устанавливает надстройку COM в следующей папке:

\Acrobat 7.0\PDFMaker\OfficeЭта надстройка COM обеспечивает поддержку значков PDFMaker и команд меню для приложений Office.

Временное решение

В зависимости от ситуации, воспользуйтесь для решения проблемы одним из следующих способов. Если при закрытии Word не сохраняются изменения, воспользуйтесь способом 1 или 2. Если при попытке запуска одного из приложений Office или открытия документа Word появляется сообщение об ошибке, воспользуйтесь способом 3 или 4.

Способ 1. Сохранение макросов, предпочтений и пользовательских настроек с помощью команды Сохранить все меню Файл

Примечание. Этот способ не применим для Microsoft Office Word 2007.

Чтобы вручную сохранить макросы, предпочтения и пользовательские настройки в программе Word 2003 или более ранних версиях, выполните следующие действия.

  1. Нажмите и удерживайте клавишу SHIFT.

  2. В меню Файл выберите команду Сохранить все.

Изменения сохранены. Кроме того, эти изменения будут доступными в других документах Word.

Способ 2. Добавьте команду Сохранить все

В программе Word необходимо использовать команду Сохранить все каждый раз при создании макроса, предпочтения или изменения настроек.

Для добавления команды Сохранить все в Word выполните одно из следующих действий.

  • В Word 2007 выполните следующие действия, чтобы добавить команду Сохранить все на панель быстрого доступа.

    1. Нажмите кнопку Microsoft Office, затем выберите Параметры Word.

    2. Нажмите кнопку Настройка.

    3. В поле Выбрать команды из выберите Все команды.

    4. В списке Выбрать команды из выберите Сохранить все, затем нажмите кнопку Добавить.

    5. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Параметры Word.

  • В Word 2003 и более ранних версиях Word выполните следующие действия для добавления команды Сохранить все в меню Файл.

    1. В меню Сервис выберите команду Настройка.

    2. На вкладке Команды в группе Категории щелкните Файл.

    3. В группе Команды перетащите команду Сохранить все в меню Файл. После того как меню Файл будет открыто, поместите команду Сохранить все на желаемое место.

    4. Закройте диалоговое окно Настройка.

Способ 3. Обратитесь в компанию Adobe

Обратитесь в компанию Adobe Systems Incorporated за сведениями о наличии обновления для Acrobat 7.0.

Контактные данные компании Adobe Systems Incorporated можно найти в соответствующей статье базы знаний Майкрософт.

65416 Список адресов независимых поставщиков оборудования и программного обеспечения, A – K

60781 Список адресов независимых поставщиков оборудования и программного обеспечения, L – Р

60782 Список адресов независимых поставщиков оборудования и программного обеспечения, Q – ZКонтактные данные независимых производителей предоставлены в данной статье с целью помочь пользователям получить необходимую техническую поддержку. Эти данные могут быть изменены без предварительного уведомления. Корпорация Майкрософт не дает гарантий верности приведенных контактных данных сторонних производителей.

Способ 4. Удаление надстройки Adobe из пакета Office

После удаления надстройки Adobe сохранение файлов в формате PDF (Portable Document File) в приложении Office будет невозможным.

Для удаления надстройки Adobe выполните следующие действия:

Примечание. Указанные ниже действия могут различаться в зависимости от версии операционной системы Microsoft Windows, установленной на компьютере. В этом случае см. инструкции в документации к продукту.

  1. Закройте все программы.

  2. Нажмите кнопку Пуск и выберите в меню Настройка пункт Панель управления.

  3. Дважды щелкните значок Установка и удаление программ.

  4. В списке Установленные программы выберите Adobe Acrobat Professional 7.0 и нажмите кнопку Изменить.

  5. Выберите команду Изменить и нажмите кнопку Далее.

  6. Разверните узел Create Adobe PDF.

  7. Разверните узел Acrobat PDFMaker.

  8. Щелкните стрелку рядом с Microsoft Office и выберите Не установлено.

  9. В мастере установки Adobe Acrobat Professional 7.0 нажмите кнопку OK.

  10. Закройте окно Установка и удаление программ.

Если после выполнения перечисленных выше действий проблема не будет устранена, удалите надстройку Adobe из реестра вручную.

Внимание! Перед удалением надстройки Adobe вручную обратитесь в компанию Adobe за дополнительными сведениями.

Предупреждение. Неправильное изменение параметров системного реестра с помощью редактора реестра или любым иным путем может привести к возникновению серьезных неполадок, требующих переустановки операционной системы. Корпорация Майкрософт не гарантирует устранения этих неполадок. Ответственность за результаты произведенных действий несет пользователь.

Для удаления надстройки Adobe вручную выполните следующие действия:

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите в командную строку regedit и нажмите кнопку ОК.

  2. Найдите и выделите следующий подраздел реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin

  3. В меню Файл выберите команду Экспорт, введите имя файла и выберите команду Сохранить.

  4. Щелкните правой кнопкой мыши параметр реестра PDFMaker.OfficeAddin и выберите пункт Удалить.

  5. Выполните действия 3 и 4, чтобы удалить параметры реестра, соответствующие надстройке, в следующих подразделах реестра:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin



    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook

  6. Закройте редактор реестра.

Дополнительная информация

По умолчанию программа Word использует глобальный шаблон (файл Normal.dotm в Word 2007 файл Normal.dot в Word 2003 и более ранних версиях Word). По умолчанию изменения, применяемые ко всем новым документам, сохраняются в глобальном шаблоне. Этого не происходит, если при сохранении изменений пользователь указывает другой шаблон. Acrobat 7.0 может запретить приложению Word автоматически сохранять изменения в глобальном шаблоне.

Дополнительные сведения об этой проблеме см. на следующем веб-узле Adobe:

http://www.adobe.com/support/techdocs/331259.html

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединение к программе предварительной оценки Майкрософт

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?

Что повлияло на вашу оценку?

Добавите что-нибудь? Это необязательно

Спасибо за ваш отзыв!

×